Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow connecting to the internet on startup


29 Jul 2012   #1

Windows 7 Ultimate x64
 
 
Slow connecting to the internet on startup

So I have a wireless connection at home which I use for my laptop. The problem is that quite frequently(not every time) when I start the laptop up it takes a long time for it to connect, which eventually ends with it not connecting at all. My solution for this is to restart the modem, but is there any way this can be avoided?

My System SpecsSystem Spec
.

29 Jul 2012   #2

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

Hello crisbeto and welcome to Seven Forums.

This is one of those problems that might take some heavy duty troubleshooting since it doesn't always happen. Some of the things that could affect internet connectivity could be the antivirus suite you're using, scheduled tasks running in the background like defrag, malware on the laptop, etc. Have you tried booting into Safe Mode with Networking to see if there's any difference in connection speed?

Advanced Boot Options

You may also want to go through these tutorials to see if you can isolate your problem.

Troubleshoot Application Conflicts by Performing a Clean Startup

Troubleshooting Steps for Windows 7

Another common problem is an outdated network driver. This Microsoft article goes into more detail.

Slow internet connection Windows 7 PC - Microsoft Answers

And some more general information regarding internet connectivity:

Why is my Internet connection so slow?
My System SpecsSystem Spec
29 Jul 2012   #3

Windows 7 Ultimate x64
 
 

About the scheduled tasks etc. I don't have those, I have also checked for malware and I have had that problem on 2 antiviruses( NOD32 and AVG). About the conflicting applications, I checked and there arent so many apps on launch(only the drivers+antivirus).
Also the network driver is the newest, according the driver scanning tool at the HP site.
The problem isn't exactly the connection speed, more that it some times it doesn't even connect(I get a yellow exclamation mark near the internet icon) until I restart the modem.
My System SpecsSystem Spec
.


29 Jul 2012   #4

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

How old is the modem and has the modem manufacturer provided any firmware updates specifically for Windows 7?
My System SpecsSystem Spec
29 Jul 2012   #5

Windows 7 Ultimate x64
 
 

Well it's quite new, I changed it when I got my laptop(around 1 and a half months ago) and no, it didnt come with any firmware updates, it was just plug and play.
My System SpecsSystem Spec
29 Jul 2012   #6

WIN7 x64 Home Premium SP1
 
 

Just to eliminate the simplest possibility, have you checked to see that the connection to the modem is seated tight?
My System SpecsSystem Spec
29 Jul 2012   #7

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

What is the specific make/model? Although rare, new items can occasionally leave the factory with problems.
My System SpecsSystem Spec
29 Jul 2012   #8

Windows 7 Ultimate x64
 
 

It's a CBN CH6640E.
My System SpecsSystem Spec
29 Jul 2012   #9

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

I found an owner's manual for your modem but unfortunately, it doesn't have much in the way of troubleshooting. In fact, under Contact Information (Overview in table of contents) it says: "For any questions or assistance with the CH6640E / CG6640E Wireless Gateway, contact your Internet Service provider."


http://www.ono.es/resources/files/ay...%20English.pdf
My System SpecsSystem Spec
29 Jul 2012   #10

Windows 7 Ultimate x64
 
 

I got a feeling its more of a windows problem, than a hardware one. Ive got some friends on the same ISP and they dont have problems like this. One thing that i just remembered is that when i got my laptop there were several types of network drivers and i had to guess which one to install. After i found the proper one i unistalled all the others, but there may be some leftovers. Is there any way this could be the source of the problem?
My System SpecsSystem Spec
Reply

 Slow connecting to the internet on startup




Thread Tools



Similar help and support threads for2: Slow connecting to the internet on startup
Thread Forum
Very slow startup and opening files and Internet Performance & Maintenance
internet slow connecting at every boot(yellow triangle) Network & Sharing
Network slow to initialize on startup, slow system Network & Sharing
Very slow startup no Internet General Discussion
Internet not connecting on startup Network & Sharing
Slow Internet connection Initialization on Startup Network & Sharing
Problem connecting to internet only at startup Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:24 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33