Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: new build only connects to internet when connected to modem

30 Jul 2012   #1
reinise

win 7
 
 
new build only connects to internet when connected to modem

my newly built pc only connects to the internet when directly connected to the modem. when connected to the Linksys WRT54G, the internet does not work and there are no status lights on the ethernet port on my computer. however all other computers and devices, wired and wireless, all work with the router. my new computer is the only one that doesnt work with the router.
i have:
1. reset the router and the modem
2. updated all drivers
3. checked to make sure the cable is good and the port on the router is good (they're both good, i use this ethernet cord and router port for my xbox and it works fine.)
4. DNS and DHCP are enabled
5. i've worked on this crap for 3 days now so ive done a lot more trouble shooting than this, i just cant remember everything.

any help would be much appreciated, thanks!


My System SpecsSystem Spec
.
30 Jul 2012   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

The obvious solution is to update the firmware on your WRT54G. You need select the correct hardware version for either of these.

Linksys WRT54G

The latest DDWRT firmware will also work and has more options in the firmware for networking.
Router Database | www.dd-wrt.com
My System SpecsSystem Spec
30 Jul 2012   #3
reinise

win 7
 
 

good idea, i think that's the only thing i haven't tried. however, when i tried it, it failed every time. i tried other versions just to see, and they all failed. i also tried the DDWRT thing, it also failed.
My System SpecsSystem Spec
.

30 Jul 2012   #4
reinise

win 7
 
 

I also called my ISP, they knew nothing and were of no help. I also called Linksys, they knew even more nothing than my ISP. so that was a wasted hour.
My System SpecsSystem Spec
Reply

 new build only connects to internet when connected to modem




Thread Tools




Similar help and support threads
Thread Forum
Cable connected to modem, ipv6 no internet access ipv4 no network
Hello Guys, I've been searching for the past 2 days a solution, but nothing came up to work. Tried different things, nothing good yet. So I'm directly connected to a modem, cable, and well, my computer takes time to identify and then identifies it first a a public network (i was able to...
Network & Sharing
PC connects to router instead of modem.
I was wondering if anyone had any tips for me. I have my internet such that my internet is coming directly from my modem to my PC. I have a network cable going from my modem to wireless router as well so I can get wi-fi for my other devices. My PC, for whatever reason automatically connects to my...
Network & Sharing
Connects with DSL Modem - Not with Cable Modem
My uncle has an HP all in one unit Omni running Home Edition SP1 64 bit that connects using a cable modem. The other day it stopped connecting and Ipconfig displayed an invalid IP address - 169 something. I brought his unit home and connected it to my DSL modem. Immediate connection. IP...
Hardware & Devices
modem connected but no internet - error message 105
Hey, basically I've just moved house and the internet isn't working. We have a modem that's connected to a pc with an Ethernet n there is a laptop co-nected wireless. Connections between comp n modems are good but modem to internet isnt. When loading ie or Chrome a message comes up 105 unable to...
Network & Sharing
Router connects, but cable modem is unidentified.
Hey there. I'm wanting to connect my PC straight to my cable modem, but the only way for me to connect to the net is through my router. For some reason, when I connect my cable modem via ethernet straight to my PC, it isn't identified. Help please?
Network & Sharing
Connected to Modem but no Internet
This keeps happening after long periods of the machine being powered off. I will boot the machine and the network connection icon will tell me there is No Internet, but I can still connect to the modem. I've been just rebooting the machine to get internet again. It hasn't failed to reconnect on...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App