Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot get D Link DIR 615 to work with Windows 7

04 Aug 2012   #11
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Red Raspberry View Post
I have to have static for my wireless Ethernet Internet connection that comes from the antenna on my roof.

But need to revert back to auto when the router is connected.
That's a new one on me LOL. Never heard of such a set up. I'm wondering why all this wasn't explained to begin with.


My System SpecsSystem Spec
.
04 Aug 2012   #12
Red Raspberry

Windows 7 Pro 64 bit
 
 

I have the router connected to the internet by setting my providers static IP address. And am seeing the router through the pc. But the pc will not connect to the internet through the router This is as far as I always get no matter if it is my laptop on XP or the dresktop with Win 7.

On my laptop it connects to the wireless connection from the router but the browsers will not connect to the internet.
My System SpecsSystem Spec
04 Aug 2012   #13
Red Raspberry

Windows 7 Pro 64 bit
 
 

What is really aggravating is I had an earlier version of a D Link and it got hit by lightening. This one has never connected as it should.

So let me clarify if I may....

My internet signal is an ethernet signal that comes from the antenna on the roof. It requires a static IP address. It works when plugged directly into the PC ethernet port and when the static address is applied under the adapter settings for IPv4.

I can set the router to this static IP address and the router sees the internet.

I then set the PC IPv4 settings to auto.

The PC does not see the internet.
My System SpecsSystem Spec
.

04 Aug 2012   #14
tman69

win7 ultimate 32bit
 
 

there is no mention of a MODEM in any of your posts--the DIR 615 'requires' a modem to connect to the internet (see attached from DIR 615 user manual)--if I'm understanding your connection it is meant for ONE computer only (connected directly)--the router is acting only as a switch, without a modem you will NOT get an internet connection.

who is your ISP? and what country are you in? the direct connection from an antenna makes me think you're in asia...


Attached Thumbnails
Cannot get D Link DIR 615 to work with Windows 7-capture.jpg  
My System SpecsSystem Spec
04 Aug 2012   #15
Red Raspberry

Windows 7 Pro 64 bit
 
 

Quote   Quote: Originally Posted by tman69 View Post
there is no mention of a MODEM in any of your posts--the DIR 615 'requires' a modem to connect to the internet (see attached from DIR 615 user manual)--if I'm understanding your connection it is meant for ONE computer only-connected directly
My incoming ethernet is the modem. And it will work through a wireless router. In fact it is working now at the router. But the PC when connected with an ethernet cable to the router or the laptop when connected to the router through a wireless connection will not connect to the internet through the browsers.
My System SpecsSystem Spec
04 Aug 2012   #16
tman69

win7 ultimate 32bit
 
 

take a look at the 'setup' help section of your router--it should help you to setup your WAN (these screnshots are for a DIR 655 but the theory is the same)


Attached Thumbnails
Cannot get D Link DIR 615 to work with Windows 7-capture.jpg   Cannot get D Link DIR 615 to work with Windows 7-capture1.jpg  
My System SpecsSystem Spec
05 Aug 2012   #17
Red Raspberry

Windows 7 Pro 64 bit
 
 

Again, the router sees the internet. When connected to the router with a wireless connection the Internet connection is there as reported by windows in XP. But the browser(s) do not connect.

When the Win7 machine tries to connect through an ethernet cable it sees nothing.

The Internet light on the router is active. The port for the Ethernet cable is active.

The DIR 645 (I think) was what I had before and it connected OK. I wonder if the problem is inherent in the 615 model? It has the latest factory firmware, E3 v5.10.
My System SpecsSystem Spec
05 Aug 2012   #18
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

What is the make and model of the modem?
My System SpecsSystem Spec
05 Aug 2012   #19
Red Raspberry

Windows 7 Pro 64 bit
 
 

I don't have a modem. All I have is an antenna, I assume some sort of ethernet converter that terminates with an Ethernet cable coming into the house.

This is wireless long range Internet service that normally plugs into the ethernet port.
My System SpecsSystem Spec
05 Aug 2012   #20
Red Raspberry

Windows 7 Pro 64 bit
 
 

This is what I had and worked but it got hit by lightening. D-Link Rangebooster N Dual Brand Router. It is difficult to get screen shots of what is going on as I have to keep manually changing the IP address to get back on the internet when the Internet connection is directly connected to the PC.
My System SpecsSystem Spec
Reply

 Cannot get D Link DIR 615 to work with Windows 7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
D-Link wireless adapter won't work at logon
I have and HP Compaq with a D-Link DWA-130 wireless adapter. Lately, when I boot the computer the D-Link connection manager opens and I have to reconnect the adapter before I can get online. I have to reenter the SSID and the password. Then it works fine until I boot the computer again and...
Network & Sharing
Link will not work in Thunderbird.
A similar problem to frodo23’s post but somewhat different though. I have a problem with a Thunderbird installation on Win 7. For a gift my 13 year old grandson is receiving a used laptop, I am the administrator and he is the second standard user. I am having trouble with Thunderbird...
Browsers & Mail
How do I get an Xtel Hi-Fi Link to work in Windows 7?
Hello, how do I get my Xtel Hi-Fi link to work on Windows 7? I've looked all over the internet and cannot find any info on how to resolve this problem. I've tried uninstalling the USB Audio Device and rebooting as reported on the Xtel home page and that has not worked. The Hi-Fi Link Info: ...
Sound & Audio
link does not work?
I use IE, and hotmail. When I get noticed from seven forum in my mail, I clicked a link to thread, but that does not work.
Browsers & Mail
.pub extension and link do not work
Always this arcane discussion goes right by me: I see many possible helpful entries and would like to participate. Kudos to you all. Seems those who participate already know and us dummies dont know where to start or posit. I want to open a file from aunt Aileine about muffin recipe. it is...
General Discussion
'Change Mouse Pointers' link does not work
will the repair install fix system links that do not worK? cursor choices show up in Cursors file in Windows. Problem is after installing windows 7 Professional the link to the mouse pointers does not work and if you go to mouse properties they are not there just the mouse driver details. Any ideas...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App