Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Intermittent wifi problem on netbook Sony Vaio VPCM120AB. Also, no WPS

09 Aug 2012   #1

Different versions in different machines
 
 
Intermittent wifi problem on netbook Sony Vaio VPCM120AB. Also, no WPS

A friend's netbook with Windows 7 Starter got a virus hard to remove, so it's time to format and reinstall everything. After reinstalling Windows 7 Starter 32-bit and properly validating it with the serial on the tag under the notebook (which is strangely different from the serial I stripped from the registry), updated everything, installed and validated Office with original S/N, installed a few other essentials (MSE, Chrome, Adobe Reader, drivers from Sony website (but NOT the bloatware programs), 7-zip, etc) and installed linux in dual boot. Connected normally to my home router and I didn't see any problems with connection dropping, but wouldn't connect to my friend's wifi using windows - which is strange, because it always used to connect to it with no problems and no other smartphone/pc has problems connecting to it. It would tell me "wrong password" as soon as I hit enter, seemingly without checking wifi's password. I had no problems connecting when booted to linux, though.
Then I brought it back home, reinstalled everything from the start, re-updated everything, etc. While in windows, the netbook disconnected once from my home's wifi and would show a "red X" over the network icon, which I assumed to be because I was updating drivers, installing stuff, etc, so I just rebooted and everything worked normally. But this time Windows 7 still wouldn't connect to her network, despite linux would connect normally. After fiddling with her router a little, I did manage to connect to it by disabling WPS, but now the wifi connection keeps dropping for no apparent reason and the "red X" over the networking icon shows, and no wifi networks are shown.
To make matters even more strange, I plugged an external usb-to-wifi adapter and it would work normally even when I had the "red X" while using the internal wifi board, but (iirc) it still wouldn't work with the router when wps was enabled.
So, WPS wouldn't work at all and internal wifi would fail sometimes, which is solved by rebooting. Even while internal wifi was on "fail state", external wifi would work normally; not a hardware problem because everything works under linux.
I would assume this is due to some file corruption, but it doesn't make much sense because windows should make some CRC check of its files when installed. Windows 7 DVD is in decent condition, altough not completely scratch-free, just minor scratchs. Tried to manually remove and reinstall the driver, also downloaded a driver update from Sony's website but it didn't solve anything.
Checking on "Administrative Tools", I could see the log I've attached (change extension to .evtx). It seems there's some problems with ODBC, also some SQL query, and sometimes the registry takes too long to update. I have no clue what could be causing these symptoms and how they could be interfering with wifi, though.

Any ideas? Requests for more info? Any clue on how can I get a new Windows 7 DVD (preferably free, since I already have the serial)? :P



Attached Files
File Type: doc eventos administrativos.doc (1.07 MB, 7 views)
My System SpecsSystem Spec
.

10 Aug 2012   #2

Different versions in different machines
 
 

Well, 22 hours waiting, guess now I can "up" this.
My System SpecsSystem Spec
21 Aug 2012   #3

Different versions in different machines
 
 

Please?
My System SpecsSystem Spec
.


07 Sep 2012   #4

Different versions in different machines
 
 

It SEEMS I have PARTIALLY resolved the issue. After fiddling with older drivers and wireless networks managers with no results, I had the idea to disable all energy saving features of the wifi adapter via Device Manager -> Network Adapters -> right-click in the Ralink (RT3090 i guess) adapter -> Properties -> Energy Management -> untick the box saying the computer can disable the adapter to save energy, or change the "energy saving mode" under the Advanced tab. I guess the wifi card was deactivated when the network got idle, but for some reason couldn't be re-enabled. I could re-enable it a couple times by disabling it on Device Manager and then enabling it again, but sometimes this wouldn't work IIRC.
Another thing I did was to disable the bluetooth network adapters, which I thought might be influencing something, and I don't care enough about them to re-enable them and see if they actually make any difference.

I still can't connect to WPS networks and THIS ISSUE IS STILL NOT SOLVED, but at least connection seems to have stopped dropping all the time for the few hours I've been using it after modifying the settings.

EDIT: well, f***. The problem is still happening, but takes a bit longer to happen. When it happens, though, it seems to be harder to solve than before. My friend even said the problem persisted through reboots.

Trying to reinstall a different version of windows seven from the same DVD but with a different DVD drive. Also cleaned the DVD with rubbing alcohol.

EDIT2: reinstalling windows solved nothing. However, installing both the wifi driver and wifi driver update from Sony website fixed the problem partially, allowing to connect to wps-enabled router and the connection seemed to have stopped dropping. However, after a few weeks, connection started dropping again and things got gradually worse to a point it was unusable for more than a few minutes.
My System SpecsSystem Spec
21 Nov 2012   #5

Different versions in different machines
 
 

I could narrow down the problem to Ralink adapters. After testing with internal and external (usb) wifi adapters, I realized I had this issue with all adapters using Ralink chipset. I've just installed a Broadcom one salvaged from a HP DV6000 and apparently the issues are gone. It was not trivial to switch the internal wifi adapter though, because the original one is very small (3x2.7cm) and I could only find longer ones (3x5cm, I guess). No modifications were needed besides some insulating tape, but I couldn't screw it so it might get loose if someone drops the netbook. For now it seems to do the trick. I'll update this in case things go wrong again.

I'm not marking this as solved because this is a workaround, not a solution. I should have been able to make the original adapter work after all, shouldn't I?
My System SpecsSystem Spec
07 Dec 2012   #6

Windows 7 Starter
 
 

My sister's netbook has this issue too. It's frustrating the dickens out of me. Can anyone offer some other suggestions?
My System SpecsSystem Spec
14 Dec 2012   #7

Different versions in different machines
 
 

At last! I'm not the only one with this issue! Thought I was going crazy or being extremely incompetent.
My System SpecsSystem Spec
28 Dec 2012   #8

wins7 starter
 
 

Hi,

I too have a Vaio netbook with intermittent wifi connectivity. Very annoyed by this.

I've tried turning off the power setting in the adapter, reinstalling the adapter, etc, etc.

Today I gave up and went and bought a Belkin micro n300 usb adapter. Seemed to be working fine, then bang... off again. I swap to the Wireless Lan card ("in-built") a few times, and both went on and off every now and then.

I then stayed with the in-built (disabled the Belkin) and fiddled with its settings. I found that the 802.11n mode was not enabled.... so I switched it on.

Now both (Belkin and in-built) seem to be working fine. I keep swapping from one to the other. I will stay with the in in-built on for the rest of the evening and see.

So to recap... my 2 cents: aside from the power saving option "off", "enable" 802.11n....and pray.
My System SpecsSystem Spec
04 Jan 2013   #9

wins7 starter
 
 

Update: I continued to use the Belkin USB, no problem at all. So I've given up trying to solve the Windows 7 WiFi.
My System SpecsSystem Spec
21 Jan 2013   #10

Different versions in different machines
 
 

Good thing you also managed to work around the problem! Apparently the issue happens only with some chipset manufactureres (I could narrow it down to Ralink in my case). Can you please confirm which chipset does your original network adapter and Belkin adapter use? (probably shown if you type "Device Manager" on start menu, go to item "network adapters" and then right-click on properties)
My System SpecsSystem Spec
Reply

 Intermittent wifi problem on netbook Sony Vaio VPCM120AB. Also, no WPS





Thread Tools



Similar help and support threads for2: Intermittent wifi problem on netbook Sony Vaio VPCM120AB. Also, no WPS
Thread Forum
Sony vaio problem Drivers
Solved how to turn on Wifi in sony Vaio Network & Sharing
Problem Regarding Wifi in sony Vaio laptop Network & Sharing
WiFi Driver on Sony Vaio VPCF11M1E - F Series Drivers
SONY VAIO GVN-I problem BSOD Help and Support
Sony VAIO W Netbook? Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:56 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33