Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Local Host runs so slow on Windows 7

13 Sep 2009   #1
chobo2

Windos 7 Pro 32 bit, Windows 7 Ultimate 32 bit
 
 
Local Host runs so slow on Windows 7

Hi

I switched from Xp to Windows 7 Pro. Since then I noticed when I run my website(asp.net mvc) in local host it goes so so slow(I mean like 10 to 20seconds per page).

This should not be. I then tested it with sloppy to mimic a user of 256kb and it loads up alot faster(maybe 2-3seconds at most).

I then changed my localHost to 127.0.0.1 and it goes super faster. It just when I use localHost it goes this slow.

Anyone got any ideas why this is happening?


My System SpecsSystem Spec
.
13 Sep 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 

chobo

We need your system specs (lower left corner) so we know what hardwarey ou have and what is the network setup like?

Ken
My System SpecsSystem Spec
13 Sep 2009   #3
chobo2

Windos 7 Pro 32 bit, Windows 7 Ultimate 32 bit
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
chobo

We need your system specs (lower left corner) so we know what hardwarey ou have and what is the network setup like?

Ken
Ok I put my hardware specs up.
My System SpecsSystem Spec
.

13 Sep 2009   #4
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by chobo2 View Post
Hi

I switched from Xp to Windows 7 Pro. Since then I noticed when I run my website(asp.net mvc) in local host it goes so so slow(I mean like 10 to 20seconds per page).

This should not be. I then tested it with sloppy to mimic a user of 256kb and it loads up alot faster(maybe 2-3seconds at most).

I then changed my localHost to 127.0.0.1 and it goes super faster. It just when I use localHost it goes this slow.

Anyone got any ideas why this is happening?
Chobo have you disabled IPv6 support in network and sharing?

Ken
My System SpecsSystem Spec
13 Sep 2009   #5
chobo2

Windos 7 Pro 32 bit, Windows 7 Ultimate 32 bit
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
Quote   Quote: Originally Posted by chobo2 View Post
Hi

I switched from Xp to Windows 7 Pro. Since then I noticed when I run my website(asp.net mvc) in local host it goes so so slow(I mean like 10 to 20seconds per page).

This should not be. I then tested it with sloppy to mimic a user of 256kb and it loads up alot faster(maybe 2-3seconds at most).

I then changed my localHost to 127.0.0.1 and it goes super faster. It just when I use localHost it goes this slow.

Anyone got any ideas why this is happening?
Chobo have you disabled IPv6 support in network and sharing?

Ken
I don't think so. Should I?
My System SpecsSystem Spec
13 Sep 2009   #6
zigzag3143

Win 8 Release candidate 8400
 
 

yeah it has been known to cause random drops, and slow downs. cant hurt to disable it. It not been used yet. also rdc (remote desktop compression) and WMP sharing service.

Is this wired or wireless? does it have encryption?

One way to find out where the slow down is is to run a traceroute. go to ping-probe.com download its free app and run it. it will look like this. you can also ping your router from a cmd prompt. I suspect the slowdown is local (like between you pc and router)

Let me know if you need help

Ken
My System SpecsSystem Spec
13 Sep 2009   #7
logicearth

Windows 10 Pro (x64)
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
...rdc (remote desktop compression)...
It is Remote Differential Compression, and it is never used except with Offline Files.
My System SpecsSystem Spec
13 Sep 2009   #8
chobo2

Windos 7 Pro 32 bit, Windows 7 Ultimate 32 bit
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
yeah it has been known to cause random drops, and slow downs. cant hurt to disable it. It not been used yet. also rdc (remote desktop compression) and WMP sharing service.

Is this wired or wireless? does it have encryption?

One way to find out where the slow down is is to run a traceroute. go to ping-probe.com download its free app and run it. it will look like this. you can also ping your router from a cmd prompt. I suspect the slowdown is local (like between you pc and router)

Let me know if you need help

Ken
I am not sure how to use it. I tired to do a traceroute and it said it can't be resolved.

I am using wired and I don't think it has encryption. I did a ping to my router and it takes about 1ms for reply.


Where can I disable Ip6 to try that?
My System SpecsSystem Spec
21 Sep 2009   #9
PeterS

Windows 7
 
 

Hi Chobo2,

Do you have this problem also in IE? Firefox has a known problem with locahost for asp.net development. Check out this post about it: Fixing Firefox Slowness with localhost on Vista (or XP with IPv6) - Dan Wahlin's WebLog
My System SpecsSystem Spec
Reply

 Local Host runs so slow on Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Laggy and choppy video playback; Windows runs very slow
All was well with my computer and one fine day video playback became very laggy and choppy. Also the computer in general slowed down considerably. My first thought was that there had been a virus attack and hence I ran a thorough scan. Nothing showed up. So formatted the whole system and installed...
Music, Pictures & Video
Windows boots very slow and runs slow after booting
Hello 7forums. I have a problem with my Windows 7 Professional (32bit). I'll try to explain everything in detail. Yesterday I was using uTorrent to download some files (24 gigabytes +). It was downloading at a speed of ~7-8 Mb/s. During the download I noticed that the PC was running pretty...
Performance & Maintenance
Computer runs really slow in normal mode, but runs fine in safe mode
I recently re-formatted my Sony VAIO since it was starting to run super slow. Now that I re-installed Windows 7 on it through recovery disks, it worked fined for about a day but then the problem came back. The computer is slow at bootup and runs super slow while freezing so many times. I am running...
BSOD Help and Support
Received from local host 127.0.0.1 ???????
I've been plauged by trojans and worms in spoofed emails with forged headers. So, I now at least look at the email headers now, even if I do not understand all of it - I had this in the header of 2 emails today: "from localhost ( helo=sfs-ml-2.v29.ch3.sourceforge.com) by...
Browsers & Mail
Runs slow after a few days.
Hi guys, I guess it's time to ask for help in this one. I bought myself a new laptop around 2 years back, and it hasn't exactly worked out. For the first year, everything went well, was pleased with and everything was dandy. Around February time though, things turned bad. After booting up quite...
Performance & Maintenance
Windows 7 Runs Slow, Freezes, Can't Reboot
** THIS PROBLEM HAS BEEN SOLVED, SEE SOLUTION AT THE BOTTOM...THANKS AGAIN! ** Hello all, First time poster here, having some problems with my Windows 7 install. Ever since this evening, about 15 minutes into my Windows 7 session, I notice that it starts running slower (mostly in any web...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App