Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: nt kernal & system 25% CPU usage, internet lags

23 Aug 2012   #1
M18XR2

window 7 64 bit
 
 
nt kernal & system 25% CPU usage, internet lags

4c/8t processor uses 25% of its cpu to this nt kernel & system. system lags a bit but barely and what hit me was the internet speed. i went to speakeasy for speed test and im still getting the usual 15mbps, but when i game online it constantly lag and got me thinking its something to do with my wifi.

i only have wifi internet installed so i only have wifi internet, LAN and bluetooth disabled and uninstalled. i went to task manager, right-click nt kernal and select "go to services" but shows no services so i do not know what i could disable or the cause of this issue.

several things i have tried: (im using driver off intel/manufacture website)
- hard restart (issue reoccurs randomly after several hours, or sometimes 1-2 hrs)
- fresh windows, installing all drivers correctly in order and issue reoccur again
- remove internet wifi driver, reinstall it and issue occurs again

now i am currently beat and dont know how to proceed, please help!


My System SpecsSystem Spec
.
24 Aug 2012   #2
M18XR2

window 7 64 bit
 
 

ok i found a tutorial video on how to use xperf thats found here "blogs.msdn.com/b/ntdebugging/archive/2010/03/22/using-xperf-to-root-cause-cpu-consumption.aspx"

i follow the tutorial but in the end it asks me to search online for the issue anyway. root of my problem "NT Kernel & System" seems to be ntkrnlmp.exe!KiIdleLoop under stack process in xperf, and ntoskrnl.exe under function process. i search it up and finding exe file under windows/system32.. what should i do now? to be honest i think deleting it would be a bad idea but this problem occurs so much at least once a day if i were to leave computer on for 10+ hours, which i normally do.
My System SpecsSystem Spec
15 Jan 2013   #3
M18XR2

window 7 64 bit
 
 

sorry for the late bump, up until early last month I still have this issues on two of my laptop and now problems all solved. turned out to be almost drivers related, either conflicts or just program compatibility issue, or conflict with firmware/bios.. pretty strange.

both of my Dell laptop have Hwinfo64 fan control running and both had compal EC enabled as the option in Hwinfo64. from my m18x after I turned off compal EC the problem went away, however issue stayed with my other Dell n5110 laptop which turned out in the end I had to reinstall graphic driver provided by dell instead of using nvidia latest graphic drivers.
My System SpecsSystem Spec
.

Reply

 nt kernal & system 25% CPU usage, internet lags




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
NT Kernal and System BSOD help
An importent note: I'm legally blind and use a screen reader. It's a lot harder to troubleshoot when you can't read anything anymore, so please bare with me. A few weeks ago I noticed some odd flashing single squares randomly popping up on my monitor. Also had some distorted sound. Sort of like...
BSOD Help and Support
Freezes, lags and sometimes BSOD when connecting to Internet
Ok, Im having this problem since yesterday, I left my computer on so i can finish my download(i nap a bit) when i woke up, my computer started to lag and freeze to the point that i cant use it(Sometimes it BSOD),,,,This only happens when i connect to internet,,When i reboot normaly without...
BSOD Help and Support
Port 80 PID 4 NT Kernal & System processes
Hi there, I have a question regarding what processes or services run on Port 80. I am trying to run XAMPP Apache virtual web server and Apache fails to start because a system process is listening on port 80. Apache needs to run on port 80. I had "thought" i fixed the error when I ended the...
General Discussion
Internet Explorer 8 lags terribly with more than 1 tab.
I have completely reformatted and reinstalled my windows 7 OS on a new quad-core 4GB computer. internet explorer 8 continues to lag badly and use up nearly 100% cpu when more than one tab is opened. is the browser really that bad, or is there another possible problem? i am totally OK with...
Browsers & Mail
CPU usage spikes (100%) and windows lags terribly
I have a Dell inspiron e1505. 2 gb RAM. Essentially I am getting seemingly random spikes in my cpu usage where it ramps up to 100% and windows basically freezes for an extended period of time. Sometimes I simply have 1 google chrome tab open with no other apps actively running in the...
Performance & Maintenance
Kernal Power System
I decided to upgrade from Windows XP32 bit to Windows 7, and after it locked up on me a couple of times once during a restart it would not let me type my password in . I found this Kernal Power System error I dont know what it is or If that has anything to do with it Locking up on me or not . Im...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App