Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: One PC Keeps Getting Limited Connectivity after 5 min

13 Sep 2012   #1
perfectgravity

Ontario
 
 
One PC Keeps Getting Limited Connectivity after 5 min

I just got the WNDR4500 and set it up yesterday. Everything works great except one annoying issue: I have one PC that keeps getting limited connectivity and i have to release/renew the ip to fix it (or power cycle the switch). This happens after 3-5 min. The other devices stay connected even though they are after the switch.

I have my network set up as follows: Cable modem connecting to the router. Router wired connection to PC1, Network Printer. I have a wired connection from the router to a switch in my living room. From the switch there are wired connections to PC2(the one with the limited connectivity issues), a network storage, and PS3.

Everything stays connected, even the PS3 and the network storage, except for PC2. PC2 drops from the internet and the LAN, and the Netgear no longer sees it as a connected device until I release/renew on the PC.

With my old Asus router everything works, with the same PC and the same switch so the issue is with the router. The new router is gigabit, so not sure if that's part of the issue. I'm using a combo of Cat5/5e so maybe switching to cat6 will help?

I tried setting a static IP for PC2, and DCHP. That did not make a difference.

I tried leaving the router with everything defualt, and upgrading to the latest firmware.

I also tried uninstalling the network card on PC2 and re-installing, although I did not check if there was an upgrade to the NIC.


My System SpecsSystem Spec
.
13 Sep 2012   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

This thread talks about problems with the WNDR4500 and shows some solutions that might work for you.

WNDR4500 loses WAN connection - NETGEAR Forums
My System SpecsSystem Spec
13 Sep 2012   #3
perfectgravity

Ontario
 
 

Quote   Quote: Originally Posted by chev65 View Post
This thread talks about problems with the WNDR4500 and shows some solutions that might work for you.

WNDR4500 loses WAN connection - NETGEAR Forums
Thanks, I saw that already. They are mentioning that the Internet disconnects but the Lan is still active and that it happens to all the PCS after 30 min of inactivity. It seem like the issue was fixed by the new firmware.

For me it happens while i am using the pc, only on one PC, and the LAN drops out too not just the internet connection. I tried the Disable IGMP Proxying and using OPEN DNS as the DNS servers.
My System SpecsSystem Spec
.

13 Sep 2012   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

It seems like the problem is more with the switch. If the switch isn't a gigabit switch then it might help to go into Device Manager and make some adjustments to the network interface for this connection. Maybe the 10/100 setting will work better.
My System SpecsSystem Spec
14 Sep 2012   #5
perfectgravity

Ontario
 
 

Okay so I did some more troubleshooting last night.

I disconnected all the other devices so I had the New router connected to PC2 directly with a cat6 cable (no switch). The exact same thing kept happening.

I downloaded the NIC drivers and reinstated them on the PC. I also messed around the speed and duplexing option selecting various settings on the NIC (100 full duplex, 10 half duplex, etc.)

I tried a static IP again, and DHCP, with open DNS servers.

I also tried to have a wireless device connected at the same time. When the LAN drops for PC2 the wireless device has internet connectivity with no issues.

Nothing worked, I have no idea what's going on now.
My System SpecsSystem Spec
14 Sep 2012   #6
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Have you tried starting up in safe mode with Networking to see if an installed program or an A/V might be causing the problem?

You could also try Autoruns to determine if a start up program is causing the problem. You can uncheck them one at a time to see which one makes a difference.
Autoruns for Windows
My System SpecsSystem Spec
18 Sep 2012   #7
perfectgravity

Ontario
 
 

I kept reading on the Netgear forum and the current firmware had a bug where it would send out wake on Lan packets to the network non-stop. I guess this cause my one PC to drop the connection.

I updated to the new firmware they release yesterday .1.20 and the PC stays on the network just fine now. Thanks for your help
My System SpecsSystem Spec
19 Sep 2012   #8
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Ok good, figured it was the router from all the complaints about it.
My System SpecsSystem Spec
Reply

 One PC Keeps Getting Limited Connectivity after 5 min




Thread Tools




Similar help and support threads
Thread Forum
limited or no connectivity
בס''ד hi experts i have 17 computers network that suddenly all of them tell me "limited or no connectivity". what can i do except of: 1. give manual ip addresses. 2. disable DHCP rauter's server. 3. anti virus, combofix, anti maleware. 4. check physical connecyions. i dont think its...
Network & Sharing
Limited Connectivity
"Problem with the driver for Wireless Adapter" I have an HP-Pavilion 2009f with Windows 7 home premium 64-bit. All has been fine with my internet connection, except for a few drops here and there, but all in all it has been tolerable. When I went to bed last night it worked, when I woke up, it...
Network & Sharing
Limited Connectivity?
So I have a laptop and a PC. My PC is connected to the router/modem by a cable, and I'm using wireless on my laptop. Everything's fine except when I start using wireless on my Nokia C7, suddenly on the laptop there's LIMITED CONNECTIVITY. I usually restart the router and it works, but it's very...
Network & Sharing
Limited or no connectivity
First let me state that I am running win7 pro on my desktop and my laptop is XP Home I have a linksys wireless router.. Now last year I was running Vista Pro on my desktop and had no problem connecting to the internet with same laptop, this year when I try to connect with the laptop I get Limited...
Network & Sharing
Limited Connectivity
I installed windows 7 32-bit RC on my PC yesterday and all is fine, except for my connection. Whenever I try to connect to my Wireless network, it says there is 'limited or no connectivity'. All my WEP settings are correct and the diagnostic said that the IP Config was wrong. What to do?
Network & Sharing
Limited Connectivity
100% of the time, I have limited connectivity for my wireless network. I have a Netgear WG311v3 wireless card in my Dell E510 desktop and a Netgear WGR614v6 router. I get a perfect connection with Windows XP but the limited connectivity in windows 7. Any Suggestion?
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App