Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: acer Laptop running windows 7 losing wireless connection and freezing

13 Sep 2012   #1

windows 7 home premium
acer Laptop running windows 7 losing wireless connection and freezing

Evening guys. i have the following problem :

Acer aspire 5750 laptop ( about 9 months old )
wireless internet with 'excellent' signal strength on internet
windows 7 home premium

the problem i'm getting is that constantly now the laptop losing its internet connection (goes to limited connectivity) or cannot connect then when i try troubleshooting/diagnosing/open the network center as soon as i run the troubleshooting etc the laptop freezes then the only way it will work again is to turn it off and back on, i would then get an internet connection again, sometimes for half an hour but often no more than five minutes.

I'm pretty sure the wireless Internet is not the issue as the fault occurs exactly the same at

My house
Girlfriends house
and has also happened when using a friends wireless at his place
so the same internet connection fault occurs at three separate connections which leads me to believe its the laptop playing up .

any ideas, help or checks i could do would be great .
thanks in advance

My System SpecsSystem Spec
14 Sep 2012   #2

Windows 7 Pro x64

Some common issues I have found to resolve similar type issues are:

1. Update network driver
2. Delete network profiles and remake them
3. run a "netsh winsock reset" from command prompt
4. Update Bios, may be a PCI communication error?
5. Replace wifi card (under warranty?)
6. Run a virus scan, somthing like Offline defender, good sucess with this, or Kaspersky rescue disc.
My System SpecsSystem Spec

 acer Laptop running windows 7 losing wireless connection and freezing

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Acer Laptop freezing on startup
I bought my Acer Laptop a few years back and now every time I start it up it freezes on the Windows Logo screen (or on a black screen with safe mode startup) and I can't seem to fix it! All I can do is press F2 to see the boot setup which doesn't give me anything to fix it. Does anyone have any...
General Discussion
System running win7 losing time on my Acer 8930G laptop
I was hoping that someone may be able to provide some advice re a small problem I have. Since my laptop died and I've rebuilt it. The time is not correct on it. When I power on the laptop the time is wrong and I then reset it to the correct time. If I leave it on for a few hours it seems to...
Hardware & Devices
Laptop keeps losing connection with new Dlink router
I have a customer that has just installed a new Dlink N300 router and cable modem internet. He has both a desk top which is hardwired to the router and a laptop which is using the wireless. The desk top does not have any problem with a connection but when he buts the laptop in hibernation it can...
Network & Sharing
Acer Aspire running Windows 7 won't find an internet connection
My Acer Aspire running Windows 7 and using an ethernet cable can't find an internet connection. It was working fine then I downloaded a pre-loaded version of Microsoft Office 10 suites and the next time I tried to get online the connection was gone. I didn't download the Office from the internet...
Network & Sharing
Losing Wireless Connection After Reboot
Hello, I need help. I have win7HP 64-bit AsusU45 laptop. Whenever i turn On, restart my laptop, i lost the wireless connection. I tried updating my NIC, its showing updated. I tried disabling/reenabling it, still no good. This is a brand new one i bought so i don't know if there is a WLAN software,...
Network & Sharing
Windows 7 Ultimate - Losing wireless connection
I used a Linksys WUSB54GC device on my same system when I was running Vista 32 bit. I did a clean install of 7 64 bit and my wireless was recognized fine, but it would lose connection after 45s or so and remain as such until the computer was restarted. I then updated the driver through windows...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:53.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App