Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HomeGroup not working, broken Networks/Sharing Console


14 Sep 2012   #1

Windows 7 Home Premium
 
 
HomeGroup not working, broken Networks/Sharing Console

I plagiarized the following from "Vista giving you a Server Execution Failed? - Page 2 - Networking - Xoxide Forum Network" which was an old post for Vista, but it worked perfectly for the broken HomeGroup problem in Windows 7. Apparently, something corrupts permissions and ownerships of some vital keys in the registry, which causes HomeGroup to stick it's head in the dirt. It's bit scary to watch some of this run, but just cover your eyes. It works. I was at the point of reloading Windows 7, but talked myself out of it at the last minute with some more searching. I'd also noticed that the network map was not displaying properly in the Networks and Sharing window, so I decided to search for "no network map onNetwork and Sharing center" in Bing, and voila, the link above showed up. I'm still not exactly sure what was broken, but another symptom was that I noticed that it was no longer complaining about having no active AV software or firewall. When I ran the third command line in step 3, both of those warnings popped up, which gave me pretty good indication something was getting better.

In addition to the steps below, I uninstalled McAfee Internet Security suite, turned off Windows Defender, and turned off Windows Firewall (I'm hiding behind TWO routers, so don't worry too much about security while I'm fixing things.)

1. Back up the registry. (DUH! You're about to overhaul the permissions)

2.Download and install SubinACL from

Download: SubInACL (SubInACL.exe) - Microsoft Download Center - Download Details

3.As an administrator, run the following commands from a command prompt (switch to the install directory for SubinACL first. Default is "C:\Program Files\Windows Resource Kits\Tools\" for 32-bit, and "C:\Program Files (x86)\Windows Resource Kits\Tools\" for 64 bit):

subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f

The first two commands can take considerable time to complete, however each command can be run in a separate window to save time. But what's your hurry?

3. After completing all four of the above commands you have to reapply the default security template by running the following command:

secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

4. Reboot.

My homegroup is back now, and I can go load my McAfee firewall and antivirus software.


Good luck


My System SpecsSystem Spec
.

Reply

 HomeGroup not working, broken Networks/Sharing Console




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33