Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Media devices can be seen from Win7 x86 but I cant from Win7 x64


30 Sep 2012   #1

Windows 7 Ultimate x64 and Windows 7 Ultimate x86
 
 
Media devices can be seen from Win7 x86 but I cant from Win7 x64

Hi,
To give you a brief description of my Home network setup:
1. I have a MSI Wind laptop running Windows 7 Ultimate x86
2. I have a HP DM1 laptop running Windows 7 Ultimate x64
3. A 3G Tenda router
4. A DLink DNS-320 NAS

So the other day I got myself a DLink DNS-320 from a local computer store because my two laptops are starting to fill up and my files are all over the place.After transferring all my from both laptops to the NAS. Both laptops are running so much slower than before so I decided to give both a "fresh start" and made a clean install on both. Everything went smoothly for both installations. Then I started discovering my new NAS and I discovered that aside from storing my files, it can also stream my media files, which is great! So I configured which files can be streamed to my Home network and everything is good to go.

Out of the fresh installed Windows 7 Ultimate x86 on my MSI Wind, when I go to Windows Explorer >> Network, I can see this: http://img.photobucket.com/albums/v2...ds/msiwind.png (FIleCenter is the NAS with UPNP on. UPNP is enabled is supported by my router too). When I clicked FileCenter in Media Devices, there was a quick installation of some sort then my Windows Media Player opened up and I noticed in the Library, there is a "FileCenter" library under the "Other Libraries". When I clicked it, I can see all the file I set as streamable. I even watched 3 streaming movies from my NAS just to give it a try. No glitch whatsoever.

So I turned my HP DM1 laptop running also on a clean installed Windows 7 Ultimate x64. I wanted to do the same setup with my MSI Wind that I can access my media files straight out of WMP. Now this is the part where I noticed something is different. When I go to Windows Explorer >> Network, I only see this:
http://img.photobucket.com/albums/v2...oads/hpdm1.png

I cant see a "Media Devices" column unlike with my MSI Wind. I opened my WMP and tried if it can detect the streaming from my NAS but the "FileCenter" library is not appearing either. I tried rebooting the HP DM1, nothing happened. I tried rebooting them booth, same thing: MSI Wind can detect and play my streaming media files without any problem but my HP DM1 cant. I can just see the NAS a part of my Home network (as shown in the picture) but no sign of streaming.Now I have them both on my table, connecting to the router thru wifi, but still, the scenario is the same. I didnt really changed anything from either laptops. I just installed their individual drivers. Please help.



Arjay

My System SpecsSystem Spec
.

01 Oct 2012   #2

Windows 7 Ultimate x64 and Windows 7 Ultimate x86
 
 

I finally found the culprit! Its my Nod32 Smart Security. It somehow blocks the discovery of these network media devices. A little tweaking on the Personal Firewall settings to make it less strict did it
My System SpecsSystem Spec
Reply

 Media devices can be seen from Win7 x86 but I cant from Win7 x64




Thread Tools



Similar help and support threads for2: Media devices can be seen from Win7 x86 but I cant from Win7 x64
Thread Forum
Imaging Win7 Pro SP1 onto 25 Identical Devices Backup and Restore
no longer see non win7 pcs, devices Network & Sharing
Streaming Recorded TV in windows media player from win7 to win7 Network & Sharing
Can Win7 power down USB devices not in use? Hardware & Devices
Devices not well configured !! help... (using hp/win7) Hardware & Devices
Connecting non-Win7 devices to homegroup Network & Sharing
Unrecognized devices after Win7 install Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:02 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33