Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 and LAN connection to Internet

23 Sep 2009   #1
John Duckworth

Windows 7 and XP
 
 
Windows 7 and LAN connection to Internet

I have a network at work with all pc's on windows XP.
It is connected with LAN Cables (No wireless)

One PC has a broadband modem (Not a router) which connects to the internet.

All other pc's can connect through this computer to the internet.

I have one free Lan cable and I used to connect my laptop to this and it would connect to the network and internet with no problem.

However I have upgraded my laptop from vista to Windows 7 and now whatever i do I am unable to connect to the internet through the pc with the modem.

I can "see" the other computers on the network, and even "see" the residential gateway device on the pc that connects to the network but whatever i do I can not now connect through that pc to the internet.

CAn anyone help please?

John


My System SpecsSystem Spec
.
23 Sep 2009   #2
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by John Duckworth View Post
I have a network at work with all pc's on windows XP.
It is connected with LAN Cables (No wireless)

One PC has a broadband modem (Not a router) which connects to the internet.

All other pc's can connect through this computer to the internet.

I have one free Lan cable and I used to connect my laptop to this and it would connect to the network and internet with no problem.

However I have upgraded my laptop from vista to Windows 7 and now whatever i do I am unable to connect to the internet through the pc with the modem.

I can "see" the other computers on the network, and even "see" the residential gateway device on the pc that connects to the network but whatever i do I can not now connect through that pc to the internet.

CAn anyone help please?

John
Hi and welcome John,

Can you provide a screenshot of the command prompt after typing:

ipconfig /all

Greetz
My System SpecsSystem Spec
23 Sep 2009   #3
John Duckworth

Windows 7 and XP
 
 

Hi Greetz ( and I love the pic of Amsterdam!)

I take it you would like a screenshot of the Windows 7 laptop rather that the XP machines?

I opened the "run" command and typed the command in and it looked like a msdos window opened up with various network details in it. However as soon as it finished it closed down. I tried to use the pause to "catch" it before it closed but despite several attempts I cant quite get it right.

Is there a way to keep the window open?

Many thanks

John
My System SpecsSystem Spec
.

23 Sep 2009   #4
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by John Duckworth View Post
Hi Greetz ( and I love the pic of Amsterdam!)

I take it you would like a screenshot of the Windows 7 laptop rather that the XP machines?

I opened the "run" command and typed the command in and it looked like a msdos window opened up with various network details in it. However as soon as it finished it closed down. I tried to use the pause to "catch" it before it closed but despite several attempts I cant quite get it right.

Is there a way to keep the window open?

Many thanks

John
lol, I see what went wrong, you typed it in the search bar, right?

what you need to do is type cmd in the searchbar.

this will open the command prompt without closing it.

then you type ipconfig /all and make the screeny.

good luck

and thanks for the compliment about the Amsterdam sig.
My System SpecsSystem Spec
25 Sep 2009   #5
John Duckworth

Windows 7 and XP
 
 

Greetz,

It worked and so now I attach a screenshot of the ipconfig as requested!

John


Attached Thumbnails
-screen-print.jpg  
My System SpecsSystem Spec
25 Sep 2009   #6
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by John Duckworth View Post
Greetz,

It worked and so now I attach a screenshot of the ipconfig as requested!

John
Hi John,

I notice the network card has no default gateway set.

The default gateway is the gateway to the internet and in your case, it must have the ip number of the computer that is connected to the internet.

On the other computers, do you have automatic or static IP settings?

And on the one that is not working? automatic or static?

I would recommend setting all the computers to static IP addresses.

That way you'll know exactly which IP is which computer, and they won't get steal each others IP when booted in different order.

Do you know how to set static IP's?

For default gateway ip and dns IP you have to type the IP address of the computer that is connected to the internet.

If you have any questions shoot.

Greetz
My System SpecsSystem Spec
Reply

 Windows 7 and LAN connection to Internet




Thread Tools




Similar help and support threads
Thread Forum
Connection OK, no internet access in windows 7
Hello everyone and thanks in advance for any help, I have searched for hours and tried any and all suggestions but I haven't been able to fix this, so here it is: Problem I have a good wifi connection but no internet access. Details I recently did a recovery on my Asus N53SV running...
Network & Sharing
USB internet connection works, Ethernet internet connection does not
OK. I'm trying to switch from wireless to a faster(?) ethernet cable based internet access. I use a Dell Optiplex 755, 32 bit OS, Windows 7. I'm the utilizing Comcast high speed internet supplier, a LinkSys E4200 wireless router, a LinkSys WUMC710 (wireless-ac universal media connector; with...
Network & Sharing
LAN connection without internet stops wireless internet connection
Well I've fiddled around and searched to no avail ... I have some form of conflict between my main wireless network and a LAN I use for file transfer and streaming. The attached PDF file illustrates the setup. Basically, the wireless network is fine by itself. Music streams from the...
Network & Sharing
Windows 7 SP1 causes slow internet connection
Hi, I formatted my 32bit Vista PC this weekend and loaded Windows 7 64bit on here. All fine, except my internet connection speed has now plummeted from around 15Mb to 8Kbps!! It's taken about 5 mins just to load this page :( I've Googled and there seems to be a lot of similar issues. I've...
Network & Sharing
no internet connection windows 7.
I have a dual boot setup with Windows xp2 and Windows 7. If I startup to Windows XP2 I have internet connection. If I then reboot to Windows 7, internet connection is retained. However if I startup into Windows 7, I cannot get internet connection no matter what. Any help appreciated.
Network & Sharing
Windows 7 RC internet connection problem.
windows 7 has always ran great until one day I got on my computer and it randomly said no connections available. iso i restarted. it didn't do anything. i did trouble shoot and said there was a driver issue. so i went into device manager and tried to mess with the driver. nothing. then i plugged...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:20.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App