Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet really slow on one laptop, runs fine on another


06 Nov 2012   #1

Windows 7 Home Premium x64
 
 
Internet really slow on one laptop, runs fine on another

Hello everyone,

I just got a new broadband line installed at home today. The thing is, at home we have two laptops (one is a Samsung 5 Series Ultra with Windows 7 Home Premium x64 and the other one is a MacBook) and an iPad.

Both the MacBook and the iPad don't have any issues when connecting to the Internet. However with the Samsung laptop (which unluckily happens to be mine, both the other things are my girlfriend's ), while I don't have any troubles when connecting to the wifi network (I even have full 5 bar signal and it says I'm connected to the internet at 150 mbps), when I try to load any website (even light ones, like Google or Gmail) it takes ages for my computer to do it, and most of the times they don't even load at all.

I don't know what could it be, since when I connect to other wifi networks (like at public places, or even when I use my cellphone as a hotspot) everything runs perfectly fine. That makes me think that the problem is with the router, however both the macbook and the iPad don't have the same issue at all so, on the other hand, the issue may lie within my computer.

Please help me! Thanks a lot in advance!

My System SpecsSystem Spec
.

06 Nov 2012   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

So you mean:
  • all other computer connected to you home router as working fast. Your laptop is slow as a snail. But it works!
  • Your latop is working fine if connect to another router/hotshot
Is that the situation?
My System SpecsSystem Spec
06 Nov 2012   #3

Windows 7 Home Premium x64
 
 

Yes, that's what happens.

EDIT: Oh, I forgot to add that even when the other devices are not connected to the router Internet on my laptop still runs really really slow.
My System SpecsSystem Spec
.


06 Nov 2012   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

My System SpecsSystem Spec
06 Nov 2012   #5

Windows 7 Home Premium x64
 
 

So slow the download doesn't even start and I got the message "This website is not available". But when I try to start the download connected to another network from this same laptop it runs good.
My System SpecsSystem Spec
06 Nov 2012   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Are ipad and imac also wireless connected to router.. so actually same config?
You got a broadband line today.... so it has never worked fast with this laptop?
My System SpecsSystem Spec
06 Nov 2012   #7

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by MichaelScarn View Post
So slow the download doesn't even start and I got the message "This website is not available". But when I try to start the download connected to another network from this same laptop it runs good.
Which other network...neighbours?
My System SpecsSystem Spec
06 Nov 2012   #8

Windows 7 Home Premium x64
 
 

Yes, the ipad and the Mac are connected to the same router through wireless. And no, this connection has never worked fast with this laptop (but I have only had it for approx. five hours).

What baffles me is that the connection worked perfectly on the iPad and the Macbook since the beginning.
My System SpecsSystem Spec
06 Nov 2012   #9

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by Kaktussoft View Post
Quote   Quote: Originally Posted by MichaelScarn View Post
So slow the download doesn't even start and I got the message "This website is not available". But when I try to start the download connected to another network from this same laptop it runs good.
Which other network...neighbours?
No, at public places like at cafes or when I share the internet from my cellphone.
My System SpecsSystem Spec
06 Nov 2012   #10

Windows 7 Home Premium x64
 
 

Just remembered that when I first connected to the network I was able to load a 1:00 YouTube video. But I never could do it again
My System SpecsSystem Spec
Reply

 Internet really slow on one laptop, runs fine on another




Thread Tools



Similar help and support threads for2: Internet really slow on one laptop, runs fine on another
Thread Forum
New laptops wireless inexplicably slow, everyother computer runs fine. Network & Sharing
Solved Slow Wireless Speeds - Laptop is fine, Desktop is SLOW Network & Sharing
Computer runs really slow in normal mode, but runs fine in safe mode BSOD Help and Support
Solved Laptop NBA 2k11 running slow when it was fine a few days ago Performance & Maintenance
Upgrade causing slow browsing, fine internet speed Network & Sharing
Laptop runs slow after a while Performance & Maintenance
installs fine, runs fine, reboots..not fine Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:58 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33