Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dual boot with Ubuntu 12.04 - Can't connect to internet on Win 7

14 Nov 2012   #1
MrPr3sid3nt

Windows 7 Home Premium 32bit
 
 
Dual boot with Ubuntu 12.04 - Can't connect to internet on Win 7

Hi, I am struggling to connect to the internet on Win 7 but can connect fine on Ubuntu 12.04

I have dualboot Win 7 and Ubuntu 12.04.
I can connect to the internet no problem in Ubuntu.
In Win 7 I can connect to my local network and it shows as having internet connection, but I can not browse the internet. I have tried running the following commands in cmd

netsh winsock reset catalog
netsh int ip reset reset.log hit

I have tried unplugging my router, running win7 network troubleshooter, resetting my wireless card.

I can not seem to find a solution, I don't know what is causing the problem.

Any help would be appreciated.

Thanks.


My System SpecsSystem Spec
.
14 Nov 2012   #2
Parman

Windows 7 Ultimate x64
 
 

Please provide the ipconfig /all output.


use option 2
My System SpecsSystem Spec
14 Nov 2012   #3
MrPr3sid3nt

Windows 7 Home Premium 32bit
 
 

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\D0CK3R>ipconfig

Windows IP Configuration


Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::e831:f496:1e0e:7412%12
Autoconfiguration IPv4 Address. . : 169.254.116.18
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.{4B023FA2-6C10-4FAF-A5F0-972F7CEF1BEC}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :


##############################################################

Exclamation mark in yellow triangle
Shown as unidentified public network

###############################################################



For comparison, this is the output of my Ubuntu when i type nm-tool into terminal



andy@Atlas:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: wlan0 [SKY25674] ----------------------------------------------------
Type: 802.11 WiFi
Driver: rtl8180
State: connected
Default: yes
HW Address: 00:06:4F:64:91:5E

Capabilities:
Speed: 48 Mb/s

Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points (* = current AP)
SKY2E733: Infra, 90:01:3B:82:E7:34, Freq 2437 MHz, Rate 54 Mb/s, Strength 41 WPA WPA2
SEC_LinkShare_cb0f70: Infra, 60:6B:BD:B2:61:34, Freq 2412 MHz, Rate 54 Mb/s, Strength 33 WPA2
BTHub3-2QJQ: Infra, 20:2B:C1:84:EF:81, Freq 2412 MHz, Rate 54 Mb/s, Strength 33 WPA WPA2
BTWiFi: Infra, 5A:2B:C1:84:EF:82, Freq 2412 MHz, Rate 54 Mb/s, Strength 40
BTWiFi-with-FON: Infra, 5A:2B:C1:84:EF:83, Freq 2412 MHz, Rate 54 Mb/s, Strength 32
*SKY25674: Infra, 4C:17:EB:92:56:75, Freq 2437 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2
Jiro1: Infra, 00:1CF:A2:A7:F6, Freq 2412 MHz, Rate 54 Mb/s, Strength 30 WPA WPA2

IPv4 Settings:
Address: 192.168.0.4
Prefix: 24 (255.255.255.0)
Gateway: 192.168.0.1

DNS: 192.168.0.1


- Device: eth0 -----------------------------------------------------------------
Type: Wired
Driver: r8169
State: unavailable
Default: no
HW Address: 00:1F0:8B:A0:5C

Capabilities:
Carrier Detect: yes

Wired Properties
Carrier: off


andy@Atlas:~$
My System SpecsSystem Spec
.

14 Nov 2012   #4
Parman

Windows 7 Ultimate x64
 
 

Im not sure if this has anything do to with the dual boot configuration. since you're receiving an IP address for the DHCP server on Ubuntu but not on windows. My first though that it might be a dhcp lease issue but i cant say 100%.
I would run the command ipconfig /renew from an elevated command prompt. When you turn CMD into the search bar right click on it and run as administrator.

Check with the manufacturer website for updated drivers.
My System SpecsSystem Spec
15 Nov 2012   #5
MrPr3sid3nt

Windows 7 Home Premium 32bit
 
 

I ran ipconfig /renew as suggested. Then I tried the network troubleshooter which came up with some errors, I have saved the diagnostics log but as it is an .etl file I don't know what to do with it! I recall it said something along the lines of not having a valid IP configuration. Is there some way to open .etl files? I thought that as it was a win file it would open by default when double clicking, but no such luck!
My System SpecsSystem Spec
15 Nov 2012   #6
Parman

Windows 7 Ultimate x64
 
 

Did you check with the manufacturers website for driver updates for the wireless card?
My System SpecsSystem Spec
19 Nov 2012   #7
MrPr3sid3nt

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by parman View Post
Did you check with the manufacturers website for driver updates for the wireless card?
OK, Thanks to Parman I have managed to solve this. I should have checked this before but it still doesn't seem to make total sense to me. For anyone else who encounters this problem, these are the steps I took:

1. Booted into Win 7, wrote down the driver version (RTL85n86.sys) and then deleted the driver.
2. Booted into Ubuntu, downloaded the driver from here Realtek 8185 Extensible 802.11b g Wireless Device Driver Download Version 6.1122.1016.2009 - Windows Driver Database - techETA
3. Booted into Win 7 again. At this point Win 7 reinstalled a driver for the wireless card, which still failed to work.
4. Ran the setup.exe from the file I downloaded, which installed the driver and the wireless utility
5. Internet now works
6. Tried to uninstall the wireless utility. This deleted the driver too so my internet didn't work again.
7. Installed just the driver from the pack I downloaded. Internet did not work.
8. Re-ran setup.exe, internet now works.

The part I can't seem to figure out is that the driver I had installed (RTL85n86.sys) is the same driver that is installed now!! Also, it doesn't seem to work without the utility installed.

I can live with the utility installed, I'm sure one of you guys could figure it out if you wanted to, but I'm just happy to have my system up and running properly.

Thanks for your help
My System SpecsSystem Spec
19 Nov 2012   #8
Parman

Windows 7 Ultimate x64
 
 

The driver could have just became corrupt. I'm sure the driver can be installed with out the utility. If you would like to me look into it let me know.

Glad your internet is working again.
My System SpecsSystem Spec
Reply

 Dual boot with Ubuntu 12.04 - Can't connect to internet on Win 7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Win 7 , Ubuntu dual boot, windows wont boot, startup disk doesnt help
Hi a couple of months ago my system crashed, windows 7 wouldnt boot, and I misplaced my installation disk. I had the problems several times since obtaining the computer several years ago. (Lenovo IDeaPad y450). I attributed the problem to what I believed was a bad hard disk, so I replaced it with a...
General Discussion
Dual Boot problem, Ubuntu is the main boot
hello I have Asus laptop with OEM Win7 HomeP 64bit on it, I installed Ubuntu 12.04 along side with Win7, didn't know that Ubuntu will be the main boot, I used Ubuntu 11.10 a year a go and Windows was my main boot, I tired several way to retrieve Win7 as main boot but didn't work. I tried to...
Installation & Setup
Cannot Boot Windows 7 after Uninstalling Ubuntu Dual-Boot
...
Installation & Setup
I have dual boot Ubuntu 11.04 and Windows 7 and now i cant boot Window
I have dual boot Ubuntu 11.04 and Windows 7 and now i cant boot Windows it says Windows can not start the installation process.
Installation & Setup
Unable to boot Windows 7 after unistalling Ubuntu Dual boot
After deleting the partition on which Ubuntu was installed and enlarging the windows partition to fill the old space at the same time( stupid I know), I am unable to boot to Windows 7. All I see is a command line message that says Unknown File System and on the next line says Grub Rescue> with...
Installation & Setup
dual boot w/ Ubuntu, need to uninstall Ubuntu
Hey all I am new here. I recently did a dual boot install of Ubuntu with my Home Premium Windows 7 machine. I need to figure out how to uninstall Ubuntu and the grub loader... any thoughts? I installed Windows 7 first... Ubuntu 64 desktop edition came after. I shrunk my Windows 7...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App