Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Homegroup troubleshoot

15 Nov 2012   #1

64bit
 
 
Homegroup troubleshoot

Hi,

I cannot leave my homegroup or change my passwords. I believe I have isolated the problem but can't fix it.

I am unable to enable/start the following homegroup services:
-peer network grouping
-peer name resolution protocal (not sure if this has anything to do with homegroup)

I receive the following error when I try to start the service:
error 1068 - Windows could not start the Peer Networking Grouping on Local Computer.

I've searched online and found recommendations to remove the idstore.sst file however I don't have access to the folder the troubleshoot points too C:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking
Unfortunately after LocalService there is no access to the "appdata" and subfolders necessary to complete this troubleshoot.

I searched how to solve the problem of not seeing the "appdata" folder and I accidently clicked on the "attributes" in the "localservice" folder "properties" and deselected the "show hidden" file attributes so now I'm unable to see the "localservice" folder at all as a result and I do not know how to make it reappear.

If someone could help me to get homegroup working it would be much appreciated. I just got a new computer and wanted to link the homegroup to my old computer. The homegroup does not function on my old computer and my old computer is the computer with all of my information.

Thanks!


My System SpecsSystem Spec
.

15 Nov 2012   #2

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

Welcome to sevenforums .
in an explorer window,click organize/folder and search options.
in the window that opens click the view tab and check the box to show hidden files and folders.
appadata can be found in your user folder then navigate from there,
remember to hide the folders again folowing the same steps and uncheck the show hidden ...
My System SpecsSystem Spec
15 Nov 2012   #3

Windows 7 Ult, Windows 8.1 Pro,
 
 

You may have run into my own page that describes how to fix this problem.
Homegroup Not Working

As was already mentioned you just need to go into, Control Panel> folder options and click to "show hidden files and folders" then you will be able to see the idstore.sst. Removing that file should allow you to start those services and leave the Homegroup.
My System SpecsSystem Spec
.


15 Nov 2012   #4

64bit
 
 

Thanks. I think I was able to find the idstore file and delete it.

I'm still not able to enable the Peer Networking Grouping service.

I've also tried to stop the services for
-homegroup listener
-peer name resolution protocol
-peer networking identity manager
-homegroup provider

After successfully stopping all process above I'm still not able to leave homegroup. Even after a reboot.

I suspect the problem is the inability to start/enable the peer networking grouping service but I cannot start it. I keep getting the error.
My System SpecsSystem Spec
15 Nov 2012   #5

Windows 7 Ult, Windows 8.1 Pro,
 
 

Threads like the one below are all over the internet, removing that rogue file usually fixes the problem as you can see but there are other reasons why that service may not start.
http://www.sevenforums.com/network-s...-protocol.html

This TechNet thread talks about the problem and shows another solution, third post down.

Can't start Peer Name Resolution Protocol

Another person further down fixed the problem like this.

Followed Novak Wu and Streetwolf suggestions, but no joy. Rebooted PC etc. Went back to the three services related to Peer Networking opened properties and went to the logon tab, clicked the Logon on as This account (second radio button), browse and select ADVANCED / Find, select "Local Service", OK, blank out the dots against the password and password confirm, click apply. Do the Peer Networking Identity Manager first, you have to stop and restart the service for it to take effect, then repeat the logon process for the other two services. Set all three to automatic. Hope it works for you.
My System SpecsSystem Spec
15 Nov 2012   #6

64bit
 
 

Ok thanks again for the help. The Novak Wu and Streetwolf suggestion did allow me to leave the homegroup.

Now I've been troubleshooting the fact that neither computer is noticing one another so I cannot join the 2 computers in one homegroup. They're both allowing me to create homegroup but not join homegroup.

After much more research I think the problem could be with my IPv6 connectivity because I do not have connectivity there. Just connecting on the IPv4. From what I've found they need to be connected to IPv6. I have confirmed that the IPv6 adapters are clicked on but for whatever reason there is no access.

Any suggestions now... Everytime I think i'm closer to solving this mystery a new turn unfolds. Windows be damned! LOL
My System SpecsSystem Spec
15 Nov 2012   #7

64bit
 
 

Figured it out! thank God! Problem was both the computer's had same name. Changed one of the names and now i can join the homegroup. Thanks again for all of your help.
My System SpecsSystem Spec
16 Nov 2012   #8

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by purplehaze23 View Post
Figured it out! thank God! Problem was both the computer's had same name. Changed one of the names and now i can join the homegroup. Thanks again for all of your help.
This not able to leave the Homegroup problem has been a bug for quite awhile now, I'm glad that Novac's advice helped. Usually deleting that idstore.sst file works but not always as you found out.

Yes the User names can be the same but not the machine names as you found out.

I'd say this is solved, thanks for reporting back in purplehaze.
My System SpecsSystem Spec
Reply

 Homegroup troubleshoot




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:29 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33