Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: The default gateway is not available problem

11 Dec 2012   #11
Protozoa

Windows 7 Ultimate 64bit
 
 

I am not wireless though, everything is hooked up.


My System SpecsSystem Spec
.
11 Dec 2012   #12
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Protozoa View Post
I am not wireless though, everything is hooked up.
The default gateway is showing up and the IP is valid and shows you as online so something appears to be blocking the connection. Could be Avast or something else.

If you can start up in safe mode with networking you may be able to determine if this problem is caused by an installed program or A/V software.

It sometimes helps to type in the default gateway into the IPv4 settings which in your case would be 192.168.100.1

The link below talks about this common problem and shows that there are many different causes and solutions which are talked about further down the page. You should go down the list and see if someone else's solution works for you.

http://pocketpccentral.net/blog/2009...blem-resolved/
My System SpecsSystem Spec
11 Dec 2012   #13
Protozoa

Windows 7 Ultimate 64bit
 
 

How do I do that Ipv4 setting thing exactly?

And would you recommend me reinstalling avast in this case or checking something about windows's own firewall?

Thanks.
My System SpecsSystem Spec
.

11 Dec 2012   #14
Protozoa

Windows 7 Ultimate 64bit
 
 

Now I'm losing my connection and getting it back all the time! my god this is annoying..

Edit: Ok I tried a couple of things and removing avast fixed it (for now, I still need to stress my connection to make sure). You think reinstalling will bring it back or might it have been just something corrupted in the programs settings?

Edit2: just got it again and avast was still uninstalled
My System SpecsSystem Spec
12 Dec 2012   #15
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Protozoa View Post
Now I'm losing my connection and getting it back all the time! my god this is annoying..

Edit: Ok I tried a couple of things and removing avast fixed it (for now, I still need to stress my connection to make sure). You think reinstalling will bring it back or might it have been just something corrupted in the programs settings?

Edit2: just got it again and avast was still uninstalled
It seems that Avast or just about any A/V software can and will destroy your internet connection, and they do so on a regular basis around here, wired or wireless doesn't seem to matter. I would uninstall Avast using it's special uninstall tool. Very frustrating for me as well.
http://www.avast.com/uninstall-utility

The link I posted shows where you would type in the Default Gateway, it might help although it shouldn't be required it has been known to fix this problem. I'll post a picture of where to type it, it's the same thing as setting a static IP, just switch to "Use the following IP" then type in the gateway, subnet, and IP which should be outside the DHCP range.

I would go with Msoft security essentials and use Malware Bytes for running scans.

If you are still having the connection problem, Type or copy each command one at a time into an elevated command prompt then hit "enter" after each one, then reboot your machine.


netsh winsock reset catalog (reset winsock entries)

netsh int ip reset reset.log hit (reset TCP/IP stack)

If uninstalling Avast doesn't work then try reading down the list in the link I posted to see if some of those solutions work for you, this is not a one size fits all type of problem, it can be many different causes.
http://pocketpccentral.net/blog/2009...blem-resolved/


Attached Thumbnails
The default gateway is not available problem-ipv4-properties.png  
My System SpecsSystem Spec
22 Dec 2012   #16
Protozoa

Windows 7 Ultimate 64bit
 
 

Thanks a lot for your help and it does indeed seem that avast was the culprit. I've now only had this problem 3 times(very random, no pattern to it) since I uninstalled it. I can't believe that such a legit software can do so much damage.
My System SpecsSystem Spec
22 Dec 2012   #17
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Protozoa View Post
Thanks a lot for your help and it does indeed seem that avast was the culprit. I've now only had this problem 3 times(very random, no pattern to it) since I uninstalled it. I can't believe that such a legit software can do so much damage.
This type of problem occurs with startling frequency using just about ANY third party A/V software.

I highly recommend using Windows defender or Windows security essentials.
My System SpecsSystem Spec
Reply

 The default gateway is not available problem




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Networking problem "The default gateway is not available"
I'm currently using windows 8.1 Pro, and the problem has gotten worse lately, so every minute or so, the internet stops working and when I diagnose the network it just keeps giving me "the default gateway is not available" error, and fixed, then another minute or so it happens again.
Network & Sharing
Internet suddenly stops working, problem with default gateway.
For the past few weeks I've been having this problem, the internet works fine and suddenly stops opening pages and disconnects me from any game I'm playing but it still says that it's connected. This happens maybe 10 times a day and when it does happen, I run the 'Diagnose' on LAN adapter and it...
Network & Sharing
default gateway problem
Everytime I wake up my laptop my internet is disconnected. I run my troubleshooter and I get a message "The default gateway is not available. Running my troubleshooter fixes the problem, but it is a huge pain in the a**. I have a WD N900 wireless router set up on a WPA2-personal network. I have...
Network & Sharing
My default gateway is 0.0.0.0 how do i change my default gateway
to forward a port i typed my default gateway in the browser then i got this pageIP Address Lookup - Home page at the top right corner there was a login field wherei tried to login without having an account i tried .I tried five times and each time i failed.after five times the webpage banned me for...
Network & Sharing
Wireless Default Gateway problem
Hello, I'm having a problem with a wireless network, it's a public network, however I am pretty sure only a few people use it. I get it at random times, but happens quite often. Internet will cut off pretty often, with a 5 bar signal, and when I repair I get "Default Gateway is not available"....
Network & Sharing
the default gateway problem
Hi, I'm new on this forum I tried to look like a problem but I found, so I decided to make a new top. Today I installed Windows starter version 7 and I have a problem with internet connection .. I have static IP, enter my IPs and when I give error like the picture is "the default gateway is not on...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App