Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Connections not showing in Network and Sharing Center

21 Nov 2012   #1

Windows 7 64 bit
 
 
Connections not showing in Network and Sharing Center

Hi,

So for a little background I think this started when I connected my PC to my laptop with an Ethernet cable to attempt to use my laptop as a network adapter because my PC adapter wasn't working (fixed now). Anyway ever since then something has obviously messed up and now in the Network and Sharing Center it no longer shows anything next to "Connections", also in the task tray the icon for my internet has changed to this (see picture below), it still connects to the internet fine but for some reason shows that icon. I'd really appreciate any help I could get as I keep running into problems which I can't solve because of this.

Thanks, Adam.




My System SpecsSystem Spec
.

21 Nov 2012   #2

Windows 7 Ult, Windows 8.1 Pro,
 
 

That red X indicates that you have an Ethernet adaptor that isn't plugged in. If you don't need that connection then you can disable the Ethernet connection in Device Manager, reboot the machine after disabling and check to see that the red X is gone.
My System SpecsSystem Spec
21 Nov 2012   #3

Windows 7 64 bit
 
 

Thanks for the reply, I tried disabling "Realtek PCIe Family Controller" and restarted my machine however nothing has changed, any other suggestions?
My System SpecsSystem Spec
.


21 Nov 2012   #4

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by AdamPC View Post
Thanks for the reply, I tried disabling "Realtek PCIe Family Controller" and restarted my machine however nothing has changed, any other suggestions?
Maybe if you can show me the missing connection stuff you were referring too.
My System SpecsSystem Spec
21 Nov 2012   #5

Windows 7 64 bit
 
 



You see next to "Connections" there is nothing there, as opposed to my laptop which says "Wireless Network Connection (home)" and you can then click that which takes you to the Wireless Network Connection Status so you can look at your properties and what not.
My System SpecsSystem Spec
21 Nov 2012   #6

Windows 7 64 bit
 
 

Screen shot

Heres the picture in case it didn't show in the last reply as it didn't on my screen.
My System SpecsSystem Spec
22 Nov 2012   #7

Windows 7 Ult, Windows 8.1 Pro,
 
 

Yes I see the problem now. I'm not sure what caused this but try saving the file below, unzip and run the file, your machine will reboot automatically. This will reset everything related to winsock and the network stack.

After the automatic reboot please post a screen shot of your ipconfig/all from this machine.


Attached Files
File Type: zip IPResetALL.zip (33.6 KB, 49 views)
My System SpecsSystem Spec
22 Nov 2012   #8

Windows 7 64 bit
 
 

Hi, thanks for the reply, I ran the IPResetALL program, here is a screenshot with the info from ipconfig/all .
My System SpecsSystem Spec
23 Nov 2012   #9

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by AdamPC View Post
Hi, thanks for the reply, I ran the IPResetALL program, here is a screenshot with the info from ipconfig/all .
Everything looks good with the ipconfig.

Someone else had a similar problem the other day with the red X showing up for no apparent reason, in his case it went away after disabling the Ethernet connection and several reboots.

If you can get a screen shot of Device Manager with network adaptors expanded and with the View Tab choose "show hidden devices" it may help me to stop what is causing this problem.
My System SpecsSystem Spec
23 Nov 2012   #10

Windows 7 64 bit
 
 

Yeah I know it's a real annoying issue and not a very common one either so it's bugging me, here is my device manager, not sure if you wanted to see more of the plug and play stuff, I can screenshot the rest if you like, thanks.
My System SpecsSystem Spec
Reply

 Connections not showing in Network and Sharing Center




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:48 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33