Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SubnetMask Reg Value Not Corresponding With Interface Properties GUI


07 Dec 2012   #1

Windows 7 Professional x64
 
 
SubnetMask Reg Value Not Corresponding With Interface Properties GUI

Hi All,

I am trying to manually change the subnet mask for a particular interface by using the key HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}\SubnetMask. If I delete the data for this value everything works fine. However, if I then go to the interface configuration GUI (Network and Sharing Center > Change Adapter Settings > *Right Click Interface* > Properties > IPv4 > Configure) and change the mask there, all it does is append the new mask on a new line of the multi-string value listed above. That's all fine, but now if I try to add a new mask to that reg value on a new line, the GUI still registers the old one. I did a search in the registry for the old (now current) mask and it only appears in 3 places. I tried updating all 3, but nothing changes the GUI or registers under cmd > ipconfig /all.

This really isn't that big of an issue, but it seems to me like the GUI registers the mask as a second (third, fourth, etc.) IP instead of making it the sole mask.

Will having 2 or more in the list at that reg location cause any errors anywhere else? Does anyone know why there is this disconnect and where the GUI is looking to get that mask value?

Any help here would be great!

My System SpecsSystem Spec
.

Reply

 SubnetMask Reg Value Not Corresponding With Interface Properties GUI




Thread Tools



Similar help and support threads for2: SubnetMask Reg Value Not Corresponding With Interface Properties GUI
Thread Forum
Is it possible to change IE9's interface to that of IE7 or IE8? Browsers & Mail
W7 tablet interface Themes and Styles
I do not see a spdif interface Sound & Audio
IDE interface? Hardware & Devices
How Can I get My Windows7 interface to look like this? Customization
Interface Bug General Discussion
Interface not registered Music, Pictures & Video

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:16 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33