Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet works on Ubuntu, but not on Windows 7

12 Dec 2012   #1
vedrann

Windows 7
 
 
Internet works on Ubuntu, but not on Windows 7

Hello
I'm dual booting Ubuntu and Windows 7 and I've got a wierd problem. Internet, both wireless and wired, works normally on Ubuntu but doesn't on Windows. I've installed wlan drivers but Windows somehow doesn't recognize any networks. Does anyone know how to fix this?
This is my computer.


My System SpecsSystem Spec
.
12 Dec 2012   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Maybe the Msoft trouble shooter for this will help.
Troubleshoot problems finding wireless networks

Do you have any virtual adaptors blue tooth or VPN's enabled on this system?
My System SpecsSystem Spec
13 Dec 2012   #3
vedrann

Windows 7
 
 

Troubleshooter didn't help at all. It only suggests that something is wrong with my wireless but that's not the case because wireless works on Ubuntu and my mobile phone.
Quote:
Do you have any virtual adaptors blue tooth or VPN's enabled on this system?
I don't think so. How do I check that?
My System SpecsSystem Spec
.

15 Dec 2012   #4
vedrann

Windows 7
 
 

I think I've found out what's the problem, just don't know how to fix it. I opened the device manager and saw that there is a problem with drivers. Here is the screen shot. I've tried reinstalling drivers (even tried older versions) but nothing seems to help. What should I do?
My System SpecsSystem Spec
15 Dec 2012   #5
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by vedrann View Post
I think I've found out what's the problem, just don't know how to fix it. I opened the device manager and saw that there is a problem with drivers. Here is the screen shot. I've tried reinstalling drivers (even tried older versions) but nothing seems to help. What should I do?
I haven't really seen this before so not sure what might be causing it.

It seems as if some system files may have become corrupted.

Try running the sfc/scannow command and see what it finds.

It might help to run a start up repair from the Windows CD a few times.
My System SpecsSystem Spec
Reply

 Internet works on Ubuntu, but not on Windows 7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Help Diagnose, Windows keeps deleting itself, Ubuntu works fine
I bought a used Lenovo x230 and upgraded with a brand new Samsung EVO 840 SSD 250GB and Crucial 8GB of ram on August 1st of this year (2014). The machine ran perfectly without a hitch for about 20 days straight. I was running Windows 8.1 64bit. About 5 days ago, I was watching Netflix when all...
Hardware & Devices
Internet Problems through Windows - Not present in Ubuntu
I have a custom built PC with dual Ubuntu 64 bit and Windows 7 Ultimate 64 bit OS's. I would use the Ubuntu exclusively, except that I need to use Solidworks, AutoCAD, and a few other programs that are not easy to use through Ubuntu. Whenever I'm in Windows, I have constant connectivity issues...
General Discussion
Why my laptop works fine using ubuntu live cd but not with windows 7?
When using the installed windows 7 my laptop keeps crashing no matter what web browser I'm using, what antivirus I use etc. The 'not responding' thing always bugging me plus occasional BSoD and regular freezes. I tried clean installing using windows CD but that didn't solve my issue. Posted...
BSOD Help and Support
Dual boot with Ubuntu 12.04 - Can't connect to internet on Win 7
Hi, I am struggling to connect to the internet on Win 7 but can connect fine on Ubuntu 12.04 I have dualboot Win 7 and Ubuntu 12.04. I can connect to the internet no problem in Ubuntu. In Win 7 I can connect to my local network and it shows as having internet connection, but I can not...
Network & Sharing
Audio Works in Ubuntu but not Win 7 (Device not detected)
I have a Lenovo Thinkcentre M55 8813-a21 (LKRYA75). The sound works just fine in any Ubuntu installation i do, but I cannot get sound in either XP or Win7. I also couldn't get the networking drivers to work in XP so I am now on Win7. I have tried the driver download page on the Lenovo website,...
Drivers
Ubuntu's Internet connection now hates me.
OKAY! Thank lord to DarkNovaGamer for telling me about the Ubuntu 10.04 beta. It works almost perfectly on my system! So now I have a backup in case Windows fails. But, I still have a problem... as usual... I can't connect to the internet via WiFi, and Wired is very unpractical unless I want to...
Chillout Room


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App