Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Windows could not connect to the System Event Notificat

30 Sep 2009   #1

Windows 7 Professional Build 7600
 
 
Windows could not connect to the System Event Notificat

I have Windows 7 Pro RTM installed on my laptop (all updates are installed) and the problem that I am having is atleast once or twice a week, when I boot my laptop it says "Please Wait" and then the login box comes up. After I enter my password and the desktop loads, there is a "lock" in the bottom right corner with a notification that says Windows could not connect to the System Event Notification Service service. Please consult your system administrator.

I am the administrator (only user) and I have uac turned off. I have tried so many different things after google searches that I will list below and nothing helps except for one thing which temporarily fixes it.

1. Disable windows defender
2. Run command prompt and do "netsh winsock reset", this is the temporary fix after reboot (sometimes I have to do it and reboot multiple times for it to work).

This worked fine with Vista Enterprise and Home Premium 64 bit so I'm not quite sure whats going on so any suggestions would help. My computer is malware/spyware/virus free.

Thanks.

My System SpecsSystem Spec
.

30 Sep 2009   #2

Windows 7
 
 

Is the service running? The System Event Notification Service?
My System SpecsSystem Spec
01 Oct 2009   #3

Windows 7 Professional Build 7600
 
 

The service is running when the system boots up normally (it is set on on and start automatically) but when this happens I can't even go into the log to see what was going on, I end up having to reboot once or twice after running the netsh command.
My System SpecsSystem Spec
.


01 Oct 2009   #4

Windows 7
 
 

I would say the netsh is just a coincedence. Where did you see this was a fix? Have you disabled any other services?
My System SpecsSystem Spec
01 Oct 2009   #5

Windows 7 Professional Build 7600
 
 

I did not disable any services (they are set to whatever they were set to when 7 was installed).

After google searches there were two solutions that I came up with: this is the only one that worked.

How to Fix “Could Not Connect to the System Event Notification Service” Error in Windows Vista

The other one was to disable windows defender but that did not work.

Also, how can it be a coincidence if every time the problem occurs I run that command and it works fine after the reboot? If I reboot without running the command I run into the same problem.

Thanks.
My System SpecsSystem Spec
14 Oct 2009   #6

Windows 7 Ultimate x64
 
 

I have the exact same problem. Fortunately it doesn't happen all the time, but it's really a pain in the neck, as when this problem happens I have to repeat the procedure (netsh...) and when I reboot the system hangs and needs a forced shutdown.

Anyone with a solution?
My System SpecsSystem Spec
15 Oct 2009   #7

Windows 7 Professional Build 7600
 
 

I did the netsh and it's been fine so far since my last post. No offense but I'm kind of glad I'm not the only one with this problem lol.
My System SpecsSystem Spec
Reply

 Windows could not connect to the System Event Notificat





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33