Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "The Diagnostics Policy Service is not running" - No Internet Access

28 Dec 2012   #1

Windows 7 64 bit
 
 
"The Diagnostics Policy Service is not running" - No Internet Access

I hope I find you all well. This is my first post on this forum. I've first dug through all previous posts on this matter, have followed all instructions that seem to have worked for other people with the same issue but none have yet solved my problem.

Initially I had a problem when I tried to connect to my wireless network at home and got the message "Limited Internet Access" so I followed a few command prompts that I found on this forum which changed the "Limited Internet Access" message to "Connected" so I thought great, it's fixed but it's not.
My wifi connects fine and my wife's laptop connects fine to the internet(on which I am working now).

When I diagnose the problem i get the message "The Diagnostics Policy Service is not running" so I then click "try these repairs as an administrator". It runs a brief attempt to repair and then I get the message "The Diagnostics Policy Service is not running" with "Detected" to the right hand side of it and a yellow exclamation mark. I then have a further 2 options; "Close troubleshooter" or "Explore additional options" which i have tried and I don't get anything helpful.

I have ran a full windows system scan (which says there are no corrupt files found), I have ran all anti-virus and anti-malwares on my system in safe mode that find nothing.
I have uninstalled all network adaptors and re-installed them. I have attempted to restart the DPS via command prompt but got no joy.

So the situation I am in at the moment is that I have connection to my wifi but no internet access.

If I go into my "Wireless Network Connection Status" I can see that under "connection", It says:

IPv4 connectivity: No Internet access
IPv6 Connectivity: No Internet access
Media State: Enabled
SSID: ***********


I am wondering if these IPv whatevers (apologies that this area I don't know anything about) could have anything to do with my problem and if anyone knows how I can get this working again?

I'd very much appreciate it if anyone can help me out with this.

Thanks in advance and I await any pearls of solution.


My System SpecsSystem Spec
.

30 Dec 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Welcome to Seven Forums mitchellleary. See the reply by farhannasir on this thread.

Diagnostics policy service not running on Windows 7 home premium

See if that helps you. A Guy
My System SpecsSystem Spec
30 Dec 2012   #3

Windows 7 64 bit
 
 

Thanks for the reply A Guy. Unfortunately it didn't make a difference. I still can't connect. I believe I've now made it worse as on the screen where it says Diagnostics Policy Service is not Running, I clicked on "Disable" and now my Internet connection doesn't appear as an option of a wireless network for me to connect to from the list. Any idea how i can connect to my network now it appears to have gone missing.
Thanks in advance
My System SpecsSystem Spec
.


30 Dec 2012   #4

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

I've no personal experience with wireless, so I will ask for more help for you. A Guy
My System SpecsSystem Spec
30 Dec 2012   #5

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

One of our Mods will take a look when he gets a chance as he's in UK. He suggested we get some info and have you post it here. Let's open an advanced command prompt:

Start> In search box type cmd> Right click cmd.exe in results above and choose Run as administrator> When command prompt opens type

ipconfig /all

Enter

Post the results in your next post. A Guy
My System SpecsSystem Spec
31 Dec 2012   #6

Windows 7 Ult, Windows 8.1 Pro,
 
 

Usually with a connection showing that has no access to the internet means that the TCP/IP stack is messed up or winsock was somehow corrupted. The error message might just be a symptom of this problem.

There is also the firm possibility that your anti virus software is somehow causing this problem.

You should try running the file below, unzip and run the file, your machine will reboot itself, this may not fix the problem but it will eliminate the possibility that it's just some type of IP stack corruption.

The ipconfig/all would also be helpful as A Guy pointed out.


Attached Files
File Type: zip IPResetALL.zip (33.6 KB, 878 views)
My System SpecsSystem Spec
09 Apr 2014   #7

Windows 7 Pro
 
 

chev65 - You are GREAT!!! The IPResetAll file fixed the issue I was having. Many THANKS...
My System SpecsSystem Spec
09 Apr 2014   #8

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by dlstoehner View Post
chev65 - You are GREAT!!! The IPResetAll file fixed the issue I was having. Many THANKS...
Glad to hear I gave the correct advice to solve the problem even though it took over two years to be useful.

With over 12 thousand hits I'd say that the IPReset file has helped quite a few more than have reported back in here.
My System SpecsSystem Spec
09 Apr 2014   #9

Windows 7 Pro
 
 
People that really know the Windows 7 OS

...are really appreciated. Thanks again!
My System SpecsSystem Spec
08 Aug 2014   #10

Windows 7 Ultimate
 
 
Thanks!

Saved me, too! Many thanks.
My System SpecsSystem Spec
Reply

 "The Diagnostics Policy Service is not running" - No Internet Access




Thread Tools



Similar help and support threads for2: "The Diagnostics Policy Service is not running" - No Internet Access
Thread Forum
The diagnostics policy service is not running General Discussion
Problem with the Diagnostics Policy Service + Internet General Discussion
The diagnostics policy service is not running Performance & Maintenance
Diagnostics Policy Service not running + internet problems? Network & Sharing
Unable to connect to internet; diagnostic policy service not running? Network & Sharing
Diagnostics Policy Service and internet drop Network & Sharing
diagnostics policy service General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:28 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33