Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: None of my devices are showing on "Network"

28 Dec 2012   #1

Windows 8 Pro
 
 
None of my devices are showing on "Network"

When I click "Network"nothing is showing up, even though 3 phones, a tablet, and an Imac are all connected to this network. When I go to routerlogin, it see's all of them. What could be the issue? I am running Windows 8 pro, I posted there but no one seemed to answer, so thought i'd try here as well.


My System SpecsSystem Spec
.

28 Dec 2012   #2

Windows 7 Ult, Windows 8.1 Pro,
 
 

Usually just turning on Network Discovery in the Advanced Sharing settings will get those devices to show up.
My System SpecsSystem Spec
Reply

 None of my devices are showing on "Network"




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:51 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33