Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Lenovo laptop REFUSES to stay connected to internet(wifi AND lan)

07 Jan 2013   #11

Windows 7 Home Premium 64-Bit
 
 

Oh...yeah...didn't think of that. It worked, scanning now. Standby for results

My System SpecsSystem Spec
.

07 Jan 2013   #12

Windows 7 Home Premium 64-Bit
 
 

yeah, guess I should've thought of that. Done, and "Resource protection did not find any integrity violations"
My System SpecsSystem Spec
07 Jan 2013   #13

Desk1 8 Pro / Desk2 7 Home Prem / Laptop 8 Pro all 64bit
 
 

Quote   Quote: Originally Posted by DavidW7ncus View Post
Did you right click on CMD.EXE and click "Run as administrator" to open the CMD console window?
Oops David yes I was remiss not explaining that a bit better
My System SpecsSystem Spec
.


07 Jan 2013   #14

Microsoft Community Contributor Award Recipient

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by heavyorion View Post
HI all, I have a lenovo laptop that is almost exactly a year old and it WILL NOT stay connected to the internet neither by wifi nor LAN. It will connect sometimes for 10 mins, sometimes for ten seconds. I can turn the computer off, restart it, close all other programs, diagnose connection, disable and restart adapters, nothing works for very long. I dont believe it is the internet as my Xbox, my desktop and my phone all connect fine through both wireless and wired connections. There are also two other laptops on the house that connect just fine (not windows 7 machines tho) my desktop is also windows 7 and sporadically has this problem as well. I have tried going to barnes and noble and starbucks to try different internet and still the same thing happens. Very Frustrating, please help if you can
It may be worthwhile to start up in safemode with Networking to see if the problem persists or not.

If the problem goes away in safemode then it's most likely an installed program or antivirus software causing the problem.

It would be helpful to see a screen shot of the ipconfig/all from this machine, just type ipconfig/all into an elevated command prompt same as with sfc/scannow command.
My System SpecsSystem Spec
07 Jan 2013   #15

Desk1 8 Pro / Desk2 7 Home Prem / Laptop 8 Pro all 64bit
 
 

Yep as Chev says mate this could be malware if the safe mode pans out as that if that is the case then try a full scan with your security backed up with these scanners the ADW may pick up some rubbish stuff too

http://www.superantispyware.com/

http://www.malwarebytes.org/products/malwarebytes_free/

AdwCleaner Download





My System SpecsSystem Spec
08 Jan 2013   #16

Windows 7 Home Premium 64-Bit
 
 

I have not tried in saef mode yet, will do that now, but i did uninstall all antivirus programs that came with it and I am using windows defender for a firewall and Avira anti-virus. I also have malwarebytes installed and scan every night. I do have a proxy connection with Privoxy going through a VPN I set up using Hamachi BUT...I don't currently connect to the internet through it anymore as Hamachi changed their EULA and features included in their freeware. So, Privoxy is turned off and Hamachi just runs in the background as a direct tunnel to my desktop. BUT, that too is always turned off unless I'm out of the house with my laptop on a public network, so I don't think that has any bearing, but thought I'd mention it in case anyone knew of any weird conflicts.
My System SpecsSystem Spec
08 Jan 2013   #17

Windows 7 Ultimate x64
 
 

Have you reserved an IP address with your modem for your laptop? it is probably attempting to join the modem with the same IP as another device such as your desktop or xbox.
My System SpecsSystem Spec
08 Jan 2013   #18

Windows 7 Home Premium 64-Bit
 
 

@iroro I hadn't done that because of the previously mentioned VPN/proxy setup made it a pain in the a$$, and since I don't use it anymore that IS an option. BUT, I that still doesn't address/fix the underlying issue of why it won't stay connected, which is what I want to figure out first.

@ICit2-opened malwarebytes to check the scan log and apparently it hasn't run in a couple weeks because it couldn't update the database (because it couldnt stay connected long enough to do so) Am now in safe mode, updated MWB and currently running a full scan which will likely take a while, so I'll go jogging and check back in about an hour. But, it's looking as tho you and Chev may be right
My System SpecsSystem Spec
08 Jan 2013   #19

Windows 7 Home Premium 64-Bit
 
 

Safe mode made no difference in connectivity, below are the results of the Malwarebytes scan. Found PUM.hijack.startmenu and removed it, rebooted computer in normal mode then again in safe mode, still no change in behavior.

Malwarebytes Anti-Malware 1.70.0.1100
Malwarebytes : Free anti-malware download

Database version: v2013.01.08.02

Windows 7 Service Pack 1 x64 NTFS (Safe Mode/Networking)
Internet Explorer 9.0.8112.16421
Administrator2 :: USER-PC [administrator]

1/7/2013 11:25:00 PM
mbam-log-2013-01-07 (23-25-00).txt

Scan type: Full scan (C:\|D:\|)
Scan options enabled: Memory | Startup | Registry | File System | Heuristics/Extra | Heuristics/Shuriken | PUP | PUM
Scan options disabled: P2P
Objects scanned: 448743
Time elapsed: 47 minute(s), 55 second(s)

Memory Processes Detected: 0
(No malicious items detected)

Memory Modules Detected: 0
(No malicious items detected)

Registry Keys Detected: 0
(No malicious items detected)

Registry Values Detected: 0
(No malicious items detected)

Registry Data Items Detected: 1
HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced|Start_ShowSearch (PUM.Hijack.StartMenu) -> Bad: (0) Good: (1) -> Quarantined and repaired successfully.

Folders Detected: 0
(No malicious items detected)

Files Detected: 0
(No malicious items detected)

(end)
My System SpecsSystem Spec
08 Jan 2013   #20

Desk1 8 Pro / Desk2 7 Home Prem / Laptop 8 Pro all 64bit
 
 

Quote   Quote: Originally Posted by heavyorion View Post
I have not tried in saef mode yet, will do that now, but i did uninstall all antivirus programs that came with it and I am using windows defender for a firewall and Avira anti-virus. I also have malwarebytes installed and scan every night. I do have a proxy connection with Privoxy going through a VPN I set up using Hamachi BUT...I don't currently connect to the internet through it anymore as Hamachi changed their EULA and features included in their freeware. So, Privoxy is turned off and Hamachi just runs in the background as a direct tunnel to my desktop. BUT, that too is always turned off unless I'm out of the house with my laptop on a public network, so I don't think that has any bearing, but thought I'd mention it in case anyone knew of any weird conflicts.
Hiyya heavy now you say you deleted all the security that came with the machine but just how did you do that because stuff like Norton and AVG etc etc usually have to be removed with their own specialised removal tools as they will still leave objects / files in the registry, and still be a real nuisance.
My System SpecsSystem Spec
Reply

 Lenovo laptop REFUSES to stay connected to internet(wifi AND lan)





Thread Tools



Similar help and support threads for2: Lenovo laptop REFUSES to stay connected to internet(wifi AND lan)
Thread Forum
Solved Unusual Internet Issues, Cannot Stay Connected Mostly Network & Sharing
Laptop cannot stay connected to wireless after a standby Network & Sharing
Work Lenovo Laptop will not stay connected on my Home Network Network & Sharing
Laptop connected to wifi but no internet access Network & Sharing
Just Can't Stay Connected to The Internet Network & Sharing
Internet wont connect/stay connected Network & Sharing
WiFi connected, but no internet (delay) Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33