Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: I can't connect some sites

03 Oct 2009   #1

Windows 7
 
 
I can't connect some sites

Hi friends. I have Windows 7 and sometimes i can't connect some sites. Especially my clan's site, =TC= Clan Battlefield Türkiye. When i try to enter different section of this forum, the page is loading for 1 minute and say the page can not be displayed. Also i can't see the pictures and thumbnails at gallery. I tried different dns, update realtek driver, disable antivirus and more but didnt help me. I dont have this problem in vista and xp, only windows 7. Please help me.

Edit: This situation resets every new ip via reset the modem. And when i try to enter some picture in gallery or new topic or another thing, same things occurs again and page can not be displayed.

My System SpecsSystem Spec
.

Reply

 I can't connect some sites





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:37 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33