Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Very Slow Internet connection

20 Jan 2013   #1
AndrewWalton

windows 7 Home Premium 64 bit
 
 
Very Slow Internet connection

I have two laptops running Win7 Home Premium 64 bit. One laptop gets normal internet connections - both wireless & wired; the other is very slow. I have updated all network drivers on the problem laptop. (Actually, when I automatically updated the network drivers from Device Manager the drivers were indicated as up to date.)

I did a complete scan with McAfee - 0 issues.

When I booted in Safe Mode with networking, the internet connection is normal.

I have looked at the startup and processes in MSCONFIG. There is nothing suspicious - i.e. the only software is from manufacturers that I would expect based on the applications installed.

What should I do to troubleshoot this problem?


My System SpecsSystem Spec
20 Jan 2013   #2
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

out of interest what is the wireless adapter version on the problem laptop
My System SpecsSystem Spec
20 Jan 2013   #3
AndrewWalton

windows 7 Home Premium 64 bit
 
 

Wireless adapter = Intel WiFi Link 1000 BGN
Network card = Realtek PCIe GBE Family Controller
Problem Laptop = Dell XPS L501X 4GB Memory
Win7 Home Premium 64-bit - SP1
My System SpecsSystem Spec
22 Jan 2013   #4
Saurabh A

Windows 7 64bit
 
 

Hi AndrewWalton,

Would like to know if you experience 'slow internet speed' with both 'wired and wireless' connections? Do you experience issues with any specific browser (IE / Mozilla Firefox / Chrome)? If yes, try using an alternate browser to see if that works.

Also try to 'disable' 'Mcafee Firewall' temporarily and check performance; if that improves performance, restore 'Mcafee Firewall' to 'factory default settings' and check results. If the issue persists, you may have to re-install 'Mcafee Software' completely. You may also want to refer to the following 'article': Turn firewall protection off

If the issue persists, you may also try a 'clean boot' to isolate the 'software' causing the conflict: Perform a clean startup to determine whether background programs are interfering with your game or program

Hope this helps. Do reply with the findings; would be glad to assist.
My System SpecsSystem Spec
22 Jan 2013   #5
AndrewWalton

windows 7 Home Premium 64 bit
 
 

Rather than trying to figure out what was degrading the internet connection - both wired & wireless - I restored the laptop to a date before I encountered the performance problems. The internet connection performs OK at that point.

I am now selectively applying updates and checking the internet connection performance before moving on the the next update(s). Hopefully, I'll be able to isolate the update that introduced the problem.
My System SpecsSystem Spec
23 Jan 2013   #6
Saurabh A

Windows 7 64bit
 
 

Hi AndrewWalton,

Glad that the 'connectivity issue' is fixed with 'System Restore'. You may observe changes in system behavior as updates get installed; valid approach. You may also want to refer to the steps I shared, if needed.

Do reply if you have any further questions; would be glad to assist.
My System SpecsSystem Spec
Reply

 Very Slow Internet connection




Thread Tools





Similar help and support threads
Thread Forum
Very slow internet connection
Well last month I was using an HP laptop (winXP) and it was running 54 mbps, which is fast for me. I got a new laptop (a week ago) and it's a HP and has Windows 7. Every since I started using it it's so slow and running at 12 and 18 mbps, it takes like 1 min. to load up a page. I have a Netgear...
Network & Sharing
Windows 7 SP1 causes slow internet connection
Hi, I formatted my 32bit Vista PC this weekend and loaded Windows 7 64bit on here. All fine, except my internet connection speed has now plummeted from around 15Mb to 8Kbps!! It's taken about 5 mins just to load this page :( I've Googled and there seems to be a lot of similar issues. I've...
Network & Sharing
Really slow internet connection after install
Hello, I've been having really annoying issues with my internet connection since i moved from vista to windows 7. I looked the forum several times to find an answer to the problem but i can't find anything close. I used to have this driver: 802.11n Wireless PCI Express Card LAN Adapter...
Network & Sharing
Slow Internet connection
Hi all I am getting a very slow internet connection. Sometimes in the morning I get 6Mb/s, but more typicaly it's 0.1 Mb/s even when other machines on LAN connect at 4Mb/s I have tried to be methodical about identifying root cause, but am now stumped :cry: ISP My other machines...
Network & Sharing
Internet Connection too Slow
Hi, my internet connection is slow, so sometimes when i visit webpages, some pictures,specially from image hosts like tinypic dont load at all. I've tried with several other browsers, but all have the same problem. and the problem is not with the webpage, cause i had it checked from someone...
Network & Sharing
Slow Internet Connection with RC :/
I have just installed the RC and I have found that my internet connection dropped from 100kb/s with Vista to 15kb/s with W7. check the pics :/ does anyone got any solution, because I have tried from disable QOS and stuff from network connections and edit the registry =/ thanks in advance
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App