Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems with Internet connections and connectivity to servers.


23 Jan 2013   #1

Windows 7 Home Premium 64bit
 
 
Problems with Internet connections and connectivity to servers.

Hello, I haven't posted here before so please excuse any noob-ish errors.

At the moment and over the past year I have been having scattered problems with my computer's Internet connection. The problems have been very scattered, but common enough for me to get fed up and look for some help.
It started with games, mostly I noticed whenever trying to host locally or join locally hosted games like Left 4 Dead 2 or Portal 2. Note that I was once able to host them with my friends who live in at least a 10km radius and get a steady ping below 100, at least. But now I can't, if I try, my friend will get a ping around 500, and if he hosts I get the ping of 500. To narrow it down to my computer, I had two friends join, both of which got pings of 500. However, when one of them hosted, only I got 500, leaving me to assume that it is in fact my computer's problem.
That error has bothered me for the last year, and while I can connect to official game servers, I can't do it locally.
The second trouble I found was with Minecraft. I had port forwarded it on my Bigpond Thompson router for at least a year, and a few months ago, it simply stopped working. I may have tinkered around with something, but I have updated the server and redownloaded the files, and I still get nothing. I assumed though that it was less to do with the server files, and more to do with the port forward. I had changed nothing, but suddenly my computer was showing up as 'unknown' followed by a bunch of letters and numbers.
This wasn't always the case, for a long time my friends could join with a nice ping, but now they can't connect despite my port forward being valid.
Now, what has recently annoyed me, is that after a month of playing Chivalry Medieval Warfare, it has stopped working. I try to join a server, it goes into the game and everyone just freezes, leaving me to run around, disconnected from the game. Incredibly annoying!

I guess what I want to know is this; is there any relevance between these problems, and of course, can it be fixed? I CAN connect to other game servers on my computer like Team Fortress 2, Battlefield Bad Company 2, the official Left 4 Dead 2 servers and I can connect to other Minecraft servers too.
I am not the only person on my Internet, my brother does not have the problems that I do with his computer, so that leavese me to assume that it is my computer, not my Internet.
My download speed averages around 800kb/s and I have tried to do these things while other people are not using the Internet, so it is not a problem with banwidth. And my Internet is not capped or anything.

My laptop is a Dell Inspiron 15R N5110, with Windows 7 Home Premium, is 64bit, has 4gb RAM, has Intel core i5 and a 2.30GHz processor. It connects Wirelessly to a Thompson TG782T modem.
The computer has mcafe virus protection which is always on.

Thanks if you can help.

My System SpecsSystem Spec
.

Reply

 Problems with Internet connections and connectivity to servers.




Thread Tools



Similar help and support threads for2: Problems with Internet connections and connectivity to servers.
Thread Forum
Solved Internet Connectivity issue - proxy server refusing connections Network & Sharing
Internet connectivity problems with VMware Player involving DHCP Network & Sharing
Solved Internet connectivity problems with 2 separate networks. Network & Sharing
Solved limited network connectivity - DHCP and DNS servers not responding Network & Sharing
Solved Problems with internet connectivity after hibernate Network & Sharing
Random Internet Connectivity Problems Network & Sharing
Internet Connectivity Problems Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:08 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33