Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: DNS Server Client won't start - dependent service does not exist

19 May 2013   #31
chapster5

Windows 7 x32
 
 

Sorry for a bump on this thread,

I have this DNS won't start problem, all the other services needed for file sharing have started (Server, DHCP, so on...) Just this DNS Client I am missing to make it complete. I tried that ff.reg up above and I get the error "Error cannot access registry".

Any help guys? I have recently had an issue with DHCP not starting and deleting that Dependent registry key fixed that just this DNS now won't boot?

Thanks

Nick


My System SpecsSystem Spec
.
20 May 2013   #32
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by chapster5 View Post
Sorry for a bump on this thread,

I have this DNS won't start problem, all the other services needed for file sharing have started (Server, DHCP, so on...) Just this DNS Client I am missing to make it complete. I tried that ff.reg up above and I get the error "Error cannot access registry".

Any help guys? I have recently had an issue with DHCP not starting and deleting that Dependent registry key fixed that just this DNS now won't boot?

Thanks

Nick
What did you delete? Did you try to import my fix with psexec?
My System SpecsSystem Spec
21 May 2013   #33
chapster5

Windows 7 x32
 
 

I deleted the "DependonService" from the DHCP registry. I cannot seem to see an exe file for psexec? I made a .bat file and copied the code into it and ran it and it prompted me, do I really want to mess with the registry yadda yadda I chose yes and that's when it said the registry is not accessible.

Code:
C:
CD  \TDX
psexec -i -s cmd.exe
A new command prompt window opens. Goto that window
whoami
Are you really system now?
C:
CD  \TDX
start  ff.reg
import succesfully?
That's what I put in the bat file.
My System SpecsSystem Spec
.

21 May 2013   #34
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by chapster5 View Post
I deleted the "DependonService" from the DHCP registry. I cannot seem to see an exe file for psexec? I made a .bat file and copied the code into it and ran it and it prompted me, do I really want to mess with the registry yadda yadda I chose yes and that's when it said the registry is not accessible.

Code:
C:
CD  \TDX
psexec -i -s cmd.exe
A new command prompt window opens. Goto that window
whoami
Are you really system now?
C:
CD  \TDX
start  ff.reg
import succesfully?
That's what I put in the bat file.
Now psexec is attached. Put in in c:\windows\system32
After that open an Elevated Command Prompt
Now do MANUALLY:

Code:
C:
CD  \TDX
psexec -i -s cmd.exe
A new command prompt window opens. Goto that window
whoami
Are you really system now?
C:
CD  \TDX
start  ff.reg
import succesfully?
You may delete folder \TDX afterwards if you wish

Quote:
I deleted the "DependonService" from the DHCP registry
What exactly did you delete? Anyway revert the changes!
My System SpecsSystem Spec
21 May 2013   #35
chapster5

Windows 7 x32
 
 

Cheers for the reply,

I still cannot see the attached psexec.exe mate. I never made a backup of DependonService before I deleted it the guide I read didn't mention about backing it up? It must have been rewritten back into the registry as DHCP is running fine where as before it wasn't.

Nick
My System SpecsSystem Spec
21 May 2013   #36
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by chapster5 View Post
Cheers for the reply,

I still cannot see the attached psexec.exe mate. I never made a backup of DependonService before I deleted it the guide I read didn't mention about backing it up? It must have been rewritten back into the registry as DHCP is running fine where as before it wasn't.

Nick
psexec is in zip file on PsExec
I don't know why attachement is gone
My System SpecsSystem Spec
21 May 2013   #37
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Are those values still in registry?


Attached Thumbnails
DNS Server Client won't start - dependent service does not exist-dhcp.png   DNS Server Client won't start - dependent service does not exist-dns.png  
My System SpecsSystem Spec
Reply

 DNS Server Client won't start - dependent service does not exist




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
DHCP Client Service FAILS TO START! (Error 1075)
Hello, On July 12th 2012, my computer installed updates. After rebooting and waiting for me on the login screen, I gave it a hard shutdown to check on the BIOS settings (for a little side project, in the end I did not save any changes). After booting and logging in again, I find that many...
Network & Sharing
Offline Folder sync issue, Win 7 Client Server 2003 Flie Server.
Hi, I am having an issue with offline files created offline syncing back to the server. I have set up a network share to be available offline on a client computer. All files are available offline without issue. Here is the issue however. If I set the folder to work offline any file I create in...
Network & Sharing
audio service not working, dependency service does not exist...
hi can anyone help? i have a medion akoya laptop running windows 7 64 bit i have no audio. if i click troubleshoot problems it says the audio service is not running it says the windows audio and endpoint builder arent working if i go into services, windows audio is set to automatic but its...
Sound & Audio
LAN network for server/client only, USB hotspot for server internet.
A friend is moving his business, and the new business park that he's setting up shop in does not have anyway to get any wired internet to his building, excluding a T1 line, which he can't justify the cost of. One windows 7 machine acts as the server, primarily for Quickbooks database, and there...
Network & Sharing
"The specified service does not exist as an installed service" problem
Hi. I am having really bad problem on my WIN 7 x32. I would appreciate some help. Here's brief description of the problem: The problem started when my mcafee anti virus removed ZEROACCESS trojans from my system. After the scan was completed, my system rebooted and I lost control of all...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App