Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows does not connect to the internet at startup

14 Feb 2013   #1
7x64user

Windows 7 Ultimate x64
 
 
Windows does not connect to the internet at startup

Hello friends.

I'm having a weird issue with my internet access. When I first installed win 7 x64, windows would connect automatically to the internet. After I did some tweaking and fiddling about, this is no longer the case .

Now, after starting the computer, I have to open Network and Sharing Center, click on the red X that's on the line between "Network" and "Internet", Windows will do its thing and then I'm connected to the internet.

I've tried uninstalling and re-installing the Network port driver and I've rerun the setup cd that came with the modem, but that didn't change anything. Any suggestions? Could this be a windows firewall issue?


My System SpecsSystem Spec
.
14 Feb 2013   #2
TwoCables

 

Did you change any settings to any of the services in Services.msc?
My System SpecsSystem Spec
14 Feb 2013   #3
7x64user

Windows 7 Ultimate x64
 
 

I did disable a few of them, but here is a list of services I have running :

Code:
Image Name                     PID Services                                    
========================= ======== ============================================
System Idle Process              0 N/A                                         
System                           4 N/A                                         
smss.exe                       240 N/A                                         
csrss.exe                      376 N/A                                         
csrss.exe                      448 N/A                                         
wininit.exe                    456 N/A                                         
winlogon.exe                   512 N/A                                         
services.exe                   552 N/A                                         
lsass.exe                      560 SamSs                                       
lsm.exe                        576 N/A                                         
svchost.exe                    672 DcomLaunch, PlugPlay, Power                 
nvvsvc.exe                     736 nvsvc                                       
svchost.exe                    776 RpcEptMapper, RpcSs                         
svchost.exe                    876 AudioSrv, Dhcp, eventlog, lmhosts           
svchost.exe                    912 AudioEndpointBuilder, Netman, SysMain, UxSm 
svchost.exe                    940 AppMgmt, Browser, LanmanServer, ProfSvc,    
                                   Schedule, SENS, ShellHWDetection, Themes,   
                                   Winmgmt, wuauserv                           
svchost.exe                    260 gpsvc                                       
svchost.exe                    384 EventSystem, fdPHost, netprofm, nsi,        
                                   WdiServiceHost                              
svchost.exe                    984 CryptSvc, Dnscache, LanmanWorkstation,      
                                   NlaSvc                                      
svchost.exe                   1132 BFE, DPS, MpsSvc                            
nvxdsync.exe                  1196 N/A                                         
nvvsvc.exe                    1204 N/A                                         
svchost.exe                   1504 FDResPub, FontCache, SSDPSRV, upnphost      
svchost.exe                   1552 WcsPlugInService                            
taskhost.exe                  1696 N/A                                         
svchost.exe                   1756 WinDefend                                   
dwm.exe                       1848 N/A                                         
explorer.exe                  1940 N/A                                         
HsMgr.exe                     2128 N/A                                         
HsMgr64.exe                   2136 N/A                                         
ClassicStartMenu.exe          2152 N/A                                         
rusb3mon.exe                  2324 N/A                                         
AsusAudioCenter.exe           2344 N/A                                         
nvtray.exe                    2572 N/A                                         
daemonu.exe                   2500 nvUpdatusService                            
javaw.exe                     2028 N/A                                         
firefox.exe                   2368 N/A                                         
cmd.exe                       2496 N/A                                         
conhost.exe                   1672 N/A                                         
tasklist.exe                  2908 N/A                                         
WmiPrvSE.exe                  2992 N/A
My System SpecsSystem Spec
.

14 Feb 2013   #4
TwoCables

 

Do you know or remember which services you disabled or perhaps even set to Manual?
My System SpecsSystem Spec
14 Feb 2013   #5
7x64user

Windows 7 Ultimate x64
 
 

I'm afraid not, I did not really keep a list.
My System SpecsSystem Spec
14 Feb 2013   #6
TwoCables

 

Quote   Quote: Originally Posted by 7x64user View Post
I'm afraid not, I did not really keep a list.
hehe well shame on you!

This might get a little bit involved, but can you open Services.msc, maximize it and then take screenshots to show all of the services? Use the .PNG format for a nice clear image quality.

For me, I need 4 screenshots to get all of my services. Be careful that no services are left out of any of the screenshots. I actually recommend doing it this way: the service at the very bottom of screenshot #1 can be at the very top of #2, and the service at the very bottom of #2 can be at the very top of #3, etc. That way you know you're not missing any.

I might be able to spot the culprit(s). Although, I'm not going to guarantee it!
My System SpecsSystem Spec
14 Feb 2013   #7
7x64user

Windows 7 Ultimate x64
 
 

Please see the following.

[IMG]http://img17.**********.com/th/03017/vc6y5s3en23b.jpg[/IMG]
[IMG]http://img17.**********.com/th/03017/dfsoulqscw5s.jpg[/IMG]
[IMG]http://img17.**********.com/th/03017/azloijidlfq2.jpg[/IMG]
[IMG]http://img17.**********.com/th/03017/173l9vmhucm2.jpg[/IMG]

I can also upload the 4 images in a zip file to mediafire, if that is more convenient.

You were right on the money, 4 screenshots did the trick
My System SpecsSystem Spec
14 Feb 2013   #8
TwoCables

 

I'm not sure if this will work, but try setting both Network Connections and Network List Service to Automatic and then reboot.

I have these disabled and my internet access still works. Although, I have a wired connection, so these may only be needed for wireless connections. I'm not sure.

(by the way, thank you very much for taking these excellent screenshots! I felt right at home while looking at them)
My System SpecsSystem Spec
14 Feb 2013   #9
7x64user

Windows 7 Ultimate x64
 
 

I have a wired connection too and unfortunately, it did not work.

This is how it looks like at startup:

[IMG]http://img52.**********.com/th/03017/3d7ehj74ia7e.jpg[/IMG]

I click the indicated X and Windows tried to troubleshoot it and next thing I know, I'm able to use the internet.

(My pleasure, really. I use PNG-8 for windows screenshots.)
My System SpecsSystem Spec
14 Feb 2013   #10
TwoCables

 

Hmm. Well, I've always had Windows Firewall disabled, so I guess I can recommend disabling it as an experiment. You can put those other two services back in Manual if you want.
My System SpecsSystem Spec
Reply

 Windows does not connect to the internet at startup




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
On, startup Windows could not connect to Group Policy .... help plz
So fresh install of windows 7 home premium 64bit every time I start up I get the same issue of "Failed to connect windows service ...... Group policy client.." I did some research about checking the key strings in regedit, but there is nothing in my registry about it.. any idea how I...
General Discussion
Can't connect to internet "Windows was unable to connect to this netwo
Hello guys, I have just finished my very first computer build and am rather happy with most things. Unfortunately I am having problems connecting to the internet. I have a temporary dongle in place and because it's my only option for about a month I kinda need it to work. When I first...
Network & Sharing
Computer does not automatically connect to internet at startup
For the last couple days one of our two computers does not connect to internet when it is first started. There is a simple band aid, which is to disable the on-board network adapter then enable again, which triggers internet connection which then stays connected until the computer is turned off. ...
Network & Sharing
Unknown device connect at Windows 7 login/startup
I am in the process of configuring a new HP Z820 workstation. This thing is a beast and absolutely love the power. Just recently I started getting a strange device connection sound playing at login/startup. Just after the windows start up chime I hear the second device connect sound. I have...
Hardware & Devices
Windows XP PC will not connect to the internet.
Okay i am trying to help a friend fix her computer though she has no clue where the original CD's with the drivers/ETC on them are. It is saying its connected to the internet through a 1394 net adapter,, which is a firewire. Now i have reviewed the specs of the borad she has (DFI Infinity NF Ultra...
Network & Sharing
Can't connect to the internet on Windows 7
I just got a new computer with windows 7. It automatically joined my home nework (so cool!) and I was able to view shared files on the already-established-and-working home network. (So no problems with cords or cables.) However, I have NOT been able to connect to the internet. The other computers...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App