Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Workstation Giving logon errors. "The trust relationship"

19 Feb 2013   #1
kylegorter

Windows 8 Enterprise 64bit
 
 
Workstation Giving logon errors. "The trust relationship"

Hi, i have a set of office computers linked to the main local Domain server. Its been a while now that some computers has been giving logon errors telling me "The security database on the server does not have a computer account for this workstation trust relationship". I could only temporarily fix it by doing a clean install of windows and joining the Domain server again, but it has happened the 3rd time today after a few months of no errors. Im thinking of finnishing this regular error by doing a clean install of the server itself but im afraid of losing data stored and have to set up all my settings all over again. So if theres any permanent fix to this it would be extemely appreciated.


My System SpecsSystem Spec
.
19 Feb 2013   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

I'm not sure if this will help but from what I've read this is a fairly common problem although the solutions seem to be different depending on many factors.


Trust Relationship Between Workstation and Domain Fails

Hot fix that may help with this problem.

Error 1789 when you use the LookupAccountName function on a computer that is running Windows 7 or Windows Server 2008 R2

And another link with a fix for the problem and some helpful comments.
FIX: Windows 7 Login Error "The trust relationship between this workstation and the primary domain failed."
My System SpecsSystem Spec
Reply

 Workstation Giving logon errors. "The trust relationship"




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
The trust relationship between this workstation and the primary domain
Hi, i hope anybody can help me about this error under Windows Server Standard SP2 and some of my client pc always showing "The trust relationship between this workstation and primary domain". it happens to in my company always so if anyone could help me to solve this problem it will be much...
General Discussion
The Trust relationship between the workstation and Domain Failed -Win7
Hi all, Over the last week or so, we have experienced an epidemic of Windows 7 PCs displaying the message "The trust relationship between this workstation and the primary domain has failed". We have had to manually unjoin and rejoin over 140+ PCs in the last week alone, however some of...
Network & Sharing
Samba as PDC: "The trust relationship ... failed" *from the beginning*
Hi, When I try a net logon from Windows 7 64-bit Business (don't have any other Windows machines), I get "The trust relationship between this workstation and the primary domain failed". The discussion I've found around the Web regarding this error message seems to be only in the context of...
Network & Sharing
trust relationship bet. this workstation & the primary domain failed
Hello, I need help again. We have several computers withWin7 Ent and Pro 64 and 32 bit. :confused:. For some i-dont-know reason, it showed 'the trust relationship between this workstation & the primary domain failed' when we login. It happened few times already. The issue is resolved if we...
Network & Sharing
"Check Disk for Errors" & "hard drive needs to be formatted" errors
I'm getting a lot of "Check Disk for Errors" and "this hard drive needs to be formatted before it can be used" error messages when plugging my external usb hard drives into my home pc which uses windows 7. I don't get any of these messages when I plug the same hard drives in at any of a number of...
Hardware & Devices
Win7 "workstation" to WinXP "server" file copy FAIL
This is driving me bonkers and I have almost no hair left. I really hope someone can help. When I attempt to copy or move a file or folder from my Win7 box to my WinXP (SP3) media server, the operation nearly always fails. Take, for example, my trying to copy the VLC Media Player folder (704...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App