Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: I need help optimizing my LAN

07 Mar 2013   #1
mouser58907

Windows 7 Professional x64 SP1
 
 
I need help optimizing my LAN

I have a HTPC that I often transfer large files to. I've worked hard on making sure I have all the equipment to have a fast LAN, but for some reason Windows 7 is slowing it down. I've tried following directions all over the net and haven't had any luck. I'll post my equipment and the results of my experiments below.

Equipment:
  • Desktop (W7/Ubuntu) - Ethernet 1gbps
  • MacBook Pro (OSX) -Ethernet or Wireless
  • HTPC (W7) - Wireless but can hook up gigabit Ethernet for testing
  • ASUS N56-U Gigabit Router (Latest firmware)
  • All ethernet cables are Cat-5e
  • No other 2.4Ghz equipment nearby.
Tests:
  • Direct Ethernet from Desktop W7 to HTPC W7 - ~100 MBps
  • Same, but through router, - 3-10 MBps
  • Again through router but Desktop Ubuntu to HTPC W7 - 3-10 MBps
  • Macbook Pro to Ubuntu - 60MBps
This tells me the router is working as transferring back and forth between Ubuntu/OSX works fine. However, when my Windows 7 HTPC gets involved it slows down significantly. ONLY if the router is involved though. Direct ethernet gave me 100 MBps. This makes me think it has to be a setting in Windows 7. I've spent dozens of hours trying to figure this out myself, but can not figure out anything.


For the record, I am aware of differences in bits/bytes and they are correctly labeled in this post.


My System SpecsSystem Spec
.
07 Mar 2013   #2
mouser58907

Windows 7 Professional x64 SP1
 
 

I ran another experiment: Windows 7 to Macbook also gets 60MBps. So Sending isn't the issue, just recieving on the HTPC
My System SpecsSystem Spec
Reply

 I need help optimizing my LAN




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
optimizing ssd help
It says with the exception of the following necessary logs, (Application, SEcurity, System, and Security ESsentials), I can disable them from starting. The only ones I see are EventLog-Application, EventLog-Security, and EventLog-System that are Enabled. There's no Security Essentials listed...
Hardware & Devices
Optimizing my SSD install.
I just re-installed Windows 7 on my machine and I want to maximize my boot speed. Everything else is blazing fast its just taking a long time (about 50 seconds) to boot, from and SSD mind you. Maybe some services I can disable safely for a faster boot that would be great. I dunno anyway if I...
Performance & Maintenance
Optimizing sound
How do these settings look for optimal sound quality? I've been fiddling with sound the last few days- when I turned on iTunes the other day, in the speakers it sounded too bright and too trebly. But I've boosted bass and dropped treble, and I still can't get it the way I want. The headphones...
Music, Pictures & Video
optimizing performace
hie everyone... i seem to a have a little problem with ma startup services... if i start all of them, my PC becomes slower... so i decided to deactivate most of the useless ones...THE PROBLEM is that i do not know which drivers i should not mess with... i need my sound and my internet.... i really...
Performance & Maintenance
Optimizing VPC.exe
Hi, I kind of stuck with one VPC.exe process, executing all my running virtual PCís! I would very much like to run multiple applications on different virtual PCís at the same time, but the VPC process is never using more than one CPU in my system. Isnít there a way to tweak this?
Virtualization
SSD - need help with optimizing
30gb Vertex OCZ, x64 7600 build. I tried to disable hibernation and it wasnt there anyways. With only windows, ATI drivers and the MOBO utilites I'm at 13.6 GB free. The rest of my system specs are in my signature.
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:12.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App