Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dual NIC, 2 Segment configuration question

08 Mar 2013   #1
Sunapee

Windows 7
 
 
Dual NIC, 2 Segment configuration question

I have a dual NIC in my work desktop (Windows 7 Ultimate 64 bit) connecting to separate routers. Eeach router has internet access, each on a different segment, each on the same subnet. We have 2 independent networks here. One segment is a domain and the other is a work group. Both have multiple servers.

The first NIC's IPv4 is configured with a static IP Address on a Domain and has a gateway configured. The second one also has a static IP address in a work group and is configured with no gateway. This seems to work fine, but the second one shows up as a Public newtork and I would prefer it to be a Work network.

Researching this pointed me to an article that said networks without default gateways are always public.

I changed the second NIC to also have a default gateway, matching the router's IP Address on the second segment. Windows slapped me for having 2 default gatewyas and let me save it anyway. Now, both connections are showing up under Domain Network and everything seems to be working fine. Both connections show that they have internet connectivity.

I fear that just because they seem to be working does not necessarily mean that is is working efficiently. I am also not positive that it even matters that the second one is listed as a Public network. Can anyone identify the proper configuration in my situation?


My System SpecsSystem Spec
.
08 Mar 2013   #2
Sunapee

Windows 7
 
 

OK, after a bit more poking I now have the second router configured to assign a static leased IP Address for my second NIC where it assigns the NIC an IP address based on the MAC Address of the card. Then I configured the ipv4 for that card to obtain an ip address automatically.

Now, that connection's details show the original IP Address (the one I had previously set as a static IP on the card itself) as well as a default gateway (Router #2's IP Address), and I am no longer getting slapped by Windows for having 2 default gateways (even though each connection shows that it has a default gateway in the details). It is also showing up as a connection in the Domain Network's location.

Visually, this seems to be set up the way I would expect to have it, but I am still not 100% positive that I have good expectations.

Any input?
My System SpecsSystem Spec
Reply

 Dual NIC, 2 Segment configuration question




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Dual Monitor Configuration - HD6850
Wasn't sure if this should go in hardware or here seeming as it's about monitors as well as the graphics card, but yea.. move if needed I guess :) So.. today I got a new monitor. One of those korean 27" 2560x1440 displays, the QNIX qx2710. I have also an LG 22" old flat panel screen, and a 20"...
Graphic Cards
Canīt see all my CPUs/trheads on dual Xeon configuration
Hallo, I have a strange problem on a HP z600 with dual Quadcore Xeon @2,93 Ghz with HT, OS is Windows 7 Ultimate x64. CPU-z can see correctly two cpus with 4 cores but with only 4 threads. I checked BIOS settings and I enabled HT and multi cpu support, than with CPU-z i can see only 1...
Hardware & Devices
MBO configuration question.
I think this is a dumb question but is there any reason my Gigabyte MA790X-UD4P MBO will work at 32 bit but not at 64 bit? If I configure at 32 bit it works fine but when I go to 64 bit it gives me all kinds of strange problems. My OS is Win 7 Home Premium. I want to use 64 bit because I have 8GB...
Installation & Setup
Windows 7 DUAL boot configuration
Hi , I have a windows 7 x64. I separated 40 gb my disk and installed windows 2008 R2. But my boot info did not change. How can i add my new OS in my bcdedit? (I need exact commands) Thankx...
Installation & Setup
Odd configuration: Setting up Dual Monitors
Ok, so I just added Windows 7 to my lineup. After an epic battle with permission problems between XP and 7, I finally managed to fix it and have moved on to a slightly more odd yet annoying problem- my dual monitors. The way I used to have my monitors set up was my monitor on the right had my...
General Discussion
Want to delete an OS from a dual boot configuration
Hello, I originally stated out with XP Pro and then installed Win 7 in a separate partition with dual booting. Now I want to get rid of the XP OS and recover the partition the XP OS is in for other uses. Running bcdedit shows the the Win 7 as drive C and XP as drive D. The master boot...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 05:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App