Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: VPN starting connecting authenticating and disconnecting same time

06 Apr 2013   #1

Windows 7 Home Premium 64-bit
 
 
VPN starting connecting authenticating and disconnecting same time

Okay so I am trying to setup a VPN for my iphone. ive set it up via the windows built in server. I set my comps IP to static and port-forwarded the vpn port of 1723 to my comp IP. also enabled vpn in my router. and just to be sure I tried disabling windows firewall. no matter what I have done so far whether Im on wifi or cellular my iphone nor my wifes (iphone) work. They both display "starting, connecting, authenticating and disconnecting" one after the other in a matter of 3-5 seconds. So Its like I get a connection but it cant fully authenticate. i have know clue as to why though. I am about 90% certain its not my iphone which is why im posting here and not some iphone forum. it could be my router but Id like to make certain its not windows first because I cant flash my router to dd-wrt as it belongs to my isp so I'd have to call them and swap it out and blah blah blah.... so, any suggestions, thoughts? I've done this before with another model iphone and a different router so either I'm forgetting a few steps or something just isnt the same. oh and im using pptp i think.

edit: also when I run netstat -a it says that windows is listening for vpn connection on "0.0.0.0:1723". Shouldnt it have and IP other than 0.0.0.0? I have 192.168.0.19 on 1723 set for the port-forward.... and my router wont let me set 0.0.0.0 as the IP.

My System SpecsSystem Spec
.

07 Apr 2013   #2

Windows 7 Ultimate x64
 
 

1. Are you trying access the server outside your home network i.e from the internet using 3G?
2. Is VPN passthrough enabled on the router it needs to be enabled?
3. Your Public IP address from your ISP is it a dynamic IP address or static?
My System SpecsSystem Spec
07 Apr 2013   #3

Windows 7 Home Premium 64-bit
 
 

1. Yes over 3G and\or LTE if it matters

2. Yes it is

3. I think it's static but I'm not sure. It's been the same every time I've tried to connect so it wasn't a mismatch between my phone vpn settings and the router.
My System SpecsSystem Spec
.


07 Apr 2013   #4

Windows 7 Ultimate x64
 
 

Open a webrowser and navigate to your routers IP address and login with username and password and go to the status screen and make a note of the Public IP address that your ISP has given then log out.

A simple check you could to see if your Public IP is dynamic is to powercycle all equipment connected to the router including your router and leave for two minutes.

Then power up the router and wait for lights to stabilize and power up devices one by one and wait until fully started.

Then log back into your router and go to the status screen and check to see if your Public IP address has changed.

If you are still unsure you can give your ISP a quick call and they will confirm whether they supply you with a dynamic IP address or static IP address. Please let us know what the results are then can advise you further.

Please post make and models of your modem or ADSL modem/router and/or wireless routers you are using.
My System SpecsSystem Spec
07 Apr 2013   #5

Windows 7 Home Premium 64-bit
 
 

alright checked and double checked and I am confident its static.

edit: also router is a Cisco DPC3825 DOCSIS 3.0 Gateway.
My System SpecsSystem Spec
07 Apr 2013   #6

Windows 7 Ultimate x64
 
 

Ok it is static that is good.

Now i was assuming you had a site to site VPN but upon re-reading you are just using a VPN provider to setup a VPN connection for general use what VPN provider are you using?
My System SpecsSystem Spec
07 Apr 2013   #7

Windows 7 Home Premium 64-bit
 
 

not currently using any providers. just using the windows built-in vpn server and port-forwarding from my router. if there are any free providers that youd recommend im all ears but not looking to spend anything on this when i know that i can do it for free (at least i used to less than a year ago)
My System SpecsSystem Spec
07 Apr 2013   #8

Windows 7 Ultimate x64
 
 

What VPN app are you using on the Iphone?
My System SpecsSystem Spec
07 Apr 2013   #9

Windows 7 Home Premium 64-bit
 
 

Oh I'm using the iPhones built-in vpn client
My System SpecsSystem Spec
08 Apr 2013   #10

Windows 7 Ultimate x64
 
 

If you go to edit your VPN configuration and input following details from your server configuration:

Description:
name of your VPN
server: if no hostname then your static Public IP address
Account: input username
RSA SecurID: set to off unless you have a certificate
Password: input password
Secret: secret password
Send all traffic: on

Proxy off or set to manual with following settings:
Server: Public IP address
Port: 1723
Authentication: on

If you do not have a static Public IP address you will need to use something like no-ip.com hostname

and install their sync client on your server to sync the hostname with your Public IP address and then input the hostname as the Server in your iphone configuration.
My System SpecsSystem Spec
Reply

 VPN starting connecting authenticating and disconnecting same time




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:44 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33