Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Atheros Wireless Adapter Slowing Down


24 Apr 2013   #1

Windows 7 64bit
 
 
Atheros Wireless Adapter Slowing Down

Hello, I have an Atheros AR9258 Network Adapter on a Lenovo Z560 laptop.

I recently noticed that my internet speed was very slow, so I went to Speedtest.net. I found out that I am only getting 1/4 of the speed I pay for. I uninstalled the device and its drivers. I then re-installed them (using a wired connection). My speed went up to about half of what I pay for.

I thought the problem had been solved, but after about 5 minutes my speed was down to 1/4 of what I should get again. I have repeated the Speedtest, uninstall, reinstall, and Speedtest again procedure multiple times to the same conclusion. On my desktop I am getting the correct speed all of the time, so I know it is not my ISP.

Is my Wireless adapter going bad? How can I fix this problem?

Thanks

William

My System SpecsSystem Spec
.

24 Apr 2013   #2

Windows 7 64bit
 
 

I had two network drivers (Realtek and Atheros). I updated the Realtek and that seemed to fix it. I am now getting 100% of what I should get.
My System SpecsSystem Spec
Reply

 Atheros Wireless Adapter Slowing Down




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:55 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33