Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network Adapter Driver is missing, cant connect to internet.


26 Apr 2013   #1

Windows 7 home Premium 32bit
 
 
Network Adapter Driver is missing, cant connect to internet.

Hello,

The network adapter driver is reported missing by windows on my Acer M5630 desktop running Windows 7 32bit and i cannot connect to the internet (using another computer for this).

I am using a Ethernet cable connected to a router which also has 3 other Ethernet ports that are working fine (have other devices plugged into those), as well as wireless that is working fine with my laptop and kindle. Also, there is no Network Adapter category listed in the Device Manager and some "Multimedia controller" & "Multimedia Video controller" items listed under Other Devices with yellow exclamation points.

This problem started after i plugged in an iPhone and it auto installed its drivers, i did what i needed to do with it, and then the problem started next time i turned on the computer. Now after turning the desktop on and not being able to connect, i try to shut down with the windows button, it enters a shutdown-reboot cycle until i do a hard shutdown. Previously, it was starting up into this shutdown-reboot cycle too, and i could only start in safe mode, but that problem seems to have fixed it's self.

Any help would be appreciated, thanks.


My System SpecsSystem Spec
.

26 Apr 2013   #2

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by krod14 View Post
Hello,

The network adapter driver is reported missing by windows on my Acer M5630 desktop running Windows 7 32bit and i cannot connect to the internet (using another computer for this).

I am using a Ethernet cable connected to a router which also has 3 other Ethernet ports that are working fine (have other devices plugged into those), as well as wireless that is working fine with my laptop and kindle. Also, there is no Network Adapter category listed in the Device Manager and some "Multimedia controller" & "Multimedia Video controller" items listed under Other Devices with yellow exclamation points.

This problem started after i plugged in an iPhone and it auto installed its drivers, i did what i needed to do with it, and then the problem started next time i turned on the computer. Now after turning the desktop on and not being able to connect, i try to shut down with the windows button, it enters a shutdown-reboot cycle until i do a hard shutdown. Previously, it was starting up into this shutdown-reboot cycle too, and i could only start in safe mode, but that problem seems to have fixed it's self.

Any help would be appreciated, thanks.
I have no idea what the phone might have done to your system but you might try running system restore to put your system files back to how they were before the Phone ruined your connection.

System Restore
My System SpecsSystem Spec
28 Apr 2013   #3

Windows 7 home Premium 32bit
 
 

I tried to system restore originally, but windows failed to complete it and gave me a BSOD, then entered a shutdown/reboot cycle. So i gave up trying to system restore. Maybe a virus is causing this??
My System SpecsSystem Spec
.


28 Apr 2013   #4

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by krod14 View Post
I tried to system restore originally, but windows failed to complete it and gave me a BSOD, then entered a shutdown/reboot cycle. So i gave up trying to system restore. Maybe a virus is causing this??
I would have to see a screen shot of the ipconfig/all to see how the network adaptors are configured.
My System SpecsSystem Spec
04 May 2013   #5

Windows 7 home Premium 32bit
 
 

So this is the ipconfig i am seeing, as well as the device manager errors. When i try to connect using the broadband PPPoE connection i get errors 561 or 797. I am unsure of what to do next, i have tried the default solution of replacing rapppoe.sys in windows\system 32\drivers with a copy from my working pc and that hasnt helped. I also downloaded the LAN drivers and Modem drivers from the Acer webste and windows cant find the drivers in those folders. Any ideas would help, thanks


Attached Thumbnails
Network Adapter Driver is missing, cant connect to internet.-capture1.jpg  
Attached Images
 
My System SpecsSystem Spec
05 May 2013   #6

Windows 7 Ult, Windows 8.1 Pro,
 
 

From the Device Manager you don't have any network adaptors installed at all here. It's no wonder the ipconfig/all isn't picking up anything. I'd like to help but I don't have anything to work with here.
My System SpecsSystem Spec
Reply

 Network Adapter Driver is missing, cant connect to internet.




Thread Tools



Similar help and support threads for2: Network Adapter Driver is missing, cant connect to internet.
Thread Forum
Solved network adapter missing Network & Sharing
Solved Network adapter missing. Drivers
Solved Network Driver Adapter is missing after restart Network & Sharing
Cannot connect wirelessly to internet by USB adapter Network & Sharing
Can't always connect to internet, says to reset adapter Network & Sharing
Missing Network Adapter? Please help! Network & Sharing
Network adapter is missing Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:52 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33