Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Internet Speed

25 Jan 2009   #1

windows seven
 
 
Internet Speed

I recently transitioned from windows xp to windows seven. I like all the perks of windows seven with the sleek look and advanced security but my internet acts very strange. I have an 8meg internet connection and it ran fine on xp. After installing I can't even get 1meg down. sometimes I only get 500ish kbs and have trouble even loading pages. I know there is nothing wrong with my internet because surrounding friends have the same internet and they have no problems. Any help is greatly appreciated.

My System SpecsSystem Spec
.

26 Jan 2009   #2

Windows 7 Build 7048 x64
 
 

Try using Advanced System Care Pro by IObit, it has a built-in connection optimization that might set your system free. After optimization, restart and try to check your connection again. That should do the trick.Whatever that's slowing down your connection should be fixed by the optimization done by ASC.
My System SpecsSystem Spec
26 Jan 2009   #3

Windows 7 Professional 64-bit
 
 

One way is to use resource monitor to see whats eating your bandwidth.

Right click on the taskbar and select start task manager.
Click on the performance tab and press the resource monitor button

In resource monitor click on the network tab.

Click on the rollup arrow to bring up the tcp connections window and you'll be able to see all the connections that are taking place along with the latency for some programs.

Keep this open for a while and see what happens. You might find a load of connections appear for one particular program such as wermgr.exe. Let me know what happens.
My System SpecsSystem Spec
.


09 Feb 2009   #4

windows 7
 
 
same issue

This is also happening to me, I have fios 10/2 and i will drop to speeds of 700kb/1.5k. I have to end some of the svchost proccesses in the task manager in order to fix it, and even then it takes a few minutes for windows explorer to refresh, re-enable and be good again.

This also occured when I used remote desktop.. and utorrent.... its real quirky.. sometimes i reboot and it happen right away and some times i can surf the web for a while and it will just slow down.

I read up on a streaming throttling issue, anyone heard of this?


any help would be good. I really dont want to have to use XP again...
My System SpecsSystem Spec
09 Feb 2009   #5

windows 7
 
 
hmm

Ok i did the system monitoring thing and it looks as if utorrent isnt shutting down, even after I kill it in the system processes menu in the task manager. Also regular exiting doesnt work....

wth...
My System SpecsSystem Spec
Reply

 Internet Speed





Thread Tools



Similar help and support threads for2: Internet Speed
Thread Forum
What's your Internet Speed? Network & Sharing
How do I speed up my internet speed? Network & Sharing
my internet speed changes Network & Sharing
Wireless Router Speed Connection VS Actual Internet Service Speed Network & Sharing
Solved What is my Internet speed? General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:33 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33