Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Remote Desktop Protocol


23 Jul 2013   #1

Windows 7 Professional (64-bit)
 
 
Remote Desktop Protocol

It's been along time since I've came by, but never forgot about you guys and this forum. I Can't tell you how much tutorials I did here and never finished them all "Yet" but will in the not to distant future. Here's the problem I'm having, reading the Maximum PC July 2013 Magazine said I'll give Windows RDP ago again and follow the little tutorial what can go wrong!

The first time it was with UltraVNC and Hamachi
and there was no problems, but with Windows RDP I just can't connect from the outside WAN. LAN works great and I always use it to access the NAS/Server backup running Windows XP Professional that's upgraded to Windows 7 Ultimate now.

Here's what I did:

1. I setup a
Static IP Address using www.noip.com on the Workstation that's what I call my main system Computer (A) not the NAS/Server computer (b).

2. I made sure my Router had Port Forwarding setup correctly and ran No-ip Port checker Tool, came back good and followed the tutorial for
Speedstream6520 Router also.

Note: I have the Speedstream6520 Router set has the DHCP server for the D-Link DGS-108 8-port Gigabit Ethernet Switch (that has no Web-interface) and turned Linksys wrt54g into a dumb switch.

Speedstream6520 Router Start IP Range: 192.168.2.10 - End IP Range: 192.168.2.150 and the Linksys wrt54g Router plugged into the Speedstream6520 Router with the IP set to 192.168.2.151 all under IP Netmask: 255.255.255.0.

3. Created a new user account add the guest group for security and Remote desktop Protocol to the new user account also, made sure it was added to the Remote desktop users list enabled Allow connections from this computer running any version of Remote Desktop (less secure).

4. Checked to make sure the Firewall had the right ports opened after enabling Allow connections from this computer running any version of Remote Desktop (less secure).

Domain ports where open but not the public and don't know if they have to be?

Note: When enabled Allow connections from this computer running any version of Remote Desktop (less secure) from the remote tab under system properties all three below for domain are open but not the public. Opening them and when disabling the Remote Desktop option under System Properties they all close, that's for Domain and public.

Remote Desktop (TCP-In)
Remote Desktop - RemoteFX (TCP-In)
Remote Desktop - RemoteFX (UDP-In)

5. Fired up the Remote Desktop Connection enter Computer Name: Seven-PC User Name: PhoneyVirus and then Password connected and warned me that there was another user logged in using the PC witch I was so I knew LAN was working.

Next tried my Public IP that's outside of my NAT all from NAS/Server Computer (b) with No-ip (ex:Virus.no-ip...) and the Pubic IP (ex: 99.192.xx.xxx) I keep getting the following error below:

Remote Desktop can't connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled"

The above two (2 and 3), i have checked. What is the 1st point?

Remote access to the server is not enabled. Where is this option available in windows 7?

Can I connect through my LAN using the Pubic IP or do it have to be outside of the WAN for it to work?

I came across this post "i delete the old certificate and enroll the new one, after that i able to make RDC session. in order to make RDC session the certificate must be avlid other wise you will get the RDC connectivity errors cited above in the post, in case if the certificate is valid then perform basic level troubleshooting like RDC service status and firewall issues as well."

How do I delete the old certificate or is this something else?

I tried everything but disabling the windows firewall, from disabling the DMZ on the Speedstream 6520 Router, rebooting, looking through the Event Viewer, making sure the Remote desktop services were running and searching the world wide web for hours and said if the guys on seven-forums can't figure out what I'm doing wrong then no one will. Hope someone with more skills then me can pin point the problem Thanks. Also I post no where else on the web only here and will do so until I fine out what I'm doing wrong or someone else do.

Again Thanks!


My System SpecsSystem Spec
.

Reply

 Remote Desktop Protocol




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33