Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Homegroup Problem: Network Discovery Issue

26 Jan 2009   #1
mmisterio

 
 
Homegroup Problem: Network Discovery Issue

I have a desktop and a laptop. On the laptop when I select network discovery ON and I save changes. For some reason, the next time I look the setting is turned to OFF. It is preventing me from using homegroup. Anyone got a fix?


My System SpecsSystem Spec
.
06 Mar 2009   #2
endu

Windows 7 Beta (x64)
 
 

I am having the same problem on my Desktop. I've set my network "location" to both Home and Work, which enables and disables Homegroups, but attempting to set Network Discovery to "on" does nothing. Other options in the advanced window can be changed, but every time I attempt to save the change to Network Discovery it is off as soon as I go back to look at it.
My System SpecsSystem Spec
06 Mar 2009   #3
limneos

Windows 7 RC 7100 32bit/64bit
 
 

Have you by any chance changed the following option?


Attached Images
 
My System SpecsSystem Spec
.

06 Mar 2009   #4
endu

Windows 7 Beta (x64)
 
 

I've tried it in both settings (it is currently set to the second option). I actually have got it working right now, here is what I did.

I went to Control Panel -> Administrative Tools -> Services. I found that SSDP Discovery service was set to "Disabled". I haven't had any reason to change services, so apparently it was set that way by default. After setting the service to "Automatic" and starting it, I was able to set Network Discovery to "on" successfully.
My System SpecsSystem Spec
06 Mar 2009   #5
limneos

Windows 7 RC 7100 32bit/64bit
 
 

Glad to know you've worked this out endu.

Thanks for posting the solution here for others too.
My System SpecsSystem Spec
15 Mar 2009   #6
UKForce

Windows 7 Build 7077
 
 

I have the same issue here, for some reason it keeps going back to Network Discovery - OFF, it will not stay on at all.

I have checked all the services that need to be on, they are on, I have event stopped the firewall, but that made no difference either?


I am in a Homegroup but just this computer refuses to keep network discovery on ?

Internet etc, etc is all fine, and my other 2 computers are fine, all talking to each other etc.

I am running build 7057.




Any ideas anyone?
My System SpecsSystem Spec
16 Mar 2009   #7
RRabbit427

W7 (7057) x86
 
 

Quote   Quote: Originally Posted by UKForce View Post
I have the same issue here, for some reason it keeps going back to Network Discovery - OFF, it will not stay on at all.
I have checked all the services that need to be on, they are on, I have event stopped the firewall, but that made no difference either?
I am in a Homegroup but just this computer refuses to keep network discovery on ?
Internet etc, etc is all fine, and my other 2 computers are fine, all talking to each other etc.
I am running build 7057.
Any ideas anyone?
Same Problem: Settings will not save changes... Network Discovery will not stay on... changes services to automatic... still nothing... I can even look at my network map and both computers show up but cannot configure this homegroup.... any help would be much appreciated...
My System SpecsSystem Spec
23 Mar 2009   #8
rozrack

<o>
 
 

Turn on DNS Client, Function Discovery Resource Publication, SSDP Discovery, and UPnP Device Host services.
My System SpecsSystem Spec
23 Mar 2009   #9
darkassain

Windows 7 Ult x64(x2), HomePrem x32(x4), Server 08 (+VM), 08 R2 (VM) , SuSe 11.2 (VM), XP 32 (VM)
 
 

Also if you want Homegroups you need to have IPv6 enabled...
My System SpecsSystem Spec
11 Jul 2009   #10
DarkMatter

Windows 7 RC 7100 build
 
 

Quote   Quote: Originally Posted by rozrack View Post
Turn on DNS Client, Function Discovery Resource Publication, SSDP Discovery, and UPnP Device Host services.
Thanks that actually worked for me on RC build #7100
My System SpecsSystem Spec
Reply

 Homegroup Problem: Network Discovery Issue




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 Network Discovery Issue
I'm unable to get my network discovery working. This is preventing me from connecting to my homegroup and even my printer. I can ping the other computers and devices on my network, I just can't connect to them. Here are all the services currently running. Application Experience Background...
Network & Sharing
Network discovery & computer browser svc issue, but no error in EV
I have a small home network with a A)Win7 desktop, B)a Win7 laptop, and C)an XP desktop. I work primarily with A. I did some network refiddling to replace a router. All seems to be working, but when I try to enable Network Discovery or File & Printer Sharing on A, they turn themselves right back...
Network & Sharing
Network Discovery Issue -- Blue Screen!
I have a laptop with windows ultimate 64 , when I enable network discovery and file sharing so the system can connect a media player that use samba for file sharing and my system crash , I had a Zone alarm that uninstalled it here is the output of dump file but I really don't know how to analyze...
BSOD Help and Support
Network Discovery Issue...I think
Hey all, Just changed from a Linksys WRT160N to a Belkin Play F7D4302UK and everything has gone smoothly apart from one thing. For some reason using the Belkin I don't think my PCs and devices (I have a Popcorn A110 too) are able to broadcast their presence to eachother anymore. I can...
Network & Sharing
network discovery? problem
I have a problem. We have 4 network storage drives between 2 offices that our servers backup to daily. every other week we swap 2 of the drives out with the other office so that we have backups in 2 locations offsite. the problem is that the 2 offices are on the same domain but 2 differant subnets....
Network & Sharing
Network Discovery Issue
So I recently upgraded my laptop from Vista to 7. I have a desktop running Vista. After upgrading the laptop, I mapped the secondary drive of the desktop as a network drive on the laptop. It worked fine for a couple of days. Then the laptop wouldn't connect to the drive. I checked the network page...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App