Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to connect to Internet-diagnostic policy service off

01 Aug 2013   #1
redwood25

32 bit OS
 
 
Unable to connect to Internet-diagnostic policy service off

Background: several weeks ago laptop stopped connecting with internet. Troubleshooter said that the Diagnostic Policy Service was off. Went to admin>services> diagnostic Policy service, no joy, already set in automatic. (Error 5)

At the time the laptop stopped connecting the free microsoft license that came with the computer also stopped working... called Dell they said I never had the full version. Needless to say I screwed the pooch, I purchased the software, but did not keep the receipts. I gave it to my daughter who is more computer literate than I am to do the install as the computer was for her anyway.

I do not have any discs, she lost them.

Other than blowing my brains out, is there a fix?

thanks


My System SpecsSystem Spec
.
02 Aug 2013   #2
SandeepP

Winndows 7 32 bit
 
 

Quote   Quote: Originally Posted by redwood25 View Post
Background: several weeks ago laptop stopped connecting with internet. Troubleshooter said that the Diagnostic Policy Service was off. Went to admin>services> diagnostic Policy service, no joy, already set in automatic. (Error 5)

At the time the laptop stopped connecting the free microsoft license that came with the computer also stopped working... called Dell they said I never had the full version. Needless to say I screwed the pooch, I purchased the software, but did not keep the receipts. I gave it to my daughter who is more computer literate than I am to do the install as the computer was for her anyway.

I do not have any discs, she lost them.

Other than blowing my brains out, is there a fix?

thanks
Hi redwood25,

Welcome to Seven forums.

Please set the service to manual instead of automatic and then start the service and let us know the results.

I believe your system must have come with the Windows preinstalled. So you should be having genuine OEM version of windows on this system.

Please check this link for further troubleshooting the issue:

How to troubleshoot network connectivity problems in Internet Explorer

If the system was working fine earlier then you can also set the system to earlier stage by performing system restore:

System Restore

Lastly, check this links for requesting backup discs for your system:

http://dell.to/Zj7oHA

Keep us posted with the results so we can advise you further.
My System SpecsSystem Spec
02 Aug 2013   #3
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by redwood25 View Post
Background: several weeks ago laptop stopped connecting with internet. Troubleshooter said that the Diagnostic Policy Service was off. Went to admin>services> diagnostic Policy service, no joy, already set in automatic. (Error 5)

At the time the laptop stopped connecting the free microsoft license that came with the computer also stopped working... called Dell they said I never had the full version. Needless to say I screwed the pooch, I purchased the software, but did not keep the receipts. I gave it to my daughter who is more computer literate than I am to do the install as the computer was for her anyway.

I do not have any discs, she lost them.

Other than blowing my brains out, is there a fix?

thanks
To fix this particular problem Go to start ,search and type:- cmd, right click on returned cmd.exe and select "run as administrator" at the prompt type:-


HTML Code:
net localgroup Administrators /add networkservice
Press enter then type:

HTML Code:
net localgroup Administrators /add localservice
Press enter then type:
HTML Code:
exit
Press enter and restart your computer

Open services and make sure the Diagnostic Policy Service is started.

Source:> Windows 7: Diagnostics Policy Service not running - Microsoft Community
My System SpecsSystem Spec
.

Reply

 Unable to connect to Internet-diagnostic policy service off




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Cannot connect to the Internet. Diagnostic Policy Service not start.
First time posting. Running an Asus Notebook U50F Series with Windows 7 Home Premium, 64 bit, 2 Gig processor w/ 4 GB RAM. I lost the ability to connect to my wireless router or to connect via an Ethernet cable connected to the router. Other devices can connect wirelessly and hard wired so...
Network & Sharing
Diagnostic Policy Service not working
Hello All I am looking for help with a problem I am having with my laptop Dell Inspiron 1545 O/S Windows 7 Home Pemium. It has stopped connecting to the internet through the house wireless router although all other devices in the house can connect. If I try to run troubleshooter I cannot and get...
Network & Sharing
Can't run Diagnostic Policy Service because of Error 5
This started happening when I accidentally turned off my computer whilst it was booting. I have tried sfc /scannow, I have done the CMD thing (net localgroup Administrator) and have tried manually starting the service, to no avail. Here is a screenshot of what I think appears to be the...
Performance & Maintenance
Unable to connect to internet; diagnostic policy service not running?
Hey everyone, if anyone could provide any information on this issue, i'd greatly appreciate it. My mom's laptop is detecting that our wireless internet connection is active, but it won't actually connect to the internet. When we troubleshoot the issue, it says that our diagnostic policy service...
Network & Sharing
Diagnostic Policy Service cannot be started
I've searched the forum but most error text is different. Mine is simple.. It says I've tried multiple things however I cant get it fixed.. I tried system restore but system restore took 4 days and SURPRISINGLY, the restore failed.. I am planning to do system image restore.. Any help will...
General Discussion
Cannot start diagnostic policy service
i tried to diagnose my internet connection, and it informed me that the diagnostic policy service was not running. so i went over to services.msc right clicked the diagnostic policy service and got the following error: im at loss |:
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App