Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Connecting Issues with Windows 7

04 Aug 2013   #1

Windows 7 Home Premium 64bit
 
 
Connecting Issues with Windows 7

I just installed Windows 7 onto a blank hard drive on a new desktop. It's mostly working fine, but I have some issues with the network/connecting. Windows Update can't reach the update servers, and neither can the steam updater. Some websites don't load right/take forever to load, and the site will work fine on another computer. I think something is missing/didn't install right. Most sites work and my actual internet connection works, it's just a few specific sites and such that won't work.

I've tried turning my firewall and anti-virus off with no success. I've run the troubleshoot connections application and it doesn't find anything. Windows Fix-It finds issues and fixes them, but I still have the same connection issues. I've run MGA Diagnostic, I'm not sure if the results are relevant but I can post those. In my event log, I've had several errors related to not being able to find the browser master service. I don't know if that has anything to do with it.

Please help.

My System SpecsSystem Spec
.

Reply

 Connecting Issues with Windows 7





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:17 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33