Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: installed wireless card in desktop and wifi networks have no strength

02 Sep 2013   #1
maximus12

Windows 7 32 bit
 
 
installed wireless card in desktop and wifi networks have no strength

I recently installed a Dell wireless PCI 1520 card into a Dell XPS. I can see my home network but it shows no signal strength. I can connect to my wifi network with my smart phone and my wife's laptop can connect without a problem. The desktop will connect when hardwired. I've done the usual rebooting of the router modem and computer but still the same problem.


My System SpecsSystem Spec
.
02 Sep 2013   #2
Boozad

W7 Pro x64 SP1 | W10 Pro IP x64 | W8.1 Pro x64 VM | Linux Mint VM
 
 

Did you have an antenna supplied with the card?
My System SpecsSystem Spec
02 Sep 2013   #3
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by maximus12 View Post
I recently installed a Dell wireless PCI 1520 card into a Dell XPS. I can see my home network but it shows no signal strength. I can connect to my wifi network with my smart phone and my wife's laptop can connect without a problem. The desktop will connect when hardwired. I've done the usual rebooting of the router modem and computer but still the same problem.
The suggestions on the following page may be helpful in fixing this problem.

It sounds like Windows isn't picking up the card, it may help to shut down the PC, unplug power and push power button to bleed power, remove the Dell PCI NIC, reinstall the PCI NIC, then power back up and see if Windows can find it now.

Try the Dell site for the correct drivers.

Problem trying to install 1520 wireless card in XPS 8300. Can anyone help? - Networking, Internet, Wireless Forum - Networking, Internet, Wireless - Dell Community
My System SpecsSystem Spec
.

02 Sep 2013   #4
maximus12

Windows 7 32 bit
 
 

there was no antenna with the card. there are some stickers on both sides of the card. i was reluctant to remove them when installing. Is it possible that its causing problems. ive checked all the drivers and they are up to date. Gonna try removing the card and the stickers and reinstalling.
My System SpecsSystem Spec
02 Sep 2013   #5
xunile

Win 7 x64
 
 

Is this a laptop you are talking about?
My System SpecsSystem Spec
02 Sep 2013   #6
maximus12

Windows 7 32 bit
 
 

A Dell XPS desktop. The wifi card is internal
My System SpecsSystem Spec
02 Sep 2013   #7
xunile

Win 7 x64
 
 

Can you post a picture of the card? Is this a full size pci-e card or does it look like this:


Attached Images
 
My System SpecsSystem Spec
03 Sep 2013   #8
maximus12

Windows 7 32 bit
 
 

thats the one. do i peel off those stickers?
My System SpecsSystem Spec
03 Sep 2013   #9
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by maximus12 View Post
thats the one. do i peel off those stickers?
Peeling off the stickers won't help as the contacts for the PCI slot are already exposed.

It may take a couple of tries before the card is picked up by the machine or Windows. Shut down and bleed power before reinstalling the card.

Keep checking in Device Manager until the card shows up.
My System SpecsSystem Spec
03 Sep 2013   #10
xunile

Win 7 x64
 
 

the reason you cant connect is that card needs an antenna connected. the two contact points for the antenna are at the top of the card in the picture,there is a 1 and a 2 right below the two points. you need to see if your pc came with the antenna or you'll have to buy one. these kind of wifi adapters are usually used in laptops with the antenna built into the laptop
My System SpecsSystem Spec
Reply

 installed wireless card in desktop and wifi networks have no strength




Thread Tools




Similar help and support threads
Thread Forum
WiFi Limited Access, Signal Strength Excellent, works if I reconnect
Alienware X-51 Win 7 Home Premium SP1 Thompson TG585 v8 Modem /WPA2-PSK Scope of Problem: This is a Desktop LOADING based problem. NOT a connection dropping, fading while in use problem. Other Devices work fine. Same problem with previous Modem.
Network & Sharing
Need to increase the Wifi strength
Hello Friends I bought a connection from my ISP and they gave me a Wifi modem. My main issue is that the range of the device is only 10 Mtrs. I want to increase the range as I want my dad to use it. I know you will say that he can come in that 10 Mtr range and use it :D. But, the device is kept...
Network & Sharing
Wifi Adaptor is installed/enabled but Windows can't detect networks
I got a Dell E6220 with Windows 7 32bits. Our System Admin pushed the new A/V upgrade from Symantec 11 to Symantec 12 and that broke all the network connectivities including Ethernet and Wifi. I was able to run CleanWipe couple time and get rid of all the Symantec crap and checked the registry...
Network & Sharing
cant pickup my wifi with wireless card
ive just put a wirelss network card into my sons pc its a netgear wg311v3, when i scan i cant pick up my wireless network, it will pick up 2 or 3 others but not mine, i know my wifi is on because i can pick it up with my phone with a full signal. not sure if its the pc which is win7 64 or the...
Network & Sharing
Problems in ad-hoc wifi network - signal strength weak, unable to ping
Hi, I need some help with Win7 wifi. I'm trying to create an ad-hoc wifi network between my Windows 7 laptop (Toshiba c650) and my samsung wave y handset. My wifi card is atheros-AR9285. When I connect to this network from my wifi, connectivity is established, but with some problems: It...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App