Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Icon shown no internet but connection OK

07 Dec 2013   #1
Procrastinus

Windows 7 Home Premium
 
 
Icon shown no internet but connection OK

The network/internet connection icon in the task bar shows 'No Internet access' with a yellow exclamation mark and the Network and Sharing Centre shows a red X on the line. However I seem to have normal internet access!
What is going on?
The only recent change is that I had to reset Firefox with add-ons disabled, but that is all working normally now.


My System SpecsSystem Spec
.
07 Dec 2013   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Procrastinus View Post
The network/internet connection icon in the task bar shows 'No Internet access' with a yellow exclamation mark and the Network and Sharing Centre shows a red X on the line. However I seem to have normal internet access!
What is going on?
The only recent change is that I had to reset Firefox with add-ons disabled, but that is all working normally now.
There are many possible causes of this ongoing problem so it's hard to give a precise answer although it's usually easy to fix.

You can sometimes just disable and enable the connection at the "change adaptor settings" page or in Device Manager to clear up the problem although sometimes deleting all the wireless profiles will fix this problem. Depends on if the problem is with wired or wireless.

Most of the working solutions show up on one of 8 pages in the following Microsoft community thread.

Network icon show red "X" even though wireless adapter is - Microsoft Community
My System SpecsSystem Spec
08 Dec 2013   #3
Procrastinus

Windows 7 Home Premium
 
 

Thanks chev65. The link to MS Community produced this:

BillyHodgkinson asked on:
I had the same issue and this is how I solved it. Go to
services.msc set "WWAN AutoConfig" to automatic, and start the service.
In device manager uninstall ALL network adapters. Then right click and select "Scan Hardware For Changes" allow windows 7 to install the adapters. (No need to select remove driver)
This solved the problem for me.

Worked fine!
My System SpecsSystem Spec
.

08 Dec 2013   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Procrastinus View Post
Thanks chev65. The link to MS Community produced this:

BillyHodgkinson asked on:
I had the same issue and this is how I solved it. Go to
services.msc set "WWAN AutoConfig" to automatic, and start the service.
In device manager uninstall ALL network adapters. Then right click and select "Scan Hardware For Changes" allow windows 7 to install the adapters. (No need to select remove driver)
This solved the problem for me.

Worked fine!
Yes, you are welcome, there were so many possible solutions in that link I wasn't sure which one would work. That solution looked like one of the more promising ones I saw there.

Thanks for reporting back in with the solution.
My System SpecsSystem Spec
10 Nov 2015   #5
hoswizzle

Windwos 7 64 bit
 
 

This fixed it, However the problem just comes back in a few days. This does not PERMANENTLY fix this issue. Anyone find a permanent fix for this?
My System SpecsSystem Spec
29 Jan 2016   #6
gswzero

Windows 7 Professional x64
 
 
Restart NLA service

Open services.msc and restart Network Location Awareness. This usually solves almost all UI indicators went awry.
My System SpecsSystem Spec
18 Jun 2016   #7
Jim Spriggs

Windows 7 32 bit
 
 

This worked immediately, gswzero, and it only took about a minute. Thanks! Let's see if it stays this way next time I check this particular computer here at work.
My System SpecsSystem Spec
19 Jun 2016   #8
asama2014

Windows 10 Home x64
 
 

I got this problem and this is My Solution:
1. go Start search msconfig then Enter,
2. click Services, then make sure the 'hide all microsoft services' is Untick.
3. Find "Windows Event Log" and "Windows Event Collector" make sure each boxes is Tick,
4. Apply and OK, restart the pc.
My System SpecsSystem Spec
Reply

 Icon shown no internet but connection OK




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
'Bluetooth connection' is shown in my Network Connection suddnly.
Hi, I really had not this 'Bluetooth connection' before. But, I really don't know that pairing my Nokia Bluetooth with my HP Laptop Bluetooth would add this Bluetooth connection or NOT. I really guess this Bluetooth Connection was listed there when I connected my Lapotp Bluetooh with Nokia...
Network & Sharing
Yellow Triangle of Death on Internet Connection Icon, What can I do?
*I've bolded the main points for you Good morning everyone! I am currently doing all my schooling online and was supplied with a Lenovo Think Pad laptop that has Windows 7 Pro running. It's been a few months since I had it and it was working perfect at the beginning, but for the last two...
Network & Sharing
Image icon shown as standard icon
Hi all, After formatting my pc whenever I open a folder with images, the icons are standard icon and not a preview of the image. Why? I have to click the icon in order to see which image is it. I have 7 ultimate Thanks for help
Music, Pictures & Video
Wireless connection icon freezing but still connected to the internet
Hi all, I have been having this problem for over a month now. It first started on my old laptop which is now sadly defunct due to a graphics card issue and is no longer on the network, however, the issue has now transferred to 2 other laptops over the space of a few weeks. A basic overview...
Network & Sharing
Internet connection icon missing from systray
Hi, I turned on my Dell Laptop running W7 today and the "2 tv's and globe" icon showing that you are connected to the Internet is missing from the systray. Thankfully I'm connected to the Internet, however it is very annoying and mystifying that this icon has just disappeared. I've gone into the...
General Discussion
internet connection icon in tray is not blinking ?
How to get the internet icon to get blinking as in win xp ?
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:44.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App