Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Linksys E3200; Awful Wi-Fi Performance

20 Dec 2013   #1
NKTechGuy

Windows 7 Ultimate x64
 
 
Linksys E3200; Awful Wi-Fi Performance

I have been having endless problems with this E3200 router. Almost every week there is something that needs changed in the web configuration page. As of now, I am having a download speed of about .38 Mbps (14.98 through modem directly). and about .45 up (.98 through modem directly). I have tried changing channels and even upgrading the firmware. I also reset the router after the firmware upgrade and it worked great for about a week. Today I have spent the last 2 hours trying to figure out what's going on and I have just given up, I have absolutely no more ideas and have tried every resolution on lots of forums and to no avail.
Any help on this would really be appreciated!


My System SpecsSystem Spec
.
21 Dec 2013   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

NK mate how old is the router? Depending on that I would either RAM it or get another brand I personally like TP-Link stuff.

You might like to run these first though

http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html

http://www.sevenforums.com/tutorials/433-disk-check.html< DO NOT runon a SSD

http://www.superantispyware.com/

http://www.malwarebytes.org/products/malwarebytes_free/

http://www.bleepingcomputer.com/download/adwcleaner/

download from bleeping computer delete any rubbish these find.
My System SpecsSystem Spec
21 Dec 2013   #3
NKTechGuy

Windows 7 Ultimate x64
 
 

We bought it from Radioshack in June of 2011, so it's not that old. We had a WRT54G for about 7 years before we replaced it with this E3200.
My System SpecsSystem Spec
.

21 Dec 2013   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

If you want help with this problem it's best to make an educated decision on which channels and router settings to use rather than just guessing. Please download the InSSIDer software and post a screen shot of the results here.

inSSIDer for Home ? Discover The Wi-Fi Around You | MetaGeek
My System SpecsSystem Spec
21 Dec 2013   #5
NKTechGuy

Windows 7 Ultimate x64
 
 

Linksys E3200; Awful Wi-Fi Performance-scrnsht2.png
This is all that came up. I have tried refreshing the program and it still looks the same. It's working fine now, but usually once every day or two it will just completely drop like it did last night and stay like that for several hours.


My System SpecsSystem Spec
21 Dec 2013   #6
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Do you do realize that you are using wireless G which is limited to 54Mbps and is also outdated by over 10 years.

Clear signal with nobody around, wish it was like that here.

So first to set this up for the router to use the 802.11n Only mode which is the only way to achieve true wireless N speeds of up to 450Mbps.

I'll assume the wireless NIC is wireless N capable?

In the routers set up page for wireless, you will see something like mixed a b g or N only mode, you want the N only setting.

With this clear of a signal your router also has a setting for channel bonding which is usually shows up as 20 or 40 Mhz, you want the 40Mhz setting here which bonds channels to give the best possible bandwidth. With a clear signal like you have you will want to use channel bonding.

You haven't mentioned the make, or brand of the wireless NIC you are using, either PCI-e or USB we need to make sure the driver is updated WHQL Windows approved driver.
My System SpecsSystem Spec
21 Dec 2013   #7
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Yes Chev it is and this is the download stuff for it E3200 Support | High Performance Dual-Band N Router
My System SpecsSystem Spec
21 Dec 2013   #8
NKTechGuy

Windows 7 Ultimate x64
 
 

Chev65: I am using a Realtek RTL8192CE WLAN PCIe card. The driver is up to date. I am using wireless G because when I switched it from N-Only to G-Only, it seemed to help a lot with the speed. I use mixed mode mostly, and that's because some of the devices on my network aren't compatible with wireless-N. I also have the frequency set to 20MHz (auto makes the performance god awful--I was forced to use LAN to even change it back to 20MHz).
My System SpecsSystem Spec
21 Dec 2013   #9
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

NK is there any way you can use N on this machine only it is the source of your problem mate.
My System SpecsSystem Spec
22 Dec 2013   #10
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by NKTechGuy View Post
Chev65: I am using a Realtek RTL8192CE WLAN PCIe card. The driver is up to date. I am using wireless G because when I switched it from N-Only to G-Only, it seemed to help a lot with the speed. I use mixed mode mostly, and that's because some of the devices on my network aren't compatible with wireless-N. I also have the frequency set to 20MHz (auto makes the performance god awful--I was forced to use LAN to even change it back to 20MHz).
You are handcuffing your entire network using mixed mode. Faster in G mode, this is a joke right, if it seems faster in G mode then it's time to update the Realtek NIC.

If you need G mode for legacy devices then set up the old router as an access point for G and use the new router for N only.

Maximum PHY data rate for this NIC up to 144.4Mbps using 20MHz bandwidth, 300Mbps using 40MHz bandwidth, notice how the potential speed more than doubles by just switching to 40Mhz dual band mode.

This Realtec NIC it's been around since the XP days and it's not even dual band so upgrading the Realtek PCI-e to a more updated dual band version to match the router might also help but don't expect any decent performance in mixed mode using this NIC.

All problems here are fixable but there is no magic button fix for this, either make the required changes to the network or continue with poor network speeds so good luck.
My System SpecsSystem Spec
Reply

 Linksys E3200; Awful Wi-Fi Performance




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Why sharing over bluetooth is so awful?
Hi guys ok, i can stand this anymore, i have been experiencing this since my fist steps in windows 7, since windows 7 basic edition, spanish, then english then professional, then 64bit, in this computer, my mom's computer friends computers.... trying to share files with my phone, other phones...
Network & Sharing
What is better? Linksys WRT54G2 or Linksys WRT54GL?
Title says it all
Network & Sharing
Odd problem with Linksys WUSB 100 in connection with linksys WRT110
Hi all! I have home network consisting of 4 Desktops (1 W7, 2XP, 1 Vista)and 1 Laptop (W7). All connect to WRT110. 2 via cable, two via WUSB100 and the laptop via build in WiFi device. The actual problem: whenever the Vista computer connects via one WUSB100 (after a reboot or on initial start)...
Network & Sharing
Why are media players so awful?
I have used various media players and most of them are awful. My favourite media player is WMP 10! WMP 10 The layout isn't too bad and there are only a few haphazard control/option placements. The library is reasonably easy to use. This player is the one I use in XP. Winamp The...
Music, Pictures & Video
New Headset and a really awful noise
Hello. I bought a new headset and when I use it to chat with my Friends on skype, they all complain because they hear a machiny noise.... like the computer ventrilator or somethings... no matter the distance between the computer and the mic.... they always hear the noice. The other problem...
Sound & Audio
some of my games look awful. Aero, perhaps?
The specs on my graphics are a standard Intel onboard GMA X4500. It's decent, if not gamer-perfect. I can run Postal 2, Half-Life 2 and Portal all at max settings and Doom 3 at medium. My problem seems to be with a few games.... in general, on-screen fonts look bad in many games. I think...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App