Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Atheros AR9285 constantly disconnecting/reconnecting

10 Jan 2014   #1
MillsyUK

Windows Seven Home Premium 64bit
 
 
Atheros AR9285 constantly disconnecting/reconnecting

Hi there,

I have an HP DV7 4010-TX bought from Australia roughly 4 years ago, I am now residing in the UK. For the past few days I have been having problems with my wireless card (Atheros AR9285) constantly disconnecting and reconnecting to my network as well as timing out whilst loading websites etc. This seems to be getting progressively worse; started off every half hour and now every two minutes. I have also noticed that the signal strnegth is now only good compared to excellent before.

So far I have uninstalled and reinstalled my card using the latest drivers as well as some previous ones, reset my internet protocol setting using command prompt and tried to use the windows troubleshooter which finds no problem as the network connects again before it detects that there is no internet connection. All other devices in the house using wireless work fine, xbox 360, other laptops and mobile phones. The computer has been on the same desk for two years with the router in the same place with no real problems.

Is there anything further that I can try or does it look as if my wireless card is dying? If so can anyone recommend a suitable replacement for me. If there's anything I have missed out please let me know, little new to this kind of stuff.

Thanks for any help and suggestions!

Cheers,

Millsy


System Specs


Operating System
Windows 7 Home Premium 64-bit SP1

CPU
Intel Core i7 720QM @ 1.60GHz 50 C
Clarksfield 45nm Technology

RAM
8.00GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)

Motherboard
Hewlett-Packard 1449 (CPU) 50 C

Graphics
Generic PnP Monitor (1600x900@60Hz)
VX2239 SERIES (1920x1080@60Hz)
ATI Mobility Radeon HD 5650 (HP) 50 C

Storage
596GB Western Digital WDC WD6400BPVT-00HXZT1 (SATA) 29 C

Optical Drives
DTSOFT Virtual CdRom Device
hp DVDRAM GT30L

Audio
ATI High Definition Audio Device




Network



You are connected to the internet
Connected through Atheros AR9285 802.11b/g/n WiFi Adapter
IP Address 192.168.1.76
Subnet mask 255.255.255.0
Gateway server 192.168.1.254
Preferred DNS server 208.67.220.220
DHCP Enabled
DHCP server 192.168.1.254
External IP Address 91.125.177.81
Adapter Type IEEE 802.11 wireless
NetBIOS over TCP/IP Enabled via DHCP
NETBIOS Node Type Hybrid node
Link Speed 0 Bps

Computer Name
NetBIOS Name MILLS-PC
DNS Name Mills-PC
Membership Part of workgroup
Workgroup WORKGROUP

Remote Desktop
Disabled
Console
State Active
Domain Mills-PC
EH-Tcp
State Listen

WinInet Info
LAN Connection
Local system uses a local area network to connect to the Internet
Local system has RAS to connect to the Internet

Wi-Fi Info
Using native Wi-Fi API version 2
Available access points count 1
Wi-Fi (PlusnetWirelessB394D0)
SSID PlusnetWirelessB394D0
Frequency 2412000 kHz
Channel Number 1
Name PlusnetWirelessB394D0
Signal Strength/Quality 42
Security Enabled
State The interface is connected to a network
Dot11 Type Infrastructure BSS network
Network Connectible
Network Flags Currently Connected to this network
Cipher Algorithm to be used when joining this network AES-CCMP algorithm
Default Auth used to join this network for the first time 802.11i RSNA algorithm that uses PSK

WinHTTPInfo
WinHTTPSessionProxyType No proxy
Session Proxy
Session Proxy Bypass
Connect Retries 5
Connect Timeout (ms) 60,000
HTTP Version HTTP 1.1
Max Connects Per 1.0 Servers INFINITE
Max Connects Per Servers INFINITE
Max HTTP automatic redirects 10
Max HTTP status continue 10
Send Timeout (ms) 30,000
IEProxy Auto Detect No
IEProxy Auto Config
IEProxy
IEProxy Bypass
Default Proxy Config Access Type No proxy
Default Config Proxy
Default Config Proxy Bypass

Sharing and Discovery
Network Discovery Enabled
File and Printer Sharing Enabled
File and printer sharing service Enabled
Simple File Sharing Enabled
Administrative Shares Enabled
Network access: Sharing and security model for local accounts Classic - local users authenticate as themselves

Adapters List
Microsoft Virtual WiFi Miniport Adapter
Connection Name Wireless Network Connection 2
DHCP enabled Yes
MAC Address C2-46-19-13-25-35
Atheros AR9285 802.11b/g/n WiFi Adapter
Connection-specific DNS Suffix lan
Connection Name Wireless Network Connection
NetBIOS over TCPIP Yes
DHCP enabled Yes
MAC Address C4-46-19-13-25-35
IP Address 192.168.1.76
Subnet mask 255.255.255.0
Gateway server 192.168.1.254
DHCP 192.168.1.254
DNS Server 208.67.220.220
EasyTether Network Adapter
Connection Name Local Area Connection 2
DHCP enabled Yes
MAC Address 02-00-54-74-68-72
Bluetooth Device (Personal Area Network)
Connection Name Bluetooth Network Connection
DHCP enabled Yes
MAC Address 70-F3-95-53-9C-01

Network Shares
Users C:\Users
HP psc 1600 series HP psc 1600 series,LocalsplOnly

Current TCP Connections
C:\Program Files (x86)\Mozilla Firefox\firefox.exe (11460)
GeekBuddyRSP.exe (1320)
lsass.exe (644)
postgres.exe (2428)
services.exe (636)
spoolsv.exe (1536)
svchost.exe (1080)
svchost.exe (3240)
svchost.exe (396)
svchost.exe (648)
svchost.exe (928)
System Process
System Process
wininit.exe (560)
wmpnetwk.exe (3600)


My System SpecsSystem Spec
.
10 Jan 2014   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Have you tried starting up in safe mode with networking? If the problem seems to go away in safe mode then you can be sure than an installed program or software is causing the problem.
My System SpecsSystem Spec
11 Jan 2014   #3
MillsyUK

Windows Seven Home Premium 64bit
 
 

Hi,

Have just tried safe mode with networking, exactly same problem.

Where do I go from here? I am happy to buy a replacement wireless card if that is the most likely cause. I am not sure what card to order though as from what I have read the bios on my computer will only work with certain cards? Not sure if this is correct but I would like to upgrade the card instead of a like for like replacement if possible and don't want to order something that isn't compatible. Is there an easy way of determining this?

Is there anything else to try before giving up and ordering a new card?

Thanks for your help.
My System SpecsSystem Spec
.

11 Jan 2014   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by MillsyUK View Post
Hi,

Have just tried safe mode with networking, exactly same problem.

Where do I go from here? I am happy to buy a replacement wireless card if that is the most likely cause. I am not sure what card to order though as from what I have read the bios on my computer will only work with certain cards? Not sure if this is correct but I would like to upgrade the card instead of a like for like replacement if possible and don't want to order something that isn't compatible. Is there an easy way of determining this?

Is there anything else to try before giving up and ordering a new card?

Thanks for your help.
Yes try running the following command in an elevated command prompt, this is just to check if the system files are not corrupted which is a common problem.

Code:
sfc /scannow
My System SpecsSystem Spec
11 Jan 2014   #5
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

this may sound daft, but can you right click on the wifi icon on the systems tray, select "open network and sharing center"

to the left of the window that opens click change adapter settings.

then right click on your wifi adapter when it shows.
click disable then when its disabled right click it and select enable.
i used to have trouble with the same card.
this would help.

i also used to update the drivers from here

Station-Drivers - Qualcomm-Atheros (Wireless)
My System SpecsSystem Spec
11 Jan 2014   #6
MillsyUK

Windows Seven Home Premium 64bit
 
 

Thanks for your replies.

Chev:

Did sytem scan, appears no problems -



Boohbah: I have tried about 4 different driver versions, currently using a set that fixed the same problem for several people, I'm unable to find the forum thread again though. They seemed to solve it for me for a day or so but the problem has now returned. Tried disabling/enabling, same results as before. I'll give the ones from that site a go.

I don't know if the following screen using Xirrus wifi inspector provides any information. Had it on my computer so felt may as well put it on here.



Anything else I can try?

Thanks to both of you for your help.
My System SpecsSystem Spec
11 Jan 2014   #7
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by MillsyUK View Post
Thanks for your replies.

Chev:

Did sytem scan, appears no problems -



Boohbah: I have tried about 4 different driver versions, currently using a set that fixed the same problem for several people, I'm unable to find the forum thread again though. They seemed to solve it for me for a day or so but the problem has now returned. Tried disabling/enabling, same results as before. I'll give the ones from that site a go.

I don't know if the following screen using Xirrus wifi inspector provides any information. Had it on my computer so felt may as well put it on here.



Anything else I can try?

Thanks to both of you for your help.
Well it's not a system file problem however, the signal strength I'm seeing here is very unlikely to create a reliable connection. You might try using a different channel for the wireless like 11 or 6 but with this low signal strength you should expect a non reliable connection.
My System SpecsSystem Spec
11 Jan 2014   #8
MillsyUK

Windows Seven Home Premium 64bit
 
 

The signal strength always used to be stronger, it would say excellent whereas now it says fair. There are about four other networks nearby that used to show up as well but my computer can no longer find them. Is this an indication that my card is slowly dying? Neither my laptop or router have moved. Maybe best thing is to just buy a replacement card, they seem fairly cheap from what I have seen.

OK. If I change the channel do I have to change this on devices in the house or will they just connect as normal?

Last question, sorry! If the card dies before I have a replacement will I still be able to use a wired connection with my laptop in the meantime? I do half of my work from home and use the internet heavily for this.

Thanks for all your help.
My System SpecsSystem Spec
11 Jan 2014   #9
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by MillsyUK View Post
The signal strength always used to be stronger, it would say excellent whereas now it says fair. There are about four other networks nearby that used to show up as well but my computer can no longer find them. Is this an indication that my card is slowly dying? Neither my laptop or router have moved. Maybe best thing is to just buy a replacement card, they seem fairly cheap from what I have seen.

OK. If I change the channel do I have to change this on devices in the house or will they just connect as normal?

Last question, sorry! If the card dies before I have a replacement will I still be able to use a wired connection with my laptop in the meantime? I do half of my work from home and use the internet heavily for this.

Thanks for all your help.
The channel is changed on the routers WiFi settings. You may also see better performance when using the 802.11N Only setting versus the Mixed WiFi settings.

Yes the cards aren't very expensive but I'm not sure why it would suddenly lose signal strength. Resetting the router may help in this case. The wired connection should still be fine, completely different connection for that.

I'm not sure what the Easy Tether network is but if it's used to create a secondary access point then it may be causing problems with your wireless connection.
My System SpecsSystem Spec
11 Jan 2014   #10
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

i would be inclined to ring the isp to check the connection to the router from them.
Depending who it is
they will have a load of info and even go so far as to remote connect and check things out.
My System SpecsSystem Spec
Reply

 Atheros AR9285 constantly disconnecting/reconnecting




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Mouse constantly disconnecting/reconnecting, already tried many fixes
My Steelseries Diablo 3 mouse is constantly disconnecting and reconnecting from my computer for ~3-30 seconds at a time and occasionally becomes unresponsive until I restart the computer (unplugging and reconnecting mouse won't even bring it back online). When this happens, the computer makes the...
Hardware & Devices
Atheros AR9285
I am very new to this.. So I am going to explain the best I can and maybe someone can help me. I have a new laptop, and I filled out my specs with this forum, I have Windows 7 HP*64 bit and I also have home wireless 6.0. I have a clearwire modem running off of a Lynksys wireless modem. This morning...
Hardware & Devices
Atheros ar9285 connectivity issues
Hi, I just resonantly I bough a brand new Desktop that came with a Atheros ar9285 internet USB chip and I'm unable to connect to my Hitron Technologies Modem (model CGN2-ROG). I've tried almost everything already to connect to my modem but its all failed. Any suggestions to fix this problem? I'm...
Network & Sharing
Promblem with Atheros AR9285 wireless Network Adapter-disconnecting
Hello folks, Seriously need a Helping Hand here, I bought a Samsung R540 last yr (Oct) everything worked awesome. I have been using wireless internet since i got it, Recently I bought star wars and been dying to play it. Was going great at first but then started getting connection problems. So...
Network & Sharing
Where can I get Atheros WNA AR9285 and ATA/ATAPI AHCI drivers
Hi, Have been looking all over the internet for these drivers, but without luck. I think the latest Atheros is 9.93, and I have 8.0.0. In another thread someone suggested PCPitStop - another one of those FREE driver sites, where you can get all the drivers you need; once you "register". I.e...
Drivers
atheros ar9285 802.11b/g/n
Hey guys, I have the above-listed wireless card on my laptop. Up until the past two days, it was working fine, but now it disconnects from my school network numerous times (almost every five minutes). It'll say it can't find any networks. I even system restored to yesterday, and it's still giving...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App