Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No connectivity on ethernet, card was previously working

23 Mar 2014   #1
na85

Win 7 x64
 
 
No connectivity on ethernet, card was previously working

Hi friends,

The other day my desktop's ethernet card (Realtek, built into my Asus z87 mobo) apparently stopped working. After multiple reboots etc. it now continually tells me I have "No network access" on "unidentified network" and no matter what I do I cannot access any network resources. Can't even ping the router.

Other computers and devices can get online, both wirelessly and via the hard line so I'm confident in ruling out my router as the culprit - it's definitely a problem with the desktop.

Antivirus detects no malware. Windows reports that the device is working correctly if I examine the network adapter in Control Panel.

It's not a driver issue either: Nothing in the configuration has changed between the system working and not working. I simply shut it down one night after playing some games, and then in the morning it was no longer working.

How can I troubleshoot this?


My System SpecsSystem Spec
.
23 Mar 2014   #2
na85

Win 7 x64
 
 

I have no idea how, but it started working again magically.

It had been not working for 3 or 4 days, powered off, power bar also off.

I downloaded malwarebytes and was running a full scan when the system froze. When I started it back up the network card was not recognized. I thought maybe it was the Realtek "deep sleep" issue, but un-/re-installing drivers did not help.

I took the system apart after my previous post intending to see if I had room to just put in a discrete gigabit NIC in lieu of my broken onboard. Yup, I have a spare x1 PCIe port but I live in a small crappy town so all the PC stores are closed sundays. I put the system back together and booted it back up intending to play some singleplayer games or something, but then the networking started working just fine.

I have no idea, I didn't change anything but it now works
My System SpecsSystem Spec
24 Mar 2014   #3
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

What happens is they get loose or dirty in the PCI slot and lose connection. Often times just powering down and unplugging the system then bleeding power by pushing the start button then remove and reinstall the PCI NIC will fix these types of problems.
My System SpecsSystem Spec
.

Reply

 No connectivity on ethernet, card was previously working




Thread Tools




Similar help and support threads
Thread Forum
How do I install a Ethernet Card?
This thread is for a friend who needs help with her internet connection. She had Windows 7 installed on her HP Compaq, now she doesn't have a internet connection. I bought a internet card to install for her but I'm not sure how do install it. It is windows 7 compatible. Is there anything else I...
Network & Sharing
USB previously working not recognized
Hi everybody, I read the topics in the forum, but I did not found something that suits my needs, so I start a new thread. I'm running a Windows 7 Enterprise 64bit on a nHP EliteBook 8470p laptop, and I'm experiencing a strange issue. Connecting a USB device to the port, it works properly for...
Hardware & Devices
Delayed Ethernet connectivity after wake
Hello all, I've been having a very weird problem for a while now and can't seem to find anyone else who has experienced my version. Whenever I wake my PC from sleep the network adapter does not detect any networks (can't access my router either). When I run the diagnostic tool and it says that...
Network & Sharing
Previously working computer now BSODs with new CPU installed
EDIT: Problem has changed, I have created a new thread as the previous title no longer accurately described the problem.
BSOD Help and Support
Ethernet card not being recognized...
Hi all, I'm really glad I stumbled across this forum whilst on a mad scramble to find an answer to my question. I installed the 7022 x86 version of Windows 7. Everything installed fine and there were driver issues which I anticipated but my Ethernet port is not working on W7 or any other OS...
Network & Sharing
ICS with LAN/Ethernet Card and Wireless
Hello, are we can make ICS with Ethernet and wireless at same time? If can, how to apply it?
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App