Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No connectivity on ethernet, card was previously working


23 Mar 2014   #1

Win 7 x64
 
 
No connectivity on ethernet, card was previously working

Hi friends,

The other day my desktop's ethernet card (Realtek, built into my Asus z87 mobo) apparently stopped working. After multiple reboots etc. it now continually tells me I have "No network access" on "unidentified network" and no matter what I do I cannot access any network resources. Can't even ping the router.

Other computers and devices can get online, both wirelessly and via the hard line so I'm confident in ruling out my router as the culprit - it's definitely a problem with the desktop.

Antivirus detects no malware. Windows reports that the device is working correctly if I examine the network adapter in Control Panel.

It's not a driver issue either: Nothing in the configuration has changed between the system working and not working. I simply shut it down one night after playing some games, and then in the morning it was no longer working.

How can I troubleshoot this?


My System SpecsSystem Spec
.

23 Mar 2014   #2

Win 7 x64
 
 

I have no idea how, but it started working again magically.

It had been not working for 3 or 4 days, powered off, power bar also off.

I downloaded malwarebytes and was running a full scan when the system froze. When I started it back up the network card was not recognized. I thought maybe it was the Realtek "deep sleep" issue, but un-/re-installing drivers did not help.

I took the system apart after my previous post intending to see if I had room to just put in a discrete gigabit NIC in lieu of my broken onboard. Yup, I have a spare x1 PCIe port but I live in a small crappy town so all the PC stores are closed sundays. I put the system back together and booted it back up intending to play some singleplayer games or something, but then the networking started working just fine.

I have no idea, I didn't change anything but it now works
My System SpecsSystem Spec
24 Mar 2014   #3

Windows 7 Ult, Windows 8.1 Pro,
 
 

What happens is they get loose or dirty in the PCI slot and lose connection. Often times just powering down and unplugging the system then bleeding power by pushing the start button then remove and reinstall the PCI NIC will fix these types of problems.
My System SpecsSystem Spec
.


Reply

 No connectivity on ethernet, card was previously working




Thread Tools



Similar help and support threads for2: No connectivity on ethernet, card was previously working
Thread Forum
USB previously working not recognized Hardware & Devices
No internet connectivity and PC will not recognize ethernet Network & Sharing
Delayed Ethernet connectivity after wake Network & Sharing
Previously setup network not working??? Network & Sharing
VIA velocity ethernet -- No good on X-64 - Limited Connectivity Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:57 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33