Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Odd Wireless Issue

01 Feb 2009   #1
MerchantMilan

Vista and 7
 
 
Odd Wireless Issue

I did search through this forum, but did not see anything similar to my problem.

I installed Windows 7 on an older laptop that has a Linksys PCMCIA (WPC54G) card adapter. Windows Update found the correct driver and it installed fine. I can find my wireless network and it will show signal strength, security type, SSID, etc. When I click Connect, it immediately says "Windows was unable to connect to <SSID>." I know the password is correct and the wireless is working, as I'm currently using wifi on my main PC. I was using this card with the previous XP installation and it has worked fine for years.

I tried a few things I read about here, such as diabling IPv6 and the Windows Firewall, but to no avail. Any other ideas or is this just a beta issue?


My System SpecsSystem Spec
.

01 Feb 2009   #2
Deimateos

Windows 7 beta
 
 

Have you tried checking the wireless properties box that says "Connect even if the network is not broadcasting its name (SSID)"?
My System SpecsSystem Spec
01 Feb 2009   #3
Barman58

Windows 8.1 Pro x64 x3 + Windows 10 Preview, Ubuntu
 
 

hello MerchantMilan, and welcome to the Seven Forums

There have been problems with the older Linksys hardware since the release of vista, this has been mostly with the routers and they have made firmware updates available to correct the issues. you may want to check out the linksys site to see if your adaptor has a workaround / firmware update available
My System SpecsSystem Spec
.


02 Feb 2009   #4
MerchantMilan

Vista and 7
 
 

Thanks for the tips guys. I did a little more research and apparently they never released a Vista driver for my version of the card. I guess that means it won't work on Vista or 7. Kinda weird how Windows Update found a driver for it though...
My System SpecsSystem Spec
03 Feb 2009   #5
TripOG

windows 7 X64
 
 

my friend has the same problem with his... sometimes it will connect other times it will give the same error.... we installed dd wrt on his router and it looked like it fixed the problem then it just poped back up again
My System SpecsSystem Spec
03 Feb 2009   #6
MerchantMilan

Vista and 7
 
 

I just ordered a new card for $20 online that's compatible with Vista. I'll report back and let the thread know if that fixes the problem.
My System SpecsSystem Spec
05 Feb 2009   #7
MerchantMilan

Vista and 7
 
 

Just got my new PCMCIA card in this afternoon and it worked perfect. So the problem was with my Linksys card not having proper Vista drivers. Thanks for the help anyway guys.
My System SpecsSystem Spec
16 Feb 2009   #8
TripOG

windows 7 X64
 
 

i hear 32bit Vista drivers for WMP300N v1 will work with the wpc54g card, i have not tested to verify though....

edit: you use the connection software from the wmp300n v1 then you install the xp wpc54g drivers
My System SpecsSystem Spec
Reply

 Odd Wireless Issue




Thread Tools





Similar help and support threads
Thread Forum
Odd W7 Wireless issue..
So I recently moved from a wired connection (10Mb/s+) to a wireless connection. This wouldn't seem to be an issue, as my dad's mac laptop connects from my room with 10,XXX+ kb/s. But! My computer will not exceed ~300 Kb/s down, although it gets ~4.1 ***Mb/s*** up. ...
Network & Sharing
wireless issue
i having some random dcs of no internet access after i upgraded my dell inspiron 1525 from vista to 7 and my wireless signal normally at 2 bars only not at 4 or 5 i thot it could be my router (netgear WGR614v7 ) but im the only one having this problem at home on the wifi im leading upon the...
Network & Sharing
Wireless issue
Hi there, i am having some weird problems with my wireless on W7, i use a wireless usb pen and everything was working fine, yesterday i unplugged the wireless pen and i plugged it back and for my surprise the wireless wasn't working, i've reinstalled her software. The computer detects the pen...
Network & Sharing
Wireless Mouse issue
The mouse is a Microsoft wireless laptop, 3000 model. Works great. Great that is, until I hooked up external laptop speakers. They obviously plug into the green jack, but now the wireless mouse just drags s-l-o-w-l-y across screen. Unplug speakers, and mouse works great. Is there a fix for...
Hardware & Devices
Same Old Wireless Issue!
I know a lot of people are having this same problem, but I just can't seem to fix it. I searched old threads, but nothing has worked. I just bought a new ASUS U50A laptop, which has Windows 7 and an Atheros ar8131 LAN driver. I have a 2Wire router with WEP encryption. All my other notebooks...
Network & Sharing
Wireless PCI Driver Issue
Hey everyone, I've just recently installed Windows 7 on my desktop PC, upgrading from XP and most of the things had ran smoothly, accept for my network driver. The network won't recognize my internet signal, and because of this i cant update anything directly from my PC. My wireless card...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App