Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet not working yet network is connected.

16 May 2014   #11
UsernameIssues

W7 Pro SP1 64bit
 
 

You can try installing MSE using the safe mode with networking or you can download the entire MSE file onto a flash drive using your other computer.

Download Microsoft Security Essentials from Official Microsoft Download Center

You can also download the signature file from the middle of this web page:
https://www.microsoft.com/security/p...?wa=wsignin1.0


My System SpecsSystem Spec
.
16 May 2014   #12
Matthew Harbuz

Windows 7 Home Premium 64 Bit
 
 

Quote   Quote: Originally Posted by UsernameIssues View Post
You can try installing MSE using the safe mode with networking or you can download the entire MSE file onto a flash drive using your other computer.

Download Microsoft Security Essentials from Official Microsoft Download Center

You can also download the signature file from the middle of this web page:
https://www.microsoft.com/security/p...?wa=wsignin1.0
Ok so I've booted the computer in safe mode with networking and it looks like this... In normal mode it says that I'm connected and that everything is fine...


Attached Thumbnails
Internet not working yet network is connected.-image.jpg  
My System SpecsSystem Spec
16 May 2014   #13
UsernameIssues

W7 Pro SP1 64bit
 
 

Go ahead and install MSE via the links provided and a flash drive/stick.

Then try the clean boot troubleshooting.

Since the connectivity issue might be caused by malware, we don't want you connected to the internet without some level of antivirus install.

It sure sounds like some app is actively changing your DNS settings. If you correct your DNS settings while in the safe mode with networking - do they hold or get changed back?
My System SpecsSystem Spec
.

16 May 2014   #14
Matthew Harbuz

Windows 7 Home Premium 64 Bit
 
 

Quote   Quote: Originally Posted by UsernameIssues View Post
Go ahead and install MSE via the links provided and a flash drive/stick.

Then try the clean boot troubleshooting.

Since the connectivity issue might be caused by malware, we don't want you connected to the internet without some level of antivirus install.

It sure sounds like some app is actively changing your DNS settings. If you correct your DNS settings while in the safe mode with networking - do the hold or get changed back?
Alright well I'm at the cricket now so I'll probably have to do that tomorrow. (Just if you wonder why I don't reply today)
My System SpecsSystem Spec
16 May 2014   #15
TheCyberMan

Windows 7 Ultimate x64
 
 

From your Ipconfig /all Your DNS is 127.0.0.1 which is pointing at itself which isn't a DNS server.

Do an ipconfig /all from a machine which has internet access and post please.
My System SpecsSystem Spec
17 May 2014   #16
Matthew Harbuz

Windows 7 Home Premium 64 Bit
 
 

Quote   Quote: Originally Posted by TheCyberMan View Post
From your Ipconfig /all Your DNS is 127.0.0.1 which is pointing at itself which isn't a DNS server.

Do an ipconfig /all from a machine which has internet access and post please.
OK here is the ipconfig/all from the family computer which has internet access (sorry for the background, that's my brothers


Attached Thumbnails
Internet not working yet network is connected.-ipconfig.jpg  
My System SpecsSystem Spec
17 May 2014   #17
tro0perz1

Windows 7 Ultimate x64
 
 
nvidia networking controller for windows 7 32bit is missing

nvidia networking controller for windows 7 32bit is missing!

can anyone help me? when i open the device manager and view network adapter i saw nvidia networking controller that has this exclamation point (" ! ") and also my lan ports is totaly not blinking. thanks and need help.
My System SpecsSystem Spec
17 May 2014   #18
Matthew Harbuz

Windows 7 Home Premium 64 Bit
 
 

Quote   Quote: Originally Posted by tro0perz1 View Post
nvidia networking controller for windows 7 32bit is missing!

can anyone help me? when i open the device manager and view network adapter i saw nvidia networking controller that has this exclamation point (" ! ") and also my lan ports is totaly not blinking. thanks and need help.
Could you start your own thread please, trying to solve 2 different problems on the same thread will confuse things.
My System SpecsSystem Spec
17 May 2014   #19
Matthew Harbuz

Windows 7 Home Premium 64 Bit
 
 

Ok so I've booted the computer in a clean startup, checked the box that says "Obtain DNS server address automatically" opened chrome, browsed the internet for about 10 seconds and then it didn't work again. Checked the DNS server and it had changed to this as it always does.

I'm at my wits end here...


Attached Thumbnails
Internet not working yet network is connected.-image.jpg  
My System SpecsSystem Spec
17 May 2014   #20
UsernameIssues

W7 Pro SP1 64bit
 
 

Download Process Monitor to a USB flash drive.
There is nothing to install.
Just unzip and copy Procmon.exe to the desktop of the problematic computer.

Start Process Monitor (run as admin).
Accept the EULA.

When it starts for the first time, it automatically starts gathering data.
You can stop that via the button/icon with the magnifying glass.
Then de-select the 3 buttons/icons shown in the right part of this image:

Internet not working yet network is connected.-pm1.png


Clear the data that was gathered:

Internet not working yet network is connected.-pm2.png


Add a filter for the IP address of interest:

Internet not working yet network is connected.-pm3.png


Add a second filter for the registry action of interest:

Internet not working yet network is connected.-pm4.png


Start the data collection process.
(Use the same magnifying glass button/icon that you see in screenshot #1.)

Manually change the DNS setting back to automatic.
Then let's see if Process Monitor can find the app that changes it back to 127....


If I use the Windows interface to set the 127... IP as the DNS value, then I see this:

Internet not working yet network is connected.-pm5.png


Hopefully, these steps will find the offending app on your computer. Unfortunately, there is a chance that the offending app calls another app to do that actual change to the registry and/or the offending app hides itself from Process Monitor.


My System SpecsSystem Spec
Reply

 Internet not working yet network is connected.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Browser not working but internet is connected
Ok so I have a fairly new computer that had Vista on it. I got the free upgrade and upgraded to Windows 7 Home Premium. I've been using 7 for about 3 weeks now with no problems at all. Then out of nowhere approx 3-4 days ago, the internet doesn't seem to want to cooperate. Once in a while web pages...
Browsers & Mail
Connected to Network, No Internet Access
Dear Friends, I'm sure you've seen this post ump-thousand times, but I no previous threads were able to guide me to a solution, so here we go once again. I moved to Mexico City a month ago and the apartment that I am renting came with wireless internet installed. Until two days ago, the...
Network & Sharing
Internet connected but not working
Hi, I have my internet connected long storty short, I reset my router last night, it reset to default settings I got the new password, I'm connected on my Windows Vista computer laptop my desktop computer, all working fine, but on my Windows 7 laptop its connected I can go to google, and windows...
Network & Sharing
Connected to network but no internet access
Hi All I have recently upgraded my desktop from xp to win7. Everything is fine and i love the new windows but unfortunately i am having problems connecting to the Internet. I can connect to the network through wireless no problem but it says that there is no internet access. I have one other...
Network & Sharing
Network Resources Can't Be Connected, But Can Use Internet
Hello, I have a windows 7 system that can connect to the internet and do regular net surfing and all. I connect it to the domain of my company and everything join as it usually does and no problems. After the reboot and try to test if I can connect to a resource drive on the network it just sits...
Network & Sharing
Having it connected to the network but not internet
Hey guys, I have setup a spare computer that i have had at home as a small home server. Now, it's not a normal home server. It's a computer that i has iTunes open all the time and shares the music as a library and then my family can connect via the network and gets songs they would like. I...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:31.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App