Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet connection but cannot load browser windows

16 May 2014   #1
StephenSchneide

Windows 7 64bit
 
 
Internet connection but cannot load browser windows

So my computer says that I have internet connection (excellent signal strength), but if I try to use a browser or even a game launcher it will timeout. I have ran cmd and tracert to google and ping Google. Both suggest that the connection works. I am desperate for help. Restarting doesn't work and all other devices on this network work just fine only one device has issues


My System SpecsSystem Spec
.
16 May 2014   #2
TheCyberMan

Windows 7 Ultimate x64
 
 

Hi from Sevenforums,

Can you post all the information asked for below:

Basic Requirements Before Posting your Networking Thread
My System SpecsSystem Spec
16 May 2014   #3
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by StephenSchneide View Post
So my computer says that I have internet connection (excellent signal strength), but if I try to use a browser or even a game launcher it will timeout. I have ran cmd and tracert to google and ping Google. Both suggest that the connection works. I am desperate for help. Restarting doesn't work and all other devices on this network work just fine only one device has issues
Winsock entries tells Windows 7 how to access your network services. Additionally, your TCP/IP protocol can be corrupted. The TCP/IP protocol is a stack of 4 layers that includes several transport layers, but when this stack is corrupt you will constantly have connectivity issues.

Just open an elevated command prompt and type or copy the first command into command prompt and hit enter. Do the same thing for the second command to reset TCP/IP.
netsh winsock reset catalog (reset winsock entries)

netsh int ip reset reset.log hit (reset TCP/IP stack)
My System SpecsSystem Spec
.

Reply

 Internet connection but cannot load browser windows




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
No browser internet connection--Have internet access (Tried everything
Toshiba Laptop with W-7 Owner uses only for email, etc. Has no internet connection with IE, Firefox, Chrome in NORMAL mode. Have a connection, ipconfig OK, can Ping sites. Have a connection with all browsers in SAFE Mode. (Disclaimer-am IT for my own small SOHO PC business, been a member here...
Network & Sharing
Internet connection. But browser won't load pages.
This happened abruptly. One minute it was working fine then just nothing. I've done the winstock reset which worked and I able to browse anything quickly as normal. But every time you had to reset it when you turned the PC on. Now resetting the winstock won't get me back online. Done DNS flush...
Browsers & Mail
Laptop says connection to internet, however cant even web browser
Hello everyone, to start off this is a wifi problem, with one router about 3 weeks ago it started I cant stay connected to the internet to web browser or play game or just about anything, however people right next to my on their laptops can do everything fine. Also this only happens with the...
Network & Sharing
Windows 7 internet connection, but no working browser
Hello All, I know this is a pretty old problem, but I can't seem to get the below solution to work for me. 1. Click start, type cmd in the Start Search box, right-click cmd.exe, click Run as administrator, and then press Continue. 2. Type netsh winsock reset at the command prompt, and...
Network & Sharing
Have internet connection but can't use browser and several programs
On a Laptop with Windows Home Premium (Acer OEM) I have Windows Defender installed. Then downloaded AVG Antivirus around 1:st week of August. After the end of trial period AVG asked me if I want to upgrade to paid version or remain using free version with restricted options. I chose to keep the...
Network & Sharing
Slow Browser or Internet Connection?
Hi guys, I have a problem with accessing the internet. I have a 4MBit/s broadband connection, which I have tested and it is exactly 4 MBit/s. When I open up any browser (Opera, IE or Winfox/Firefox) it takes about 5 seconds for the google homepage to appear. This seems too slow to me, but maybe...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App