Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: NIC Metrics Issue - Internet Connected yet no response from websites

20 May 2014   #11
TheCyberMan

Windows 7 Ultimate x64
 
 

You would set the metric interface under Internet Protocol ipv4 under advanced remove the checkmark from Auotomatic Metric and put your own metric setting in there.

Leave 32 as normal and 20 change to 40.

It should work but #windows can be funny.

Check your Windows by doing a route print set similar to those.


My System SpecsSystem Spec
.
20 May 2014   #12
jvamos

Windows 7 Ultimate x64
 
 

Hey again Cyberman,

Thanks again for your help. Does anything look odd in this route print?

Code:
===========================================================================
Interface List
 21...e8 94 f6 02 61 7c ......Realtek PCIe GBE Family Controller #3
 19...00 a1 b0 00 1f 46 ......Realtek RTL8139/810x Family Fast Ethernet NIC
  1...........................Software Loopback Interface 1
 16...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
 13...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
 15...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #3
===========================================================================

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0  192.168.168.168  192.168.168.110     20
          0.0.0.0          0.0.0.0      192.168.1.1     192.168.1.48     51
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      192.168.1.0    255.255.255.0         On-link      192.168.1.48    306
     192.168.1.48  255.255.255.255         On-link      192.168.1.48    306
    192.168.1.255  255.255.255.255         On-link      192.168.1.48    306
    192.168.168.0    255.255.255.0         On-link   192.168.168.110    266
  192.168.168.110  255.255.255.255         On-link   192.168.168.110    266
  192.168.168.255  255.255.255.255         On-link   192.168.168.110    266
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link      192.168.1.48    306
        224.0.0.0        240.0.0.0         On-link   192.168.168.110    266
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link      192.168.1.48    306
  255.255.255.255  255.255.255.255         On-link   192.168.168.110    266
===========================================================================
Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric
          0.0.0.0          0.0.0.0      192.168.1.1       1
===========================================================================

IPv6 Route Table
===========================================================================
Active Routes:
 If Metric Network Destination      Gateway
 13     58 ::/0                     On-link
  1    306 ::1/128                  On-link
 13     58 2001::/32                On-link
 13    306 2001:0:5ef5:79fd:c43:24cd:3f57:5791/128
                                    On-link
 13    306 fe80::/64                On-link
 13    306 fe80::c43:24cd:3f57:5791/128
                                    On-link
  1    306 ff00::/8                 On-link
 13    306 ff00::/8                 On-link
===========================================================================
Persistent Routes:
  None
My System SpecsSystem Spec
20 May 2014   #13
TheCyberMan

Windows 7 Ultimate x64
 
 

The gateways have changed place should have shoiwn that first lower metric being first. The metric is different.

Does it work?
My System SpecsSystem Spec
.

21 May 2014   #14
jvamos

Windows 7 Ultimate x64
 
 

I did a route /F and rebooted and reset the secondary switch. I then set the metrics as you had described, the route print doesn't match the metrics I set per se. But now the console stays attached and the internet works. It's a bit slow to get a response from websites but it works! Thanks so much. I was under the impression metrics were hard and fast but I guess they are calculated?
My System SpecsSystem Spec
21 May 2014   #15
TheCyberMan

Windows 7 Ultimate x64
 
 

A reset of the switch or a re-boot of the switch would be neccessary for the new configuration which is on Windows would go thru to the switch.

Glad all is fixed. I have been a help to you.

A bit slow on the second switch you reset to default settings make sure you have the ethernet setting either 10/100 Fast ethernet or 10/1000 Gigabit ethernet.
My System SpecsSystem Spec
26 May 2014   #16
jvamos

Windows 7 Ultimate x64
 
 

The switch was reset, it is only 10/100 but it isn't internet facing. The issue has returned unfortunately today.

I am wondering if it is due to some automatic configuration of the routing. Is there any way to go through and specify the routes?
My System SpecsSystem Spec
26 May 2014   #17
TheCyberMan

Windows 7 Ultimate x64
 
 

Take the switch out of the equation for testing. Connect to the router directly. I am assuming ypou have a router.
My System SpecsSystem Spec
26 May 2014   #18
jvamos

Windows 7 Ultimate x64
 
 

Yes, I just attempted this it seems stable again. Just making sure, doing some testing.

What is the difference between DHCP and switching and how can switching have a bearing on if a interface follows the gateway or not?
My System SpecsSystem Spec
26 May 2014   #19
TheCyberMan

Windows 7 Ultimate x64
 
 

You have DHCP setting on a managed switch if computers have DHCP assigned "obtain a IP address automatically" then you should have DHCP client tiurned on on a managed switch so it can receive an IP address from the router.

A switch can have its own DHCP as well suggest you do some reading on swicthes.
Network switch - Wikipedia, the free encyclopedia
My System SpecsSystem Spec
26 May 2014   #20
jvamos

Windows 7 Ultimate x64
 
 

I was always under the impression switches worked off of mac addresses. I am going to check but I am fairly certain my switch isn't serving DHCP as I would have way more difficulties. I will try and find a way into the switch if there is a GUI.
My System SpecsSystem Spec
Reply

 NIC Metrics Issue - Internet Connected yet no response from websites




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Desktop WIFI Internet Issue - Connected, but Slow/Dropped Internet
I've been battling this particular issue for a couple of weeks now without much success. I have a custom built desktop where my WIFI connection will deteriorate to the point where internet (and gaming over Steam, etc...) will be either painfully slow or unable to load pages at all. Windows claims...
Network & Sharing
'connected' unable to pull up websites, use skype, outlook, etc.
Okay so. This is the strangest problem I've ever encountered in my entire usage of computers, by far. I download a lot of game related software, many of it mods or system files to assist with the games interior files or working of other programs or the game itself. I have no idea if it is...
Network & Sharing
Connected to internet but browser won't retrieve websites
Running Acer Aspire one, Win 7 starter, IE. While downloading Bittorrent I acquired several nasty programs. The two most insidious are v9.com and YouTube accelerator. I have tried normal uninstall but rather then removing these programs they now do not show up on the list of programs, but still...
System Security
Connected to the internet but cant browse websites
I have an HP laptop and i can connect to the network both with wireless or wired, but i cant browse websites. I've tried connecting from several different locations and i get the same result. I took it to Best Buy and they said "its broke and they cant help me". Anyone have any suggestions for me?...
Network & Sharing
Internet Connected but websites unavailable.
Hello everyone. My problem is that my internet only partially works. I am able to connect to the internet and I can see packets are being sent. P2P sharing works, steam can log on and the chat works, I am also able to play games online. (owned some people in MW2). Now my problem is that any and...
Network & Sharing
3 USB dongle connected but cannot display websites
My new laptop is a Toshiba L500 Satellite with Windows 7. I tried using my Three dongle (which I have had for 3 months now and works perfectly fine on my old laptop with Windows XP) - it managed to install and connect as normal. But it wouldn't display any websites other than the Three home page,...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App