Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Extremely slow LAN connection between 2 W7 PCs

28 May 2014   #1
ChrisPbass

7 Ultimate 64 bit
 
 
Extremely slow LAN connection between 2 W7 PCs

I have 2 computers connected through a Linksys SE2500 (http://www.linksys.com/en-apac/products/switches/SE2500/). It's either CAT 5e or 6. There is 20 feet of cable total, maybe.
The 2500 is connected to another router.
The PCs are W7 home and W7 pro. Working off the home PC to the pro PC is amazingly slow. We're talking 50kb/s. Yes...KILO. Trying to navigate folders is painfully slow. If I go to the pro and copy to the home machine it's fast.

It did not used to be like this...obviously I changed something but I'm not sure what it was.

Both PCs have MS Sec essentials. Connection to the 'net is fine.

I started a new thread because the fixes on other threads didn't work for me.

The home PC has a USB 2.0 to ethernet gigabit adapter. The pro machines a realtek GBe motherboard port.

I turned off RDC, speed and duplex on auto.
I pinged the pro from the home and no packet loss.






My System SpecsSystem Spec
.
29 May 2014   #2
MilesAhead

Windows 7 32 bit
 
 

I would go into Device Manager and try to find the USB 2.0 that has the adapter. Look in the properties for anything weird. Also I would turn off all AV and Firewall while messing with the settings until it acts normally.

Also the adapter on the home machine might have lost optimizations such as data buffer settings, cpu offloading(if it has it.) Once I get that stuff working I try to make notes or screen shots because it's easy to forget which settings you used together to get the best throughput. Seems on rebooting sometimes these things decide to change on their own accord.
My System SpecsSystem Spec
14 Aug 2014   #3
ChrisPbass

7 Ultimate 64 bit
 
 

Miles, you think I should just mess w/settings and try to find one that works?

I have removed RDC and turned off autotuning on both machines. I've left IPv6 because I'm not sure if it's needed or not
If I have the 7 Home Premium (7 H P) speed on 1 Giga and the 7 Pro (7 P) on 1Giga then I get 40 Mb/s from the HP to the P but the transfer in the other direction is 6 Kb/s. If I put the 7P on Auto-negot. then transfer speeds BOTH ways are blazingly slow.
With the 7 H P on auto-negot the speed is good one way...but FROM the 7P it's horrible.

I will another PC on the network and see how it works.

MORE TESTING:
I disabled the LAN on 7 H P and used the wireless.

7 H P to 7 P is slow.
7 P to 7 H P is slow.

And more....
Went back to the LAN adapter and now both directions are sloooooooooow.
My System SpecsSystem Spec
.

23 Aug 2014   #4
ChrisPbass

7 Ultimate 64 bit
 
 

Dead thread? No help?

I started getting unknown network errors on the W7home pc w/the usb 2 giga adapter. I think fried or something because the network seems fine without it.

However, the connection is still intolerably slow.

halp!
My System SpecsSystem Spec
23 Aug 2014   #5
ChrisPbass

7 Ultimate 64 bit
 
 

fail. Guess I should have hit refresh ` ~ ~ ~ '
My System SpecsSystem Spec
27 Aug 2014   #6
KEiGHT

Windows 7 Ultimate x64
 
 

Enable Jumbo Frame from Network Card Driver !
My System SpecsSystem Spec
Reply

 Extremely slow LAN connection between 2 W7 PCs




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Extremely slow internet?
Hi, I just reinstalled windows 7 a few days ago. My internet became really really slow after that, with download speed of <1 Mbpsd. Before it was 70 Mbps. Does anyone know how to fix this?
Network & Sharing
Videos Extremely Slow on LAN Connection
Hello all: I am currently living in a dormitory in Germany. I was given a cord to connect to the LAN on the wall, as there is no free wi-fi in this dormitory. A few days ago, Youtube videos and other videos played just fine, as usual. Now, however, it takes 30 minutes to load 5 minutes of a...
Music, Pictures & Video
CD RW EXTREMELY slow read
Sony Optiarc 24x SATA AD-7280S-OEM (No driver updates that I could find on the Sony site.) Took 45 minutes to install Company of Heroes'tov last night! When I try to check the POI or DMA, There is no listing in Device driver under IDE, that allows me to check. This is in win 7 What...
Hardware & Devices
Problem With Wired Internet Connection Extremely Slow Speeds
It all started out a week ago with random times where my internet speed would drop drastically but after about 5 minutes it would go back to normal. Then about 5 days ago I couldn't connect to cable with my cable modem the activity light would just pop green over and over again. I used cycling over...
Network & Sharing
Usb ports extremely slow
So i was working on a midterm paper last night and i put in my sprint card into the usb port after removing it my computer started doing what it is not supposed to do have a mind of its own.... i plugged in my mouse to the usb port it it took 5 min. for it to even recongnize it, i have since...
Drivers
Rapidshare extremely slow
Well I need help, my Rapidshare downloads where like... 200kb/s and no they are of 1kb/s I am running windows 7 professional. all downloads from other places like megaupload or deposit files, etc... are normal speed (200kb/s) any idea? thanks in advance for the help:)
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:01.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App