Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Download Speed MEGA SLOW! :(

02 Nov 2009   #1
CMach08

Windows 7
 
 
Internet Download Speed MEGA SLOW! :(

So, I had the techy at the office upgrade my laptop to Windows 7 Ultimate a few days ago. Well, it seems that while my PC is directly connected to the internet via ethernet wire... It's speed is flawless. No issues whatsoever.

When I go home and use my wireless, the first minute it will respond perfectly fine. 10+Mbps Down/ 2Mbps Up. After that though, it will just SLOOOOOOOOOOOOOW down a LOT! The Up speed will still be high though, which is what gets me confused on what's happening. The download speed will dip down to under 1Mbps.

I'm running a Sony Vaio VGN-NS130E w/ an Atheros AR928X Wireless Network Adapter.

Any other info that is needed to help solve my problem, ask away! I'll try to send it over asap!

Thank you so much and I look forward to all your help. ;]


My System SpecsSystem Spec
.
02 Nov 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by CMach08 View Post
So, I had the techy at the office upgrade my laptop to Windows 7 Ultimate a few days ago. Well, it seems that while my PC is directly connected to the internet via ethernet wire... It's speed is flawless. No issues whatsoever.

When I go home and use my wireless, the first minute it will respond perfectly fine. 10+Mbps Down/ 2Mbps Up. After that though, it will just SLOOOOOOOOOOOOOW down a LOT! The Up speed will still be high though, which is what gets me confused on what's happening. The download speed will dip down to under 1Mbps.

I'm running a Sony Vaio VGN-NS130E w/ an Atheros AR928X Wireless Network Adapter.

Any other info that is needed to help solve my problem, ask away! I'll try to send it over asap!

Thank you so much and I look forward to all your help. ;]
CM

If you arent using homegroup you can disable IPv6, which has several random problems. Its in network and sharing.

We could use more info on the router

Thanks


Ken J
My System SpecsSystem Spec
04 Nov 2009   #3
CMach08

Windows 7
 
 

I disabled the IPv6, and that didn't do the trick.

I ended up calling AT&T UVerse today to see what expert advice they can provide me with, and they were not able to troubleshoot the problem. We ran a test where we turned off all the WIFI connections in the household and ran a speed test w/ the windows 7 laptop. The internet speed ran perfect... When I booted all the WIFIs back up, it dipped back down low [.50mbps down/.51mbps up]. I also ran the test on another laptop [Vista OS] and it ran at perfect speeds.

The router is: AT&T UVerse 3800HGV-B Gateway
My System SpecsSystem Spec
.

05 Nov 2009   #4
aem

Windows 7 Ultimate 64Bit
 
 

Have you paid your Internet Bill?
My System SpecsSystem Spec
05 Nov 2009   #5
zx81

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by CMach08 View Post
I disabled the IPv6, and that didn't do the trick.

I ended up calling AT&T UVerse today to see what expert advice they can provide me with, and they were not able to troubleshoot the problem. We ran a test where we turned off all the WIFI connections in the household and ran a speed test w/ the windows 7 laptop. The internet speed ran perfect... When I booted all the WIFIs back up, it dipped back down low [.50mbps down/.51mbps up]. I also ran the test on another laptop [Vista OS] and it ran at perfect speeds.

The router is: AT&T UVerse 3800HGV-B Gateway
CMach08,

Can you try to turn on every computer one at a time?
Run your speed test, and if it succeeds, turn on the next computer/device and do the same.
Hopefully you can single out the source of your Internet speed problem.

Have a nice day!

zx81
My System SpecsSystem Spec
05 Nov 2009   #6
CMach08

Windows 7
 
 

Quote   Quote: Originally Posted by aem View Post
Have you paid your Internet Bill?
Yes. I don't think AT&T would have bothered giving me technical support initially.
My System SpecsSystem Spec
11 Nov 2009   #7
craigp83

Windows 7 Home Ultimate
 
 

cmach08.

did you manage to find any solution to this?

im finding a very similar problem on my vaio NS10L.

runs fine until someone else is using the wifi, then i lose connection and/or speed..
My System SpecsSystem Spec
11 Nov 2009   #8
technoguppy

Windows 7
 
 

On my laptop, I went to the Device Manager and to the Network Adapter. I selected my Wireless controller properties, I then went to Power Management and changed the

[] "Allow the computer to turn off this device to save power" setting to off (deselected).

My speeds went back to my usual. That's all I did. I'll keep testing, if anything changes I'll repost or edit this post!

Technoguppy
Toronto, Ontario
My System SpecsSystem Spec
13 Nov 2009   #9
CMach08

Windows 7
 
 

What happened was that the driver Windows is installing is a compatible but OLD version. Recently, Atheros had a driver update for their network cards which are not displayed yet on the Sony website.

[wikidrivers.com] Atheros_AR5xxx_AR9xxx_8.0.0.238.exe

Go to the link above and download that driver. It's 8.0.0.238 and it will definitely fix the problem. I hope this works out for you. This is only an update for the Atheros Wireless Drivers! Now, I can officially say that I love Windows 7... minus that hick-up. ;P
My System SpecsSystem Spec
13 Nov 2009   #10
craigp83

Windows 7 Home Ultimate
 
 

hey thanks cmach08...

i've installed the driver you linked to and it looks good so far. barring any issues to come, i think my love affair with win 7 is back on track.

thanks again.
craig.
My System SpecsSystem Spec
Reply

 Internet Download Speed MEGA SLOW! :(




Thread Tools





Similar help and support threads
Thread Forum
Very Slow Download Speed on Windows 7
Hey guys, Before I was running Windows 8 and got a download speed of 20-50MB/s average, yesterday I installed Windows 7 and have since been getting a download speed of 0-6MB/s. This is on the same laptop in the same location. I tried booting it up into Safe Mode with Networking and tried a...
Network & Sharing
difference between the download speed and internet speed?
hi! i just wanna ask between the difference of the download speed and the internet speed. because i have a 1.5mb connection i tried at speedtest and when i download i always get a 190-200kbps rate. so its not actually 1.5mb in my download speed even my internet speed is 1.5mbps. is there and...
Network & Sharing
Slow download speed on 64 Bit
Yeah i'm having trouble with my dell laptop. My download speed is freakishly slow! On my other laptop, my download speed reaches 100KB/s which is normal for my internet speed (1MB). My new speed reaches 5-15KB/s. I actually upgraded from XP to 7. Could someone at least help me? Thanks Windows 7...
Network & Sharing
fast download speed but browseing speed slow.
hallo i have a problem last 1 week.my downloas speed well..but browseing speed slow.i playing online games.watch movie. its soo low its too pain full.i cant under stand why?..i am from srilanka.internet line ADSL.. prolink router..512KB/s line..plz help me.
Network & Sharing
Win 7 slow download speed
Windows 7 Home Premium x64 Linux Mint 10 Julia x64 Both tests are taken from the same machine, same everything, besides OS.
Network & Sharing
Download Speed really slow
Okay I am having a problem with my wireless download speed. I have a desktop pc that has windows 7 pro installed. I purchased two different wireless pci n cards and both have the same problem. My download speed is terrible. On speedtest.net I get maybe 2 mb/s. My upload speed is normal, hovering...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App