Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow broadband speed on Win 7 Home Premium

17 Oct 2014   #1
sn72

Windows 7 Home Premium 32 bit
 
 
Slow broadband speed on Win 7 Home Premium

In the last 6 months I wiped my hard drive on an older Dell computer (used to have Win 98!) and did a clean install of Win 7 Home Premium. This is one computer on a network of 3 all going through a wired Belkin router but I'm getting 18 mbps on the other two computers and only 3 mbps on this computer as tested on speedtest.net. The other two computers are running Windows Vista. I've switched cables to eliminate that as a potential problem but nothing changed. AVG is my virus protection but I do not have the firewall activated with that program. Windows firewall is activated. As far as I can tell this computer runs perfectly otherwise....just slow internet speeds.

Any suggestions on how to troubleshoot this?


My System SpecsSystem Spec
.
17 Oct 2014   #2
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

If this computer was of the Windows 98 vintage it is fairly old & may not really be capable of running Windows 7 properly.
Did you check if it was compatible beforehand.
My System SpecsSystem Spec
17 Oct 2014   #3
lehnerus2000

W7 Ultimate SP1, LM18 MATE, W10IP VM, W10 Home, #All 64 bit
 
 

Did you also install the latest drivers for your Network Interface Card (NIC)?
My System SpecsSystem Spec
.

17 Oct 2014   #4
sn72

Windows 7 Home Premium 32 bit
 
 

Ranger 4 - I did check the resource requirements for loading Windows 7 and this cpu has more than enough to handle the new operating system. And like I mentioned in my 1st post it is operating just fine in every other way....it is just my internet speed that is a problem.

lehnerus2000 - yes I have checked for updated drivers for my network interface card and it says I have the latest driver.

Both good suggestions, thanks!
My System SpecsSystem Spec
17 Oct 2014   #5
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Is your Belkin router connected to this computer via a USB cable. If so this computer may have USB version 1.0 which would certainly limit the speed.
This Wikipedia website supplies details of USB versions, when they were released & the sort of speed that might be expected from them.

USB - Wikipedia, the free encyclopedia
My System SpecsSystem Spec
18 Oct 2014   #6
lehnerus2000

W7 Ultimate SP1, LM18 MATE, W10IP VM, W10 Home, #All 64 bit
 
 
Uninstall Device

Another thing you could try is to totally uninstall the NIC and let Windows reinstall it again:
  1. Locate it in the Device Manager
  2. Right click on it and select Uninstall in the Context Menu
  3. Make sure that you select "Delete the driver software for this device"
  4. Restart Windows
Slow broadband speed on Win 7 Home Premium-delete-device.png


My System SpecsSystem Spec
20 Oct 2014   #7
sn72

Windows 7 Home Premium 32 bit
 
 

Ranger 4 - My router is totally connected with ethernet cables

lehnerus2000 - I'll try deleting and reinstalling the NIC. Thanks
My System SpecsSystem Spec
20 Oct 2014   #8
sn72

Windows 7 Home Premium 32 bit
 
 

lehnerus2000,

That worked! I uninstalled the NIC and rebooted. Windows picked it up and installed a driver and I just checked my speed. It has gone from 3 mbps to 18 mbps! What I don't understand is that I had already checked for an updated driver for the card and windows told me I had the most current driver. Can you explain to me what happened and how it changed?
My System SpecsSystem Spec
20 Oct 2014   #9
lehnerus2000

W7 Ultimate SP1, LM18 MATE, W10IP VM, W10 Home, #All 64 bit
 
 
Install Glitch?

Quote   Quote: Originally Posted by sn72 View Post
lehnerus2000,

That worked! I uninstalled the NIC and rebooted. Windows picked it up and installed a driver and I just checked my speed. It has gone from 3 mbps to 18 mbps! What I don't understand is that I had already checked for an updated driver for the card and windows told me I had the most current driver. Can you explain to me what happened and how it changed?
Glad to hear that my suggestion was helpful.

I'm not sure why that trick works.
I assume that the driver install glitched (at some point during the process).
In your case, it obviously succeeded in changing your driver version number though.

Remember to make a system backup image now that everything is working.

Tutorials
Backup Complete Computer - Create an Image Backup
Imaging with free Macrium
My System SpecsSystem Spec
20 Oct 2014   #10
sn72

Windows 7 Home Premium 32 bit
 
 

Thanks!
My System SpecsSystem Spec
Reply

 Slow broadband speed on Win 7 Home Premium




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 Home Premium 64-bit SP1 slow startup
Hey guys, I'm in a Computer Repair class, and I've been given a project that's a little over my head. A client came in and dropped off his Toshiba Satellite C855D laptop, saying the startup time is very slow. I timed the startup time at 7 minutes. The start up time break down is: from button push...
Performance & Maintenance
Very slow to startup with Win 7 home premium (HP TouchSmart)
I bought 2 new computers, both HP windows 7 home premium, TouchSmart all in 1 computers. 1 works perfectly and the other takes about 10 minutes to get past the black screen that says "Starting Windows", once it does, the computer seems to run fine. It is still under factory warranty until Sept....
Performance & Maintenance
Post upgrade: Win7 Home premium, Extreme speed issues.
Alright: I'll divide this into sections and explain everything I've been dealing with and done in the last few days. To be blunt, I'm out of ideas and I need help. Section 1: pre upgrade Pc stats: Intel DBX38BT motherboard Intel core 2 quad Q9300 processor Nvidia 9800 gt 4gb of OCZ...
Performance & Maintenance
Home wireless network speed so slow
Hi all. I bought a new laptop two days ago and I setup filezilla server on my PC so I could share files between my laptop downstairs in my house and my desktop PC in my bedroom. When I first set it up it was great, getting the normal speed you would expect from a wireless n connection. Today no...
Network & Sharing
Connection Speed Problems - Windows 7 Home Premium 64bit
Greetings, all. I've just bought a brand new computer, set it all up, gotten the drivers sorted, but there's a problem. Even with all the latest Firmware and Drivers, my router adapter (Netgear WPN111) does not seem to work beyond 200kb download speed on actual files with a 10MB connection. ...
Network & Sharing
*************** Premium DL Speed Slow
Hey guys, I recently installed a Windows 7 Enterprise x64 on my PC, and now my RS.com DL speed sucks. Before on my Vista it was around 800 KB/s, and now its around 300 KB/s. Any tweaks for Windows 7 to increase download speed?
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App